• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 509
  • Last Modified:

Why can't I reach an IP when both my Internet and the remote location's Internet are using the same ISP?

I have a client who is running Windows 2011 Standard.  I use RWW to access the server.  They are also using Exchange 2010 to host their email.  I have had no problems connecting from anywhere until I recently changed my ISP to the same ISP they are using.  We both have static IPs.  Now I cannot access the RWW page (says page not found), they cannot email me (I'm using exchange 2007) and I cannot email them... we get a message that says the delivery was delayed.  If I open a browser and type their IP address I get page not found... instead of the default IIS7 splash page.  If I use another ISP I can hit everything fine.  If I ping their URL for the RWW it resolves to an IP.  If I tracert to their ip I am able to hit my router and everything after times out... however I can tracert google, microsoft, cnn, etc fine.

Our IPs are two digits away from each other, let's say their IP info is:

IP: 74.125.226.224
Subnet: 255.255.255.0
Gateway: 74:125.226.1
DNS: 8.8.8.8

Let's say My IP info is:
IP: 74.125.226.222
Subnet: 255.255.255.0
Gateway: 74:125.226.1
DNS: 8.8.8.8

I am fairly sure the reason I can't see anything is because we are on the same subnet with our ISP...but I would really like to know why that is.  I don't know a whole lot about networking outside the local network.
0
tgustaf
Asked:
tgustaf
  • 9
  • 3
  • 3
  • +3
1 Solution
 
SuperTacoCommented:
it could be or any reason, but most likely the line to the demarc on the other side may be down.   You also may need to change public Ip's, NAt and routes in your firewall/router.
0
 
tgustafAuthor Commented:
Both networks are having no trouble getting to any website or using any other internet based applications, or sending email to anywhere other than to each other.  And if I unplug my connection to this ISP and plug my other ISPs connection in there is no problem... so it appears to be something specific to this ISP and specific to having those static IP settings.  I also had my home connection changed to this ISP and at first I had a dynamic IP and everything worked fine, but they gave me a static IP and everything instantly stopped working with respect to connecting to either my network or my clients.  My home IP is two digits away from my office's... subnet and gateway are the same too.
0
 
QlemoC++ DeveloperCommented:
See the subnet info? Both IP seem to come from the same subnet, as 74.125.226.224/255.255.255.0 is 74.125.226.x . Hence the gateway isn't involved, traffic is just "blown out" thru the pipe, instead of performing routing.
Change the subnet to something more suitable   - which you can't - you need to be able to address the .1 :( -  , or create an expicit route to each other site using the gateway, that is
    74.125.226.224 / 255.255.255.255  via 74.125.226.1
and
    74.125.226.226 / 255.255.255.255  via 74.125.226.1

Your ISP has a rather strange setup. I would call them, and demand they solve the issue for you. It is their fault, so they have to provide a workaround or solution.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
nativevlanCommented:
You need to contact your ISP and explain the situation. There must be some type of security setup on their network that will not allow communication between hosts on the same subnet. They will probably just give you another static IP and send you on your way.
0
 
tgustafAuthor Commented:
What do you mean by "blown out" through the pipe?  I think you are correct I am just trying to understand it.
0
 
murgroupCommented:
You need to add a static route in your firewall to their IP address. I had this same problem with servers in a datacenter on different IP's and firewalls. After adding the static route all worked fine.
0
 
tgustafAuthor Commented:
If it were a firewall issue...wouldn't it be present with the other ISP connection as well?
0
 
murgroupCommented:
Sorry bad explaination but Qlemo and I are saying the same thing. Add a static route in your firewall should work. You might have to do the same on the client end to get bidirectional traffic working.
0
 
tgustafAuthor Commented:
I'm a little confused.  If my router/firewall can't get to their IP... how is telling my router/firewall to direct traffic to their IP going to solve it?

Again I don't understand much of this after it leaves my network so please bear with me.
0
 
nativevlanCommented:
It's not, you need to contact your ISP. Again, they probably have the equivalent of private vlans enabled the device you are connected to, effectively disabling host to host communication on the same subnet. They either need to disable this for your connections (unlikely), or get you on another subnet.
0
 
murgroupCommented:
I'm just relaying my experience (exactly the same issue) with my server and my customers server on the same public IP range and subnet. There are both in a datacenter and adding a route to there static IP fixed my problem.
0
 
rochey2009Commented:
you won't route to the other address because they are on the same subnet. Is your subnet mask correct?
0
 
nativevlanCommented:
Yes, he is able to access other web pages.
0
 
rochey2009Commented:
But he can't access the other client's devices because his router thinks that they're local to him.
0
 
QlemoC++ DeveloperCommented:
Exactly. Both locations and the default gateway appear to be on the same network. Traffic targeting the other site is not forwarded to the ISP. Traffic for the same network, determined by the subnet mask, is just sent out thru the network card, assuming it is physically connected to the same network (somehow). Any address outside of the LAN will be sent to the default gateway, which is at your ISP.

Again, http:#37012153 is the answer. Add the static route to the other location on each site, with the ISP router as gateway. That overrides the behaviour not to route "local" traffic for that specific IP address.
0
 
tgustafAuthor Commented:
Ok...so (remember I'm a noob here)  in my router I go to advanced routing and create a static route with the following information (with the correct IP and gateway of course):

 static route
0
 
tgustafAuthor Commented:
Well... that solved one issue.

I can now view the IIS7 default page when I put the IP in my browser... however... I still can't get to the RWW page nor send email to them.

Would I need to do some sort of static route in my server somewhere as well?
0
 
tgustafAuthor Commented:
So if I change the subnet of my local network... that should correct the problem right?
0
 
QlemoC++ DeveloperCommented:
Did you make above change to both sites?
0
 
tgustafAuthor Commented:
I did make the change and I also found a problem where I hadn't updated my dns settings at my registrar so I was still pointing to the old IP of my other ISP for RWW and Mail...which is why they weren't working.

So the static route did solve the problem... but I feel like it's more of a workaround... because if I come across someone else with the same ISP and a static IP...I'm going to have to add static routes to their equipment too. Seems to me there ought to be a way that we could fix it to make it work all the time without adding a pile of individual static routes.

It's a small local ISP... so they're working with me on this.
0
 
tgustafAuthor Commented:
Thanks for all the help on this.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 9
  • 3
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now