• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 491
  • Last Modified:

Access List Box - single click event firing only on double-click

OK - hopefully this is easy - I have code in the Click (not double-click) event of a list box in Access (2007). It is only firing when user double-clicks an item. This causes confusion, since if you click once, you select a different item, and then the displayed information is out of sync. Thanks!
0
terpsichore
Asked:
terpsichore
1 Solution
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
Not quite seeing how that could happen  ... Can you post the code you have in the click event?

mx
0
 
Swapnil NirmalManager, Audit AnalyticsCommented:
please post sample access with code
0
 
plummetCommented:
Hi,

Have you ever had any code behind the double-click event? I have sometimes had trouble with Access not 'registering' my code changes if I've made changes in the module rather than via the events list of the properties box.

But we still need to see some code!

0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Mike EghtebasDatabase and Application DeveloperCommented:
First thing before any code add the following lines in there respective events and test them to see if click event works for the list box:

MsgBox "You clciked."

MsgBox "You dbl-clicked"
0
 
terpsichoreAuthor Commented:
I am not at my laptop - but wanted to reply. As a matter of fact this code was until recently in the double click event and I moved it to the click event...
0
 
plummetCommented:
Aha - I thought that was likely. Can I suggest you copy the code out, then delete the click and double-click events from code, and go to the properties window for the listbox. Then double-click  'on click' in the event tab, select event procedure and add the code back in there.

I hope that might help...
0
 
terpsichoreAuthor Commented:
Your initial comment led me to suspect there was some corruption - I decompiled and recompiled, and the problem (along with a few other small things) was solved. Thanks to you and the other respondents for great ideas.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now