[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 675
  • Last Modified:

outlook 2003 cached exchange mode performance tweak

Hi Experts,

my company has a new branch office and we have implemented the outlook cached exchange mode for all users in this branch office as there is no any exchange server setup in this branch office.

However, the performance of the cached exchange mode is not like what I expected, users keeps complaining about email delay for few to ten plus minutes.

I tried to set the cached exchange mode timers to 1 in group policy but still don't have any performance boost.

Is there any other way to tweak the speed? I was wondering if there is any setting that can force outlook to check inbox more frequently then other folders.

thanks!
0
nokyplease
Asked:
nokyplease
8 Solutions
 
Chris MillardCommented:
How do you connect to the office with the Exchange Server? You COULD try using RPC over HTTP for the remote users.
0
 
SommerblinkCommented:
What version of Exchange are you using? There are some incompatibilties between Outlook 2003 and Exchange 2010, but the ones that come to mind are when you are in Online mode.

As roybridge mentions, how are the clients communicating to the Exchange server, over RPC over HTTP or TCP/IP? You can determine this by opening up the Account settings in Outlook, go to Properties for the Exchange server, then click on More Settings on the new dialog box. From here, go to the Connection Tab. Is there a tick at the bottom next to “Connect to Microsoft Exchange using HTTP”? If so, click on “Exchange Proxy Settings…” button below.

Is both Fast networks and Slow networks ticked?

(Please note, I took this from Outlook 2010. I believe some of the names are changed in my version since 2003, but it should still be obvious.)

If “Connect to Microsoft Exchange using HTTP” is not ticked, then you will need to work with your Exchange administrator (are you him as well?) to figure out what the settings need to be for the Exchange Proxy Settings. Typically this is the SAME FQDN that you would use to connect to Outlook Web Access.

More questions: Is there a firewall between the two branches? How are the firewall rules configured between them? Do you have any other remote sites that are experiencing this same problem?

How much bandwidth is there between the two sites, and how many users are at the remote site.
0
 
nokypleaseAuthor Commented:
I think the connection is using TCP/IP as all the "conn" column in the "Exchange server connection status" dialog box shows TCP/IP. Also the box "connect to microsoft exchange using HTTP" is unticked.

about the network, it is a 10M mpls with latency about 130 ms (i get this from a ping test from branch office pc to a server in the main office)

there is a firewall in between offices but it has been configured to allow all traffic to the mail server.

This is the first remote site that usse cached exchange mode so we cannot compare with other site.

thanks.  



0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Hendrik WieseCommented:
Hi,

With regards to your first question about tweaking the speed, verify the following:
1. Go to start > control panel > mail
2. Click the Email Accounts button
3. Select the active profile and click the change button
4. Now select the More Settings button
5. Go to the Connections Tab and click on the Exchange Proxy Settings button
6. Ensure that ONLY "On slow networks, connect..." is selected as seen in image below:
 Outlook Proxy Settings
With regards to your second question "setting that can force outlook to check inbox more frequently then other folders" - Unfortunately this is not possible
0
 
Hendrik WieseCommented:
You can also change the synchronization timer values by creating and by modifying the following registry keys and values under the HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\11.0\Outlook\Cached Mode registry key:
Upload=dword:0000000f (default is 15 seconds).
Download=dword:0000001e (default is 30 seconds)
Maximum=dword:0000003c (default is 60 seconds)

Reference
0
 
Hendrik WieseCommented:
Just a thought from the same reference site:

Order of folder synchronization in Outlook 2003
When Outlook 2003 synchronizes with an Exchange Server 2003 computer, Outlook 2003 uses an intelligent learning algorithm that is transparent to you. This algorithm puts higher synchronization priority on the folders that you use most frequently. This behavior gives you an optimal user experience. Outlook 2003 synchronizes folders in the following order (until you have been using Outlook long enough to train a synchronization priority):1.Utility folders (common views, views, and security settings)
2.Calendar
3.Contacts
4.Drafts
5.Inbox
6.All other folders (defined by the user)
7.Sent Items
8.Deleted Items
9.Public Folder Favorites (added by the user)
0
 
nokypleaseAuthor Commented:
I tried to set the timer to all "1" but seems don't have any changes?

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\11.0\Outlook\Cached Mode
0
 
Hendrik WieseCommented:
Have you got all the ones listed below set to 1?

Upload=dword:0000000f (default is 15 seconds).
Download=dword:0000001e (default is 30 seconds)
Maximum=dword:0000003c (default is 60 seconds)
0
 
nokypleaseAuthor Commented:
yes, all set to 1 but still have delay
0
 
Hendrik WieseCommented:
And you have restarted the machine after the values was set?
0
 
nokypleaseAuthor Commented:
yes, restarted, and there still random delay.

Also, if for some reason, the .ost file needs to be removed (e.g, outlook cannot be started), outlook will start caching the mialbox again and during that time, there will be a huge delay. I had tried to use the send or receive group to force auto send/receive per minute, however, this only can help to lower the delay down to 1 minute (the lowest possible setting).

 
0
 
nokypleaseAuthor Commented:
anyone can help?

thanks!
0
 
Hendrik WieseCommented:
If you checked all the settings as suggested then you should have seen a change in behavior. So the next step would be to check your network to ensure that there isn't something hawking the line.
0
 
nokypleaseAuthor Commented:
from out network team, the line is in good condition....

i don;t know what else i can check....

0
 
nokypleaseAuthor Commented:
We found out the delay was caused by the initial sync, is there any way to reduce the delay during the initial sync?
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now