• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 651
  • Last Modified:

The webpage cannot be found

Hi all,

I have a web page that works find when I view it internally, but when I go offsite and try to view it it comes up with http 404 error code.  The web page cannot be found.  I have multiple websites on this server using the same static ip but using host headers in IIS7 and all the others work fine from the internal and external network and this one works fine internally.

I am just wondering what I should be looking for as I am at a bit of a loss.

  • 6
  • 6
1 Solution
Sounds like your DNS records aren't set right for the new site.
chimp153Author Commented:
if i do a dnslookup for the site it comes back with the correct IP address.
Has this site ever worked from outside, or is it new?

Can you PING the server using the domain name?

I couldn't tell from your question, but do all the web pages for that site return 404, or just one page?
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

chimp153Author Commented:
Just this site returns the 404.  All the rest of the sites work fine and they are on the same server under the same inetpub/wwwroot directory.  They are just differentiated via host headers.

And it only returns the 404 externally.
Use NetworkTools.com to do a Tracert to your website to see whether it is getting the right IP address.  This will use an external DNS server rather than your own.


Also check the WHOIS record to be sure it has the right Domain Servers defined,
Also check the web error log for the new web site.
chimp153Author Commented:
The domain is correct because we have a www.coffsccs.nsw.edu.au running on the same webserver and it works fine.

I will check the error log and see what that tool tells me.  thanks
chimp153Author Commented:
I did a trace through the site you provided and it aborted. See below:

TraceRoute to [develsite.coffsccs.nsw.edu.au]

Hop (ms) (ms) (ms)       IP Address Host name
1     0    0    0   -  
2     0    0    0  xe-5-3-0.edge3.dallas1.level3.net  
3     3    0    0  vlan90.csw4.dallas1.level3.net  
4     0    0    0  ae-93-93.ebr3.dallas1.level3.net  
5     32    32    32  ae-3-3.ebr2.losangeles1.level3.net  
6     32    32    32  ae-72-72.csw2.losangeles1.level3.net  
7     32    32    32  ae-2-70.edge1.losangeles6.level3.net  
8     50    35    35  reach-level3-xe.losangeles.level3.net  
9     36    35    35  i-0-1-0-0.1wlt-core01.bi.reach.com  
10     173    173    174  i-0-2-0-0.sydo-core02.bx.reach.com  
11     179    179    179  tengige0-2-0-2.oxf-gw1.sydney.telstra.net  
12     184    191    191  bundle-ether1.ken-core4.sydney.telstra.net  
13     187    179    179  bundle-ether1.ken39.sydney.telstra.net  
14     180    179    179  iinetl1.lnk.telstra.net  
15     186    227    212  te1-4.syd-mas-bdr1.iinet.net.au  
16     180    180    180  te1-2.syd-mas-bdr2.iinet.net.au  
17     179    179    179  te9-1.syd-mas-bng1.iinet.net.au  
18     Timed out    Timed out    Timed out          -  
19     Timed out    Timed out    Timed out          -  
20     Timed out    Timed out    Timed out          -  
21     Timed out    Timed out    Timed out          -  

Trace aborted.

Does this mean that it is not getting past iiNet?  that is who our ISP is.
chimp153Author Commented:
PS:  Our www.coffsccs.nsw.edu.au comes up with the same trace but the site works fine from outside our campus.
I'll keep thinking on it, but I'm baffled.

Do you have any subdomains other than "www" working from that server?  www is somewhat special.

Your DNS records look correct.
telnet to port 80 works ok

do they have same ip address?

1) check bindings
2) network card properties
3) firewall blocking
Make sure there is no .htaccess file in the develsite folder that may be blocking external access.

Eyal:  yes, as I understand it, both sites have the same IP and can both be accessed successfully from within his local network.  I don't see how it could be related to IP as, you say, port 80 works and it is the same port on the same server for both web sites.  Seems to me the problem must be in the web site configuration or web site access control files.
chimp153Author Commented:
I checked the IP bindings and it had our internal IP address whereas the other sites had All Unassigned.  I changed this to all Unassigned and it now seems to be working externally.

I appreciate the help from both of you.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now