Javacript Form Validation

Hello, my index.php's validation is working fine in production server (which is a local server). However, when it comes to live server (in data center), the validation does not work. I am so confused about this. Attached is the code for index.php with javascript validation (it's a form). Experts, help! index.php
LVL 2
rolandmyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mark BradyPrincipal Data EngineerCommented:
Explain a couple of things first.

1: Is the server that is working on your local computer? localhost or 127.0.0.1?
2: The server that is not working is online somewhere? eg: http://www.somewebsite.com ?

3: What exactly is the problem? You have a lot of code in the index.php file and it would be much easier to help you if you could explain a bit clearer what is supposed to happen and what is NOT happening. Is it the PHP validation that is not working or is it javascript validation?

If it is PHP doing the validation then attach the validation script (unless it is in index.php)
If it is javascript doing the validation that's not working, please attach the external javascript function that is not working.

Thanks
0
rolandmyAuthor Commented:
Only the validation part is not working (for live server in data center). It works in localhost and my private server. Just not working in live server. Uploaded a sample in my private server. It can be found at http://www.rolandlai.com/sample/index-add.php?bizid=123456

Click on submit and it's able to validate. Apparently my live server unable to do. Any solution for this headache?
0
maeltarCommented:
Just tested it in FF and it validated fine...

It's not finding a few other files though ....

"NetworkError: 404 Not Found - http://www.rolandlai.com/sample/loginmodule.css"
loginmodule.css
"NetworkError: 404 Not Found - http://www.rolandlai.com/sample/loginmodule.css"
loginmodule.css
"NetworkError: 404 Not Found - http://www.rolandlai.com/images/bg-img-2.jpg"
bg-img-2.jpg
"NetworkError: 404 Not Found - http://www.rolandlai.com/images/701panduan-logo.png"
701pan...ogo.png
POST http://www.rolandlai.com/sample/checksubdomain.php
      
404 Not Found
            264ms      
"NetworkError: 404 Not Found - http://www.rolandlai.com/sample/checksubdomain.php"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

mcnuteCommented:
It seems that you have two validators on the same page the yav and the one between the script tags in the head. Try to work with only one of these.
0
BadotzCommented:
Validation errors abound:

HTML

CSS
0
BadotzCommented:
The strong, silent type, eh?

No worries - glad to help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
JavaScript

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.