Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Exchange 2010 installed partially, but won't open EMC or EMS

Posted on 2011-10-23
9
Medium Priority
?
1,711 Views
Last Modified: 2012-05-12
So I have just installed Exchange 2010 on a 2008R2 server. The install process completed 10 of the 12 tasks successfully, failed on the last 2, and after a restart Exchange services won't load automatically (but will load manually when I tell them to later), and EMC or EMS won't open and fail with the following errors:

EMC error:
Connecting to remote server failed with the following error message: The connection to the specified remote host was refused. Verify that the WS-Management service is running on the remote host and configured to listen for requests on the correct port and HTTP URL. For more information, see the about_Remote_Troubleshooting Help topic

EMS error:
 Connecting to remote server failed with the following error message : The connection to the specified remote host was refused. Verify that the WS-Management service is running on the remote host and configured to listen for requests on the correct port and HTTP URL. For more information, see the about_Remote_Troubleshooting Help topic.
    + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
   eption
    + FullyQualifiedErrorId : PSSessionOpenFailed

The install pre-req's were all completed, the server is fresh, and has only been used as a file server to date.

1 problem may be the domain topology that we are upgrading from:
Originally there was a single Windows 2000 server running Exchange ENTERPRISE 2000.
Then we moved the mailboxes to a Windows 2003 server, running Exchange 2003 STANDARD. This is still running generally O.K, but ultimately we will be moving everything Exchange to the 2008R2/EX2010 box. The 2000 Exchange was uninstalled after all mailboxes were removed, then we demoted the 2000 box to a member server. It is still there, but can be taken down if needed.

This is the point at which the Exchange 2010 install was done.

There is no A/V on the new server or during the failed install, Windows firewall is turned on. All pre-req's were met.

I have done much reading and seem to be heading towards a IIS issue, or permission issue preventing the system accessing something it needs. This is the article I am referring to, but as yet have been unwilling to try it. Thoughts?

http://blog.techgalaxy.net/archives/2322

0
Comment
Question by:Killersmits
  • 4
  • 4
9 Comments
 
LVL 6

Accepted Solution

by:
sumit_arora earned 2000 total points
ID: 37016118
1. Make sure the MSExchangePowerShellAppPool is running. If it is, try recycling the Application Pool and check for errors or warnings in the Event logs.

Also make sure SSL is disabled on the Powershell virtual directory and accept certificate is enabled on Powershell virtual directory.

2. Make sure that the user that is trying to connect is Remote PowerShell Enabled
If the user that is attempting to connect is not Remote PowerShell enabled. To check if a user is enabled for Remote PowerShell, you need to open the Exchange Management Shell with an account that has been enabled, and run the following query.

(Get-User <username>).RemotePowershellEnabled

This will return a True or False. If the output shows False, the user is not enabled for Remote PowerShell. To enable the user, run the following command.

Set-User <username> -RemotePowerShellEnabled $True



3. Make sure WinRM is properly configured on the server.

a. Run WinRM Quick Config on the server and ensure that both tests pass and no actions are required. If any actions are required, answer Yes to the prompt to allow the WinRM configuration changes to be made.

b. Run WinRM enumerate winrm/config/listener and ensure that a listener is present for the HTTP protocol on port 5985 listening on all addresses.

0
 
LVL 14

Expert Comment

by:Radweld
ID: 37016174
To prevent a guessing game. You need to review the setup log to establish what failed and why.

You can find the setup log at <system drive>\ExchangeSetupLogs\ExchangeSetup.log. The <system drive> variable represents the root directory of the drive where the operating system is installed.

The setup log file tracks the progress of every task that is performed during the Exchange 2010 installation and configuration. The file contains information about the status of the prerequisite and system readiness checks that are performed before installation starts, the application installation progress, and the configuration changes that are made to the system. Check this log file to verify that the server roles were installed as expected.

http://technet.microsoft.com/en-us/library/bb125254.aspx
0
 

Author Comment

by:Killersmits
ID: 37021865
Sumit - I recycled the App pool, yes it was running and no it didn't make any difference.

I can't use the Exchange system powershell it doesn't let me do anything as it can't connect to a local exchange server.

I haven't run the WM tests yet, will do today and let you know.

Radweld - Attached is the last part of the Exchange log, where things start to go wrong. Have a look and see if anything famililar jumps out at you. Exchange-erros-start-here.docx
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 6

Expert Comment

by:sumit_arora
ID: 37022576
For the error you are getting while installing sp1 please follow this article
=========================================

http://blogs.msdn.com/b/mohits/archive/2010/05/29/integration-of-project-server-2010-and-exchange-2010-2007.aspx
0
 

Author Comment

by:Killersmits
ID: 37022757
Sorry sumit, I don't follow, what SP1? I haven't tried to install any....for Exchange anyway..
0
 
LVL 6

Expert Comment

by:sumit_arora
ID: 37036658
Sorry, but it was for the error u are getting the in Exchange setup logs.
0
 

Author Comment

by:Killersmits
ID: 37074791
Sumit - Sorry, The version of Excchange I was using was Exchange 2010 with SP1, but I didn't install SP1 after Exchange...

Anyway, I hadn't gotten anywhere with it in the last week. The main issue is that the server it was installed on is our main file server, so I can't restart it during the day, and I lie awake at night fearing I will break it by getting too heavy handed with various fixes suggested that I have been reading about. Anyway this afternoon, I uninstalled Exchange 2010. The uninstall went fairly smoothly once I figured out how to remove the Hub transport connectors to the 2003 box. Once I got that done the rest uninstalled clean. I restarted and tested mail flow from the 2003 box and all looks good.

I have now joined a fresh 2008R2 server to the domain which will have no roles other than those required for Exchange 2010, and will do an install tomorrow to see how it goes. This way I will be able to reboot it whenever I want, as it doesn't do anything else. However it will prove a few things to me once I get the install started, regardless of it being successful, or otherwise. Theis will help me rule out a few theories, and will at least give me a backup exchange server incase my primary (2003) starts giving me trouble, assuming the install works, and I can then pursue the failure of the other install in relative comfort on the original.

I still suspect permission errors to do with the article I posted in my first post. If anyone cares to read it, it matches our upgrade path and problems descibed almost identically, but im too scared to run the script for fear of breaking the AD. Anyone care to comment on this script, and the article/theory in general?

Thanks for your help. I won't close the question as it is still ongoing, and I will keep you up to date.

0
 
LVL 6

Expert Comment

by:sumit_arora
ID: 37151411
Any update on this
0
 

Author Comment

by:Killersmits
ID: 37152075
Yes the Exchange install on the fresh box worked fine. It all installed as expected, and we are able to move mailboxes to it. We haven't however tried to reinstall Exchange on the server we originally had problems with.

I could try installing Exchange again on this server, but I am scared of breaking it, and I don't see any great advantage in havinjg Exchange on that particular box, other than having one less Server. Also this way I have all my roles more evenly spread so if 1 box goes down we don't lose the whole thing.

To be honest I can't see me going back anytime soon to solve this problem. So the points are yours Sumit arora. Thanks again for your help and interest.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Understanding the various editions available is vital when you decide to purchase Windows Server 2012. You need to have a basic understanding of the features and limitations in each edition in order to make a well-informed decision that best suits …
In this post, I will showcase the steps for how to create groups in Office 365. Office 365 groups allow for ease of flexibility and collaboration between staff members.
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Suggested Courses

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question