• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3693
  • Last Modified:

Cannot Eject Quick Stor Cartridge (Server 2008 / RDX quickstor)

Hello experts

Having a bit of difficulty regarding a Server2008 ejecting a tape

The system can see the device in windows explorer - and can write to it fine (we are using shadow protect) but it cannot eject the drive

Its a Tanberg RDX internal SATA drive. RDX mon is version 1.35 and can see the device fine

If i stop the RDX mon service and try to eject the tape via the command line (via free eject - www.freeeject.com) it simply comes back as saying that the device is ready for removal and doesnt eject the tape

I can eject the tape via explorer - but i want to automate this

I tried installing backup assist and creating a backup job to write a file to the drive then eject it - It backed up the test file fine - but also didnt eject the drive

I have another server that uses an external Tanberg RDX quickstor device and the freeeject utility works fine - so Im at a bit of a loss as to why the server doesnt eject the tape

I've tried a vbs script (posted elsewhere on EE - http://www.experts-exchange.com/Storage/Removable_Backup_Media/Q_23641549.html) to eject the tape - but it says that the device is 'in use'. I've disabled RDX mon, Backup assist monitor and indexing on the drive.

Ive used Process explorer to check what handles are open on G:\ and ended all handles (Dell UPS software - what the?) and tried to eject again via command line but still no go

Any other ides?
0
HeronTech
Asked:
HeronTech
  • 2
1 Solution
 
stergiumCommented:
Hello HerocTech.
have you tried killing the windows explorer process?
A restart could be a good idea (if possible of course) .
please feed back
0
 
HeronTechAuthor Commented:
Hello

I have restarted the server and the issue still persists - I cant eject the tape via command line - and I also now cannot eject the drive via windows explorer. It says that the drive was still in use

Process explorer showed that 4 instances of 'system' had locks similar to the following (this is one of them)

G:\$Extend\$RmMetadata\$txtlog\$Txtlog.blf

it also, however had a lock from the shadow protect service. No actual file on the drive. Just the Drive (g:) itself

I stopped the RDXMon service and Shadow Protect service and I was able to eject the drive via free eject (YAY) but I will monitor it to see if it reverts back to its old ways tonight

I've added stops to the RDXMon service and Shadow Protect services to the eject script
0
 
HeronTechAuthor Commented:
Solved myself
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now