Lost Printers in Windows 7

Last week all my printers "vanished" in my 64-bit Windows 7 (version 6.1 Build 7601: Service Pack 1).

Note I just have a locally connected printer, I don't have a network printer.

I had a Dell All-In-One 948 printer installed, and had used it that morning, but in the afternoon when I went to use it, I got a message "no printers installed". I tried reinstalling the driver, the install runs through fine, but at the end when I try to print the test page, I get the message "The Dell AIO Printer 948 printer driver is not installed. Please reinstall your printer driver."

I must have run the installer 3-4 times and it does this each time. I have tried turning the PC off and on again (I turn it off every night anyway).

Also I had the CutePDF printer driver installed, and this has vanished too - I think I had the One Note driver as well, but now I have nothing.

Part of the problem appears to be the Print Spooler service isn't running. It is set to run automatically, but when I go to services after turning on my PC it isn't running. I can start it manually, but it doesn't seem to make any difference.

When I try to print - for example from IE - I get the message "before you can print you need to select a printer, if you need to install a printer..."

Under the "select printer" list it just says "Add Printer".

Under Control Panel/ printers it does show

AIO Printer 948

but when I open it, it is only showing as a scanner.

If I try to scan it just does nothing - and I have to use Task Manager to stop the process.

When cancelling the scan I have got the message

Function Discovery Printer Provider is not responding

Any help in fixing this would be appreciated.
purplesoupAsked:
Who is Participating?
 
ded9Commented:
Close all apps ...run this fixit.

http://support.microsoft.com/mats/printing_problems/


Reboot computer and check.




Ded9
0
 
exceterCommented:
At first, check for viruses, malware
0
 
purplesoupAuthor Commented:
I've got McAfee and Microsoft Security Essentials all running and not reporting anything.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Marc SmetsSystem AdministratorCommented:
Go into Services, look at Print Spooler Properties and go to the Dependences tab.
Make sure all the services in the top box are started

0
 
purplesoupAuthor Commented:
Re: Shamzi - it is dependent on the RPC service, which is dependent on DCOM Server Process Launcher and RPC Endpont Mapper, all of these are running.

ded9 - looks promising - I'll run it and let you know how I get on..! Thanks :)
0
 
purplesoupAuthor Commented:
Well the fixit tool wasn't as useful as I had hoped.

I ran it, and it asked which printer I wanted help with (it spotted somehow that I used to have the Dell 948 driver, CutePDF and One Note all installed).

I told it to fix the Dell 948 problem - it immediately spotted that the print spooler wasn't running and started it, after that it asked me if it had fixed the problem. I tried printing something from the Dell All-in-One Center and again I got the "Dell 948 driver is not installed" message, so I told it that it wasn't fixed, and all it could suggest was taking me to a web page of common printer problems.

http://fixitcenter.support.microsoft.com/Portal/fixit/details/f5c57383-8cc9-445e-b8b7-0eccbde975c9?pid=00426-067-0672265-86782&sid=247940d8-c32b-4801-82de-db9038db69a0

I tried running the fixit tool again, and told it to detect problems - it has just been running for about the last 20-30 minutes just saying "checking for spooler service errors..." so it looks like it isn't going to do anything else.
0
 
ded9Commented:
Uninstall mcafee..reboot and then try to print.



Ded9
0
 
purplesoupAuthor Commented:
You think McAfee might have lost my printers? Have you seen this posted anywhere?

I've tried stopping the McAfee services but it doesn't fix anything.

I'd like a bit of background before going through all the effort of uninstalling McAfee.
0
 
ded9Commented:
Stopping mcafee does not work because it runs in the background that's why i recommended uninstall.

Just a part of troubleshooting step.. if you dont want to try it then lets wait for other suggestion.







Ded9

0
 
purplesoupAuthor Commented:
Just to update with an interesting development.

I had a look at Windows System event log again, and noticed near the message that said the print spooler had stopped unexpectedly ("it has done this 4 time(s)") was one about a memory problem:

Application popup: Windows - Application Error : The instruction at 0x772a7d76 referenced memory at 0xffffffff. The memory could not be read.

So I ran the windows memory diagnostic check - it found nothing wrong - but when Windows restarted after running the check all my printers were back (OneNote, CutePDF and my Delll 948). Unfortunately although the scanning part of the printer worked - and passed in a scanned document onto the computer, printing still doesn't actually work - the documents are queued and don't print.
0
 
purplesoupAuthor Commented:
Well amazingly, following a restart this  morning, everything now appears to be working again - when I started Windows the test page that failed to print yesterday came out of the printer, and I just tried to print with CutePDF, OneNote and on the Dell and everything worked ok.

Just another wonderful Windows mystery...!

Thanks everyone for your help and suggestions.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.