Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1477
  • Last Modified:

how to enter ROMMON in Cisco Router 1721 ?


HI all

i want to enter ROMMON mode in Cisco router 1721 , but when i try to do that the router give me messege says (password recovery function is disabled ) .

i tried to Press CTRL-C (break ) to enter Rommon mode , but still not working ..

note : this router doesn't have Compact Flash like Cisco router 2800 series ...

Please advice me

Thanks
0
Muhammed-Rummaneh
Asked:
Muhammed-Rummaneh
  • 3
1 Solution
 
ipajonesCommented:
see the following link:

http://www.cisco.com/en/US/products/hw/routers/ps221/products_password_recovery09186a0080094773.shtml

I think you need to do <CTRL><BREAK> when connected to the console NOT <CTRL><C>
--IJ
0
 
max_the_kingCommented:
the correct combination is ctrl break and not CTRL-C (break )
0
 
Muhammed-RummanehAuthor Commented:

Thanks for your comments

i tried to press ( CTRL- break ) but the router still doesn't work , and give me message ( Password recovery procedure function

 is disabled )

The Router will drive me crazy , and i will throw it from the window

Please Help MEEEEEE
0
 
ipajonesCommented:
Looks like the router has been configured with the "no service password-recovery" command.

There are only a few methods you can use to recover from a lost password, but all of them destroy the start-up configuration.  Suggest you review the following link which may help you:

http://www.cisco.com/en/US/products/hw/routers/ps274/products_configuration_example09186a00801d8113.shtml

(extracts from the link above)
1. Routers that have nonvolatile RAM (NVRAM) chips can be removed and reseated. The NVRAM is implemented with battery-backed up static RAM (SRAM). If you remove the SRAM, the contents of NVRAM are erased as well as the no service password-recovery configuration. Be sure to use proper anti-static procedures when you handle the NVRAM. Some of these routers are 3640 and 3660.

2. Other routers, such as the 1700, 2600, and 3620, use an electrically erasable programmable read-only memory (EEPROM) in order to hold the configuration. The EEPROM does not erase when you remove it.

3. Another method is to reload or boot the router with console access, and press CTRL-BREAK within five to ten seconds of the Cisco IOS software image decompressing or roughly when the "Image text-base:... " part of the banner begins. You are then prompted to reset the router to factory default (erase start-up configuration).

Suggest you try point 3 above.  Remember you will erase the current configuration, there is NO METHOD of recovering the router with the configuration being retained.

Good luck!
--IJ

0
 
ipajonesCommented:
Did you make any progress with this ?  If not let me know if there any other queries ?
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now