Unidata Phone WPU-7800

Posted on 2011-10-24
Last Modified: 2012-05-12
Hi Everyone,

I recently purchased a Unidata Phone WPU-7800 and I can't figure out how to provision it properly.
I am using Trixbox for my phone system, and I have a tftp server setup on it. all my previous phone I was able to configure the TFTP server ip address on the phone and everything was getting pull from it as long as the config file was existing on the TFTP server. I creaded the config file as mentioned on the admin manual and I also try to configure manually on the phone but for some reason it doesn't get register with my ohone system. what am I missing ?
I tried 0000000000.ini file  for the config and also 00:00:00:00.ini but neither one seems to get pulled from my phone. I also put the firmware in the tftp server and see if the phone would grab it , it does so I know that the tftp works with this phone and that the phone can see the tftp server.

I really need some help on how to create the proper file and have my phone grab it properly . the manual are located there:

Question by:taverny
    LVL 11

    Accepted Solution

    I started to build a config file for these phones. We only have a few of them deployed and thus far I have done the setup through the web interface. I have a text file named as <mac-address>.cfg with no periods or colons in there. The file is a KEYWORD=<value> format such as this:

    ## System Settings
    # Login Account Settings

    I have a job coming up in the next couple of weeks that will deploy 6 of these so I'll be working on the files next week. If you want I'll post an example here when it is ready.


    Author Comment

    Thanks for your reply.
    I tried to follow your instruction and I think I don't need to put the  quotes between the value. Anyway, it seems that It is able to pull the file , but I missing one iportant piece: the Server.
    on my config file i dont' see where to put the server IP
    I don't use proxy , I never had to put Domain name , but I don't see a config for the SIP Server. I assumed that it would use the default TFTP since I can't find another location. So I think this is what is missing. even on the webportal of the phone (unidata) I can't find the settings for that.
    here is my config file for my phone.
    Displayname = DAVId
    # min:0 , max :30 chars
    Phone_Number = 803
    # min:0 , max :30 chars
    User_ID =803
    # min:0 , max :30 chars :authentication ID
    User_Password = 1290
    # min:0 , max :30 chars : authentication password

    1st_Proxy =
    2nd_Proxy =
    # min:0, max : 70 chars : primary sip proxy
    Domain_Realm =
    # min:0, max : 64 chars; Domain Name/Realm
    Register_Expire = 3600
    # min:60 ,max : 86400(sec)

    Assisted Solution

    Well I found my way around, by trial and error. and now it's working . so here is the config file that I used. my SIP is
    I also had to go into the web interface to configure what I needed and download the config file to see the proper syntax so I could put in my common file .
    Attached you will find my common file, mac file and all the command from my phone that are available
    hope it will help you with your project. now I just need to figure some of the settings like the push server not sure what it is for: RTP RTCP, agent under SIP, SDP, VAD, TOS. I know it's outside of the scope of this question. but if you know I would appreciate.
    Thanks for your help.
    David  user.txt e1-common.txt e1-mac.txt

    Author Closing Comment

    my comment has some of the working config file that could be helpful to others

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    There are no good configuration guides for HP-H3C router to LYNC on the web. :( Big statement, but we havent been able to find one yet. We did find the following document useful, but the information was not enough to use H3C router for use as a L…
    Almost all Internet protocol telephones have built-in switches at the back that allow you to connect your personal computer to one port and use the other port to connect your phone to to a Cisco switch.   Why we need to connect the PC to the pho…
    Sending a Secure fax is easy with eFax Corporate ( First, Just open a new email message.  In the To field, type your recipient's fax number You can even send a secure international fax — just include t…
    Internet Business Fax to Email Made Easy - With eFax Corporate (, you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

    733 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now