• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 604
  • Last Modified:

DCOM error on all DC's every time GP updates

Everytime group policy updates on any of our DC's (can be reproduced with a gpupdate /force) the following event gets logged:

Log Name:      System
Source:        Microsoft-Windows-DistributedCOM
Date:          25/10/2011 2:47:57 PM
Event ID:      10009
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      <domain controller>
Description:
DCOM was unable to communicate with the computer <old AppV server we no longer have> using any of the configured protocols.


The server being looked for was setup to try out Microsoft AppV, but we decided not to use it, and got rid of that server (deleted the VM).

I recently removed the computer account from our AD, but I still get that DCOM error on our DC's.  I've checked through our Default Domain and Default Domain Controller GPO's, and I can't find a reference to that server directly (although I don't know much about AppV and I might find something if I knew what to look for?).

So far, I don't think there are any problems caused by this, but I am interested to know why this is occuring, and if anyone has any suggestions on where/how to start looking for the the source of the error.
0
PtboGiser
Asked:
PtboGiser
  • 2
  • 2
3 Solutions
 
Mike ThomasConsultantCommented:
You could use ADSIEDIT.msc to see if you can find a reference to it, also in ad users and computers if you select advanced and check in the system container (or better just run a search) to find a reference to it.

0
 
PtboGiserAuthor Commented:
Not sure where to even start looking in ADSI edit, but in advanced view, there is no record of it anymore in AD users and com puters.  It's been a while, and it still happens.  I'm wondering if there is somewhere in dcom settings, or in GP that I should be looking?
0
 
Mike ThomasConsultantCommented:
Check your DNS zones for old records for this server and delete them, also check any software relating to this server agents etc are removed from other servers, clients.

0
 
PtboGiserAuthor Commented:
K, I figured it out.  The old server was setup as a certificate authority, on a different (old), trusted domain, but the role did not uninstall correctly.  There were actually 2 other cert servers that had failed to uninstall, and had since been decommissioned.  I found an article directying me to remove the entries manually from Active Directory Sites and Services, and after removed, no more errors.  Thanks anyways :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now