• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3531
  • Last Modified:

Remote Desktop Services / NLA / Password Change

We have a Windows Server 2008 running Remote Desktop Services with several remote users. The users passwords expired or were reset and they are required to reset their password on next login.

The built-in NLA (Network Level Authentication) is being used in Remote Desktop sessions of the Windows 7 machines. This level of Authentication does not allow a password change at login.

Catch 22 - How can these remote users log in for the first time to set their password if they have to log in before they can change their password with NLA?

As a temporary fix, we have the remote users log in with a Windows XP machine to change the passwords remotely, which works, but is a waste of time.

How can we configure the RDS server so Windows 7 users canremotely reset their passwords on next login with NLA?

-Wes
0
qualityip
Asked:
qualityip
  • 2
  • 2
1 Solution
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Hello qualityip, did you try from a W7 workstation by pressing ctrl-alt-delete, change a password, other credentials, change a network password?
0
 
qualityipAuthor Commented:
Gerwinjansen - I think your soloution would work if we were on the local network, but would that work in a remote session? We will test, but I don't think it will.

Our users are all over the state and connecting to rds.domain.com through Remote Desktoop client and are being denied because NLA does not allow a password change at logon but they are required to change their password.
0
 
qualityipAuthor Commented:
Maybe we can set the RDP requirements on the server to a lower setting so it doesn't use the NLA to log in. Is this possible?
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
According to this post you can. It says:

User cannot change expired password when they logon through Terminal Services

If you encounter this problem, you can:

Please change your security layer to RDP and see if it resolves the issue.  To do this, click start--run--tsconfig.msc, double-click RDP-Tcp, change security layer to RDP Security Layer, click ok, then test.

another method is:

The issue is due to Network Level Authentication (NLA) on the newer RDP
clients that by design does not allow you to change your password at logon.
If you add this line to the Default.rdp file, it will disable that.
enablecredsspsupport:i:0
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now