[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 944
  • Last Modified:

Problem: Cannot open YaST anymore!

Hello experts

I'm currently running a Linux SLES 10 SP3, YaST worked fine some days ago, but now, when entering yast, the following error is displayed:

production_server:/# yast
warning: the qt frontend is installed but does not work
warning: the ncurses frontend is installed but does not work
You need to install yast2-ncurses to use the YaST2 text mode interface

Pls any help will be greatly appreciated :(!!!
0
Arrismog
Asked:
Arrismog
  • 2
1 Solution
 
Joseph GanSystem AdminCommented:
As the error message said, you may need to re-install yast2-ncurses package from a installation cd/dvd like
# rpm -i /cdrom/pkg/yast2-ncurses.rpm

This package is a character based user interface.

Have you trid

# yast2
0
 
Joseph GanSystem AdminCommented:
Also you can rebuild the yast stacks by command "ldconfig -v".
0
 
ArrismogAuthor Commented:
Yes! did as suggested and worked! Made my day sir.

It's the first time I ever get this message, was this error generated by some previous installation made through yast? I don't remember doing any change at all in the past days back when it was working.
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now