Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 453
  • Last Modified:

Applying magento theme

Experts

I have recently moved a magento site from 1.5 to 1.6 (also changed server). I didnt build the site and as such have limited knoweledge of magento, but needs must and im struggling to get it up anhd running. I took a dump of the DB, installed mag1.6, transferred skin, app, media folders and also updated the key and pass etc in local.xml. The site now outputs the underlying data, but doesnt seem to output referecnes to the correct style! (See attached grabs)

You need to add this to HOSTS file to view:
149.255.56.74 www.astridandmiyu.com


For example on the home page the style sheets point to: skin/frontend/default/default/css/styles.css    
instead of:  skin/frontend/default/astrid_miyu/css/styles.css

Images point to:  skin/frontend/base/default/images/img/img_1.jpg
instead of : skin/frontend/default/astrid_miyu/images/img/img_1.jpg

As far as i can see the theme is set in config -> design - > templates

But i have checked and this seems to be in order!

Any suggestions on how to resolve would be greatly appreciated


Easynow asdtrid grab1 astrid grabg2
0
Dean OBrien
Asked:
Dean OBrien
  • 4
  • 3
1 Solution
 
Chris StanyonCommented:
Hi again,

Firstly, make sure your cache is disabled completely while testing. It'll slow down your site, but at least you'll know your not trying to grab files from the old cache. (System -> Cache Management )

Once that's done, in System -> Config -> Design, leave the Package name set to default, and remove all the other entries. This will effectively set your site to the default theme. Reload your site and make sure that's working as it should be.

Your site is also trying to load a logo in //img/logo-80.jpg (notice the double slash). In System-> Config -> Design you'll see a section called Header. In that, make sure your image src doesn't have a leading slash.

Now, double check your file structure - particularly the app folder and the skin folder. Your skin folder structure should look like:

skin
  |--frontend
      |--default
          |--astrid_miyu
                |--css
                |--images

Your app folder should look like:

app
   |--design
       |--frontend
             |--default
                 |--astrid_miyu
                     |--layout
                     |--template

If you're sure it looks like that , then in admin, Config->Design, set the Templates, Skin and Layout options to astrid_miyu. Leave the Translations and Default blank. Double check the spellings and case of the folder names (unix is case sensitive - Astrid_miyu is not the same as astrid_miyu)

Save your config and try reloading your site.



0
 
Dean OBrienAuthor Commented:
Hi again chris, thanks for the help.

ok... i disabled all cache,

reset all fields, reloaded site = no change, even the product image are not coming through

updated header to not use //
It still points to  skin/frontend/base/default/images/img/logo-80.jpg
should point to skin/frontend/default/astrid_miyu/images/img/logo-80.jpg

confirmed the site structure to what you have = same.

reinserted values astrid_miyu and reloaded site = no change

For some reason the CSS includes are not pointing to the themes they are pointing at default still.

Any suggestions?

Easynow
0
 
Chris StanyonCommented:
OK. Lets try and figure out if this is a problem with Magento or your theme.

In the app/frontend/default folder and skin/frontend/default folder, do you have other folders, apart from your own astrid_miyu. I only have version 1.5.1 installed which comes with several other themes - including blank, iphone and modern. Not sure what you get with 1.6.

If you do, in your admin / design section, change the Template, Skin and Layout to one of these - try modern if it's there. Leave the package set to default.

If Magento is working the way it should be, then the look of your site should change to the modern theme. Try that first so we can see if magento is reading the settings correctly.

As you'll learn the more you work with magento, debuggin' can be a bit of a pain...

0
How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

 
Dean OBrienAuthor Commented:
Hi Chris,

Sorry for the delay getting back to you.

I decided to take a complete back up of all files on the old server (i.e. dumped the whole lot via SSH to local). My thoughts on a fall back plan are to simply remove all fromk the NEW server and then SSH the whole backup of files to the new server.  This will obviously give me mag 1.5 again.

Can you think of any reason the above would not work? Im tempted to just do it and stick with the old version but on new server.

Ok back to your solution. I did what you mentioned and YES it changed the theme to modern! WHen looking at the code, the CSS include strings pull in the modern ones...

When i change back to astrid_miyu, it loads the default again... Is there some kind of XML file somewhere that states the available themes?

Easynow
0
 
Chris StanyonCommented:
Firstly, there's no reason that wouldn't work. You'll also need to replace the database with your 1.5 one.

Once you've uploaded it and got it working, can't you just update Magento from within Magento Connect. Click the Check For Updates button and you should see all available updates, and the one called Mage_All_Latest will give you a list of the available versions. Select 1.6.0 or 1.6.1 and then commit the changes. Usual caveats apply - backup first !

There is no XML files for available themes. Magento will try and read the theme and layout from whatever folder you tell it to.

It seems that something in your theme is breaking - it can't find styles.css where it's looking, so is falling back to the default one.

To narrow down what's breaking, in Config -> Design, leave the package set as default, leave the layout and templates set as modern, and change your skin to astrid_miyu. Save and reload your site.

What we're doing here is just testing your skin files (css), and leaving everything else down to the modern theme. Hopefully, you should see your theme (although it may look somewhat broken).

If that's the case, then your problem is that either a template file or more likely, an XML layout file is setting the location of your CSS file wrong. The first place to look is page.xml in the layout folder of your theme. Towards the top, you will see a load of lines with action addJs and action addCSS. Double check what the line says that loads styles.css. Make sure there are no paths in there that point to the wrong file. This may also be overridden in a file called local.xml in your layout folder, although you may not have that file.

Kinda running out of ideas here, so hopefully we're getting somewhere.
0
 
Dean OBrienAuthor Commented:
Hey Chris,

I tried what you said with the leaving the skin set to astrid_miyu, but there was no change.

Rather than keep banging my head against the desk im going to just try and upload the full whack to the new server (currently 52%). I cant see how there can be problems doing it this way either, so fingers crossed.

Lol no doubt be on tomorrow crying for help!!

Cheers for the advice so far, will try the above in more detail if persists on the new install.

Regards
Easynow
0
 
Dean OBrienAuthor Commented:
Hi Chris,

Just an update, and for anyone reading this question, pounding there head as i was...

I reinstalled Joom1.5 and still had the exact same problem. I narrowed it down to the theme. I copied an old one named it modern2 and pasted all files into it and it seemed to work....

In this latest install, I copied skin and app folders unzipped to local machine, then up to new server. This seems to have solved the problem.

I suspect that the process of TAR -> UNTAR somehow corrupted the folders???

Answer: dont zip :)

Regards

Easynow
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now