• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2032
  • Last Modified:

PowerPoint 2003: no program is registered to open this file

We have a PowerPoint 2003 presentation that links to several FLV video files. I have installed codecs so that FLV files will play within Windows Media Player, which they do outside of  PowerPoint.
When the presentation is running, however, PowerPoint produces an error message when clicking the hyperlink that links to these video files. The error is "No program is registered to open this file."
I have gone into the File association dialog and manually associated Windows Media Player with FLV files.
We are using PowerPoint 2003 (SP 3) and Windows Media Player 11 on Windows XP Professional, SP 3. PowerPoint Error
0
lffit
Asked:
lffit
  • 8
  • 5
2 Solutions
 
flubbsterCommented:
Try this

1. "C:\Program Files\Microsoft Office\OFFICE11\Powerpnt.exe" /unregserver
2. "C:\Program Files\Microsoft Office\OFFICE11\Powerpnt.exe" /regserver (wait here for MSIEXEC to finish)
3. Open PowerPoint and close.
4. Open Windows Media Player- wait for MSIEXEC to finish, then close.

Test
0
 
lffitAuthor Commented:
flubbster- There is no change after trying this solution. Did you mean for me to perform the same registration commands against Windows Media Player as well?
0
 
flubbsterCommented:
No... I was hoping that the commands would reset the linkage.

Can you go into services and verify that RPC is started and running?
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
lffitAuthor Commented:
flubbster - Yes the RPC service is running. I should mention that we have the same error on separate systems so I'm assuming that it's a PowerPoint error, possibly a bug. I do have an update in that the links work if VLC is installed and selected as the default FLV video player. Of course I was hoping to avoid that as a solution since that means installing VLC on multiple systems.
0
 
flubbsterCommented:
So it's more of a Microsoft thing... what a surprise lol

I was going to suggest trying it with VLC because that is the usual FLV player that most people use and it works very well.

You say you manually associated flv files with WMP. Try removing that association, then right clicking on an flv file, selecting open with>Choose Program. Then select WMP and make sure that "Always use this program blah blah blah is checked.
0
 
lffitAuthor Commented:
flubbster- Please see attached image. I'm not able to deselect WMP as default player option. Even though I have selected VLC as the default player. For both players the 'set as default' checkbox is grayed out. Yes, I am an administrator on this computer.     File association dialog
0
 
flubbsterCommented:
Open any folder and click on Tools>Folder Options
Select the "File Types" tab
Scroll down and find FLV files
See what it shows for the default player

Click on Advanced. There should be at least two entries. One for "Open" and one for "Play." Click on each entry, then select Edit. Please post what the command line is for each entry.

Then look for the entry for VLC player. Do the same thing and post the command line for it when it is the default.
0
 
lffitAuthor Commented:
flubbster - If you select VLC as the defualt player you don't get the advanced button. This only seems to appear if you select WMP. The command line that appears for that is "C:\Program Files\Windows Media Player\wmplayer.exe" /Play "%L".

If I select VLC as the default player,  I simply get a Restore button that allows me to revert to Windows Media Player.

This may be the difference between a system file association setting and a user file association setting. When I installed the K-Lite codec pack, I specified Windows Media Player as the default player and it applied this setting for all users.
0
 
flubbsterCommented:
You're probably right. If you double-click on an flv video, does WMP open it and start playing automatically? Or do you have to open WMP first?
0
 
lffitAuthor Commented:
flubbster- WMP will play the file no problems. I don't have to open WMP first. It's just that PowerPoint doesn't seem to know that.
0
 
lffitAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for lffit's comment http:/Q_27416218.html#37033276

for the following reason:

This seems to be a Microsoft Office Bug and the best solution is installing a different media player.
0
 
lffitAuthor Commented:
I meant to award points to flubbster. Please remove the request to close
0
 
lffitAuthor Commented:
This seems to be a Microsoft Office Bug and the best solution is installing a different media player
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 8
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now