• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 224
  • Last Modified:

Trouble with VS2005 Deployment Project not installing Prerequisites

I have simplified things a bit to help understand the problem..  My 32bit target machine does not have .NET Framework 2.0.  I have a project on my developement machine including a solution with both a Windows Application and a Setup Project. I have chosen one prerequisite: .NET Framework 2.0.  After building the application and moving the .msi to the target machine, I'm confronted with the following message when I try to run the install..  "This setup requires the .NET Framework version 2.0.50727". Please install it and run the setup again etc..  I'm aware its not there which is why it's included as a prerequites installation.  Any thoughts on what needs changed?  If I run the NetFx20SP2_x86.exe thats included it installs fine.
0
tegronakron
Asked:
tegronakron
1 Solution
 
CodeCruiserCommented:
>After building the application and moving the .msi to the target machine

Setup project generates a setup.exe file which is actually the bootstraper tasked with checking and installing the prerequisites. Do you copy and run this file?
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now