Application is slow to load

I run an application for a few of my customers called Docufire (http://www.docufire.com)

I have it installed on multiple computers and a few Windows 2008 R2 terminal servers and it works fine except for on one of the Windows 2008 R2 server it takes about 20 seconds to load. I contacted thier support and they don't know what the problem is. Docufire support is telling me that it has to be in the environment. Once loaded the application works fine. THe server has 32GB of ram quad core CPU...etc...

Any idea how I could troubleshoot this? On one of my Windows 7 computers it takes 3-4 seconds to load. As far as I know the app is written in Visual C++ using a MS SQL database.
LVL 1
GerhardpetAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnb6767Commented:
Troubleshooting with Process Monitor
http://blogs.technet.com/b/askperf/archive/2007/06/01/troubleshooting-with-process-monitor.aspx

I would launch this, and set the filter to ....

"Process Name" is "Yourapp.exe" and "Include".

Then I would focus the initial efforts on the result "Name Not Found" (or at least exclude "Success"). Now you can hopefully see what it is looking for.....

Also, make sure that the capture is stopped once the app launches, or else you will end up with a TON of uneeded data......

And a few other articles, for instructions on usage if needed.....

http://www.winhelponline.com/blog/process-monitor-track-events-generate-log-file/
http://forums.totalwar.org/vb/showthread.php?90267-How-to-Install-amp-Use-Process-Monitor-%28ProcMon%29-to-gather-data-about-loading-CTD-s
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johnb6767Commented:
Did this help any?
0
GerhardpetAuthor Commented:
What I found so far is that if I reboot the server the app starts in 3 to 4 seconds but once the server has been up and running for a few days the app is slow to load again.

I did use the process monitor as per your suggestion and compared the results with another Windows 7 computer for the app and I could not see anything abnormal.

Not sure where to go from here.
0
GerhardpetAuthor Commented:
Process Monitor did help to find out what was going on but it is the developer now who is looking at the problem. Thank you for your help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.