Microsoft Exchange Active Sync error 3005 status 503 with iPhones and Androids

Hi all,

We are running Exchange 2003 on Server 2003. We have about 20 users connecting to Exchange through active sync on their iPhones and droids. Most of us experience some kind of problem with this connection. It hasn't always been like this, started a while ago and has gotten worst.
The event log shows event id 3005 with http status 503.
Some of the problems we are experiencing include the iPhone wiping all emails from the inbox (on the phone only) and then downloading them again, not being able to delete emails, not being able to send emails right away (takes a bit sometimes), deleting an email only to have it show up in the iPhone as unread again. The phones still connect but these problems are getting to be a nuisance for all of us.
Any ideas as to what is causing this? I’ve checked the vdir registry fix that is a common suggestion for status 503 but I’m still getting a ton of these events and the problems associated with them.
Whoever setup my email system (before my time) didn’t name it exchange-oma, it’s exchange only. Not sure if that makes a real difference or not.
Thanks,
Primus
PrimusPilusAsked:
Who is Participating?
 
Alan HardistyConnect With a Mentor Co-OwnerCommented:
Please have a read through my Exchange 2003 / Activesync article and check your IIS settings:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

0
 
Computer-Service-St-LouisConnect With a Mentor Commented:
Something simple to try, that you may want to consider regardless, check to see if you have the latest SP of Exchange. Sometimes Service Packs fix issues like this. It is usually not very difficult to do, and you may get lucky. Also update your devices to the newest version as well. The second option would be check the event log on the Exchange server as the user is connecting, and see if you can get some specific information at the exact time of the issue. Hope this helps! Good Luck!
0
 
PrimusPilusAuthor Commented:
Hi there.

Compute-Se...r, I cheked and I have the latest service pack installed on exchange. The HTTP log (under system32/logfiles) shows all the iPhones pinging the server but no errors as far as i can tell. What other logs should I check?

Alanhardisty, I'm going through your instructions now (which are nicely done by the way!). I don't have an Exchange-OMA website listed in IIS. You do, as well as Exchange. Attached is my IIS, do you see anything out of the ordinary with it? I'm going to continue with your instructions as well.

Thank you guys!

Primus
IIS.JPG
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Alan HardistyCo-OwnerCommented:
Exchange-OMA  is only required / created if you have Small Business Server, or you enable Forms Based Authentication (pretty login page for webmail).  If you are using FBA, then follow kb817379 to create the exchange-oma virtual directory.
0
 
PrimusPilusAuthor Commented:
Hi there,

I followed your link and went through everything, we are still getting the error.

The only part I didn't do was the SSL part but we never used SSL before and we weren't having this issue before.

Any more suggestions?

Thanks,
Primus
0
 
Alan HardistyCo-OwnerCommented:
Using Activesync without SSL is not in the least bit recommended.

If you are not using SSL - do you have SSL enabled on the Microsoft-Server-Activesync virtual directory?
0
 
PrimusPilusAuthor Commented:
We do not have it enabled on the virtual directory.

Our iPhone work right now but not very well. Again, this problem is more recent and SSL was never on. I agree with you about SSL and I will enable it but I want to solve this problem first.

I have a feeling it's a connections issue. We probably have more than 20-30 people on iPhones, droids, iPads, etc. Is there any way to increase connections to the server or to activesync? Our server isn't very good to begin with.

0
 
Alan HardistyCo-OwnerCommented:
What is your default website timeout set to?

There is a link in my article to a cheap SSL cert site trusted by everyone for £30.00
0
 
PrimusPilusAuthor Commented:
The Connection timeout is set to 480 seconds.

I'll give the SSL thing a try but this was working fine before!
0
 
Alan HardistyCo-OwnerCommented:
Try that - and if that doesn't help - reinstall Exchange 2003 SP2.

Keep me posted if no joy after that.
0
 
PrimusPilusAuthor Commented:
Issue was never solved. Upgraded to EX2010 and all is fine.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.