• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1365
  • Last Modified:

FileZilla FTP server

Hello;

I just installed FileZilla FTP server 0.9.40 on my Windows XP computer which is deployed behind a ISP router.  Due to the ftp port 21 is blocked by my ISP by default, I have to redirect port 2112 to port 21, in which; I configured a Port Forwarding in my ISP ADSL router for redirect port 2112 coming from internet to my XP computer port 21.

I used Port Checker tool in internet to test my port 2112, it works and I can see the user name pop up for my ftp server authentication but after enter the credential, I got Web page not able to open message (something like that).  I found the following error while I was checking it by a ftp diagnostic tool in internet.

What can I do to fix it?


Response: 227 Entering Passive Mode (192,168,1,65,4,176)
Status: Server sent passive reply with unroutable address. Using server address instead.
Command: MLSD
Response: 425 Can't open data connection.
Error: Failed to retrieve directory listing
0
KANEWONG
Asked:
KANEWONG
  • 4
  • 4
  • 3
  • +1
1 Solution
 
sjklein42Commented:
I think this may apply:

http://www.nodans.com/index.cfm/2008/4/24/Fix-for-Filezilla-Failing-to-Retrieve-Directory-Listing

¦Open Filezilla, go to Edit -> Settings
¦Click on Connection -> FTP: Choose Active
¦Click on Connection -> FTP -> Active Mode: Select "Ask your operating system for the external IP address"
¦Click on Connection -> FTP -> Passive Mode: Choose Fall Back to Active Mode
¦Press OK.

Try connecting to your FTP site once again.
0
 
KANEWONGAuthor Commented:
I found that work around too before I post my question here, that does not apply to me because the version on the site is the old version.
0
 
sjklein42Commented:
Oh.  Sorry.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
h3rxCommented:
Try to also forward the port 20 on the router to your windows xp
0
 
sjklein42Commented:
h3rx:  Good thought, but more likely they need to tunnel port 2111 back to their XP machine.  The command port is 2112 and the data port is that minus one.  By default, these are 21 and 20.  But this is not the default situation.

So modifying h3rx's idea, I'd try forwarding port 2111 on the router to the XP machine.
0
 
sjklein42Commented:
and for passive mode support:

You  have to forward a port range for passive mode transfers. You can specify this port range on the "passive mode settings" page in the settings dialog in the server interface. In most cases, a range like 5000-5100 is sufficient.

http://wiki.filezilla-project.org/FAQ
0
 
AlexPaceCommented:
Consider the server response:  227 Entering Passive Mode (192,168,1,65,4,176)

This means the server is telling the client to connect to IP address 192.168.1.65 port 1200

An external client can't reach 192.168.1.65 because it is a private address.

Some firewalls are able to monitor the FTP control channel and replace an internal address with an external address on the fly.  Some FTP Server software allows you to specify an external address as the PASV response.  If you don't have either then you'll need to use a different FTP Server software or give the computer a public IP address.
0
 
KANEWONGAuthor Commented:
no luck;

always got this error

Command: PASV

Reply: 227 Entering Passive Mode (my public IP,19,142)

Command: MLSD

Reply: 425 Can't open data connection.

Error: Listing failed
0
 
AlexPaceCommented:
OK, well at least you got the public IP address so that is good.  

This time it said to use port 5006
5006 = (19 * 256) + 142

I think you need to go into the server software and specify a port range to use for passive mode data channels and then open that port range on your firewall because it doesn't seem like the firewall is inspecting FTP traffic to open data channels on the fly.
0
 
KANEWONGAuthor Commented:
this time,  I got..

Command: USER username
Reply: 331 Password required for username
Command: PASS ********
Reply: 230 Logged on
Command: SYST
Reply: 215 UNIX emulated by FileZilla
Command: FEAT
Reply: 211-Features:
Reply: MDTM
Reply: REST STREAM
Reply: SIZE
Reply: MLST type*;size*;modify*;
Reply: MLSD
Reply: UTF8
Reply: CLNT
Reply: MFMT
Reply: 211 End
Command: PWD
Reply: 257 "/" is current directory.
Status: Current path is /
Command: TYPE I
Reply: 200 Type set to I
Command: PASV

Error: Could not read from socket: Connection reset by peer
0
 
AlexPaceCommented:
I am concerned that you didnt see the server's response to the PASV command in the log.

Please try downloading Robo-FTP trial version and type these command in the main console window:
TRACELOG "trace.log"
FTPLOGON "ftp.myserver.com" /user="UserID" /pw="Secret"
FTPLIST

Open in new window


Please post the trace.log file, it should not show the login password but you might want to obsucre the IP address.  I am only really intersted in if the client receive the PASV response.

Another way to do this is to use your existing  FTP client and WireShark or another packet sniffer to see what is returned by the server.
0
 
KANEWONGAuthor Commented:
will try.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

  • 4
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now