• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 378
  • Last Modified:

runtime dlls go missing from computer

For some weeks now I have been driven mad by an error that seems to occur in the morning after my PC has woken up.   Various apps that use dot net and visual c++ redist libraries stop working and give the following error:

The program can't start because MSVCR100_CLR0400.dll is missing from your computer. Try reinstalling the program to fix this problem.

In this case it came from MySQL workbench but I have had the same with other apps.  The solution is quite simple,  I do a repair installation of dot net 4 and vcredist_x86.exe and the application runs again.  However the following morning it MAY do it again.  I put the word may in caps because sometimes it will go up to a week without misbehaving and then it will start happening again.

I have changed my AV solution from Trend Micro to Webroot and that made no difference.  I disabled Macrium Reflect nightly backup and thought that had solved it but it has just started happening again.  I have run various Malware scanners with no benefit.  I have looked at the event log but cannot see anything there (although I am not exactly sure what I am looking for)

Has anyone got any suggestions?  I dont want to reinstall windows as I only did it recently - and come to think of it - the problem has only been happening since this re-installation.

I am really frustrated by this and would like to know what is going on and how to fix it.

My OS is Win 7 x64

Peter
0
peterharris
Asked:
peterharris
  • 3
  • 2
1 Solution
 
sarabandeCommented:
it looks like a hardware error for me. perhaps some cable thing. check the eventvwr log whether it tells any errors.

Sara
0
 
peterharrisAuthor Commented:
Just happened again.  Nothing in the event viewer log that I can find.   Did a disk check and it found a couple of minor errors - not convinced thats the problem.  I am using a SSD C: drive.

Looks like a Windows re-install is on the cards again.  Took me about a week to get my PC back to its normal working state after the last one :-(

Peter
0
 
peterharrisAuthor Commented:
I finally decided to reinstall windows and its now fixed.  There are a lot of other little irritations that seem to have gone away as well eg freezing explorer window and failed windows updates so I guess there was something basically corrupted in my previous installation.

Peter
0
 
peterharrisAuthor Commented:
I accepted my own comment as the solution as I could find no other way of closing the question
0
 
sarabandeCommented:
i read from issues with ssd drivers on some boards. it is fine, that the new installation could solve that.

good luck

Sara
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now