[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 891
  • Last Modified:

DNS errors - Messy dcpromo ?

I just run dcpromo after adding ADDS role on a Windows 2008 R2 server. This is a test/lab domain to check 2008 R2 functional level and changes - so I've never worked with R2 before.

Why after a clean installation am I getting these errors? ... I've never come across anything like this :/

I am getting these errors to begin with (Image 1)

DCDiag results: Code Snippet

ipconfig results:

C:\Users\Administrator.DC08R2A>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : DC08A
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-0C-29-09-73-7A
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::b0d5:e71a:86c0:94c4%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.3.30(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . : 192.168.2.1
   DHCPv6 IAID . . . . . . . . . . . : 251661353
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-3A-D4-A5-00-0C-29-09-73-7A

   DNS Servers . . . . . . . . . . . : ::1
                                       127.0.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{1FC6745B-594F-4420-90C1-3FDC64E4C602}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes



and ...... nslook up ...

C:\Users\Administrator.DC08R2A>nslookup ms2008.local
Server:  UnKnown
Address:  ::1

Name:    ms2008.local

I just followed the normal dcpromo procedure as I've done so many times before ... why this mess? :((((


Thank you
C:\Users\Administrator.DC08R2A>dcdiag

Directory Server Diagnosis

Performing initial setup:
   Trying to find home server...
   Home Server = DC08A
   * Identified AD Forest.
   Done gathering initial info.

Doing initial required tests

   Testing server: Default-First-Site-Name\DC08A
      Starting test: Connectivity
         The host d922d968-9fa2-4862-91ac-235b401b200c._msdcs.ms2008.local
         could not be resolved to an IP address. Check the DNS server, DHCP,
         server name, etc.
         Got error while checking LDAP and RPC connectivity. Please check your
         firewall settings.
         ......................... DC08A failed test Connectivity

Doing primary tests

   Testing server: Default-First-Site-Name\DC08A
      Skipping all tests, because server DC08A is not responding to directory
      service requests.


   Running partition tests on : ForestDnsZones
      Starting test: CheckSDRefDom
         ......................... ForestDnsZones passed test CheckSDRefDom
      Starting test: CrossRefValidation
         ......................... ForestDnsZones passed test
         CrossRefValidation

   Running partition tests on : DomainDnsZones
      Starting test: CheckSDRefDom
         ......................... DomainDnsZones passed test CheckSDRefDom
      Starting test: CrossRefValidation
         ......................... DomainDnsZones passed test
         CrossRefValidation

   Running partition tests on : Schema
      Starting test: CheckSDRefDom
         ......................... Schema passed test CheckSDRefDom
      Starting test: CrossRefValidation
         ......................... Schema passed test CrossRefValidation

   Running partition tests on : Configuration
      Starting test: CheckSDRefDom
         ......................... Configuration passed test CheckSDRefDom
      Starting test: CrossRefValidation
         ......................... Configuration passed test CrossRefValidation

   Running partition tests on : ms2008
      Starting test: CheckSDRefDom
         ......................... ms2008 passed test CheckSDRefDom
      Starting test: CrossRefValidation
         ......................... ms2008 passed test CrossRefValidation

   Running enterprise tests on : ms2008.local
      Starting test: LocatorCheck
         ......................... ms2008.local passed test LocatorCheck
      Starting test: Intersite
         ......................... ms2008.local passed test Intersite

C:\Users\Administrator.DC08R2A>

Open in new window

DNS1.JPG
0
nipponsoul
Asked:
nipponsoul
1 Solution
 
Miguel Angel Perez MuñozCommented:
Seems that DNS problems.

Using DNS console, have you got AD zones created? maybe during setup has a DNS problems and zones not be created.
0
 
nipponsoulAuthor Commented:
Yes, screenshots uploaded.
dns2.JPG
dns3.JPG
0
 
Neil RussellTechnical Development LeadCommented:
First off, as this is a DC I would dissable DHCP and assign a static IP Address. reboot and ensure that the IP is registering in DNS correctly.
And you have got windows firewall DISSABLED yes?
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
Miguel Angel Perez MuñozCommented:
On the second screen, can you post me contens of folder _msdcs? I´m looking for d922d968-9fa2-4862-91ac-235b401b200c._msdcs.ms2008.local

0
 
nipponsoulAuthor Commented:
DHCP role  has not been added at all.

I have assigned a static IP for the DC  192.168.3.30 ... I have disabled the firewall but that didn't change anything ...
0
 
nipponsoulAuthor Commented:
thank you all for your replies fo far.

@ Drashiel:  only one entry in the folder:


dns4.JPG
0
 
Miguel Angel Perez MuñozCommented:
Your DNS is incomplete.

you must to have folders to store information about DC, GC, etc. I attach you a DNS, see diferences with your DNS.
dns.jpg
0
 
nipponsoulAuthor Commented:
Still doesn't explain why this happened or how since this is a new machine and all I did was to add the role and then run dcpromo ....

I will re-create the virtual machine ... seems easier at the moment than troubleshooting.
0
 
Steve KnightIT ConsultancyCommented:
Seems best to dcpromo to remove (or rebuild as you say)
Make sure static IP
DNS pointing to itself via IP address, NOT loopback address as above
Probably disable IPv6 on Lan adaptor unless you specifically need/want it
Then DCpromo it

Have just done multiple 2008 R2 dcpromo's upgrading a previously 2000 DC only AD and gone like any other dcpromo I've done...

Steve
0
 
bhanukir7Commented:
hi nipponsoul,

this is caused because the IPv6 loopback adapter address is set as the primary and the IPv4 IP address is set as the secondary. while many of the blogs/forums intially adviced to disable IPv6 you can simply remove the IPv6 DNS entry by typing in command prompt

netsh interface ipv6 delete dnsserver "Local Area Connection" ::1

For additional info Refer to this blog post by a microsoft MVP.

http://msmvps.com/blogs/acefekay/archive/2010/05/27/how-to-disable-rss-tcp-chimney-feature-and-ipv6.aspx

regards
bhanu
0
 
chakkoCommented:
Also, I would try to set your TCP/IP DNS setting on the LAN card to be 192.168.0.30 (your server IP).
Then restart the Netlogon service and try testing again.
0
 
nipponsoulAuthor Commented:
Well guys nothing worked in the end...

I rebuild the virtual machine from scratch and used a different Windows 2008 R2 DVD and it all worked as a charm after dcpromo as usual ...  Thank you very much for all your suggestions.
0
 
nipponsoulAuthor Commented:
Unfortunately none of the suggestions from the other experts worked.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now