?
Solved

Deferred: Broken Pipe - Internal or External problem?

Posted on 2011-10-27
5
Medium Priority
?
4,564 Views
Last Modified: 2012-06-21
Hi All,

Major problem. Several customers experience the same problem: Deferred: Broken Pipe error message when sending email to their own internal Exchange 2007 server. This error occurs when there is an attachment of 1MB or more. They all have Internet from the same ISP, cable (no ADSL). I have learned that this has something to do with an incorrect MTU size. Within all hardware of the company the size is 1500. There is a spamfilter between the outside world and the Exchange server. WITH this spamfilter this error occurs. WITHOUT this spamfilter no problem. The filter itself is not the problem, at 98% of all domain using this filter it works fine.

Here are the tracert's of a working and failing situation:

FAILING:
TracePath Output:
1:  luna.subnetonline.net (85.17.185.51)                   0.132ms pmtu 1500
1:  gi7-0.r1.sbp.leaseweb.net (85.17.250.253)             20.783ms
 2:  85.17.129.37 (85.17.129.37)                            1.252ms
 3:  be11.crs.evo.leaseweb.net (85.17.100.225)              4.006ms
 4:  ziggo.nikhef.nl-ix.net (193.239.116.136)             asymm  5   1.418ms
 5:  tb-rc0001-cr102-ae0-0.core.as9143.net (213.51.158.155) asymm  6  53.913ms
 6:  tb-rc0001-dr101-lo0-0.core.as9143.net (213.51.125.2) asymm  7   3.423ms pmtu 1456
7:  5ED39579.cm-7-4c.dynamic.ziggo.nl (94.211.149.121)    17.378ms
 8:  D57D3F0B.static.ziggozakelijk.nl (213.125.63.11)      14.772ms
 9:  no reply
10:  no reply
11:  no reply
12:  no reply

WORKING:
TracePath Output:
1:  luna.subnetonline.net (85.17.185.51)                   0.133ms pmtu 1456
1:  gi7-0.r1.sbp.leaseweb.net (85.17.250.253)              0.901ms
 2:  85.17.129.37 (85.17.129.37)                            0.710ms
 3:  be11.crs.evo.leaseweb.net (85.17.100.225)              2.780ms
 4:  ziggo.nikhef.nl-ix.net (193.239.116.136)             asymm  5  12.539ms
 5:  ht-rc0001-cr102-ae0-0.core.as9143.net (213.51.158.103) asymm  6   3.027ms
 6:  ht-rc0001-dr101-lo0-0.core.as9143.net (213.51.124.2) asymm  7   3.184ms
 7:  541ECB0D.cm-5-7d.dynamic.ziggo.nl (84.30.203.13)      12.261ms
 8:  D57D11A3.static.ziggozakelijk.nl (213.125.17.163)    asymm  7  17.523ms
 9:  no reply
10:  no reply
11:  no reply
12:  no reply

Fingers crossed :-)
0
Comment
Question by:Agrippa
  • 3
5 Comments
 
LVL 5

Expert Comment

by:JamesGolden
ID: 37038177
It may be something as simple as allowing a larger attachment size on the spam filter.  If you can send email through the spam filter, but not email with attachments I doubt it would be an MTU issue.

Check the settings on the spam filter for attachment limitations.
0
 

Author Comment

by:Agrippa
ID: 37038254
Hi JamesGolden,

there are no limitations on the spamfilter and I doubt it will be something simple, unfortunately. Also 98% of all domains in that spamfilter work fine, even with 15MB attachments.
0
 
LVL 19

Expert Comment

by:xterm
ID: 37038751
Can you attach one of the full bounce messages that contain the broken pipe error?  Obviously blot out any sensitive names or IP addresses first.

Also, if you intentionally send spam to a personal account (as you describe these users doing with attachments) and the spam filter blocks them, does it do so with a different error than "broken pipe", or is it the same?
0
 

Accepted Solution

by:
Agrippa earned 0 total points
ID: 37167853
Hi Guys,

eventually it was a new NIC driver which solved the problem, simple as it seems, it took some time to figure this out. Thankx all.
0
 

Author Closing Comment

by:Agrippa
ID: 37191130
Own solution was the right one in this case
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to effectively resolve the number one email related issue received by helpdesks.
If you have come across a situation where you need to find some EDB mailbox recovery techniques, then here you will find the same. In this article, we will take you through three techniques using which you will be able to perform EDB recovery. You …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question