WMP 11 / XP SP3 - .wav files open, do not play.

Posted on 2011-10-27
Last Modified: 2013-12-07
Good Morning,

I have a confusing problem.  .Wav files won't play through Media Player 11.  I have no problem opening them in mplayer2.exe or RealPlayer, etc.

The files open in WMP 11, but don't play.  I do not get any errors in the player or app/system logs.  And it's only on certain workstations.  The files seem fine.  I am thinking it's a problem with the build of this generation of workstation.  

I used GSpot to analyze the files and they come back clean as well - specifying that a codec isn't actually needed to play it.

It's been a while since I"ve had to delve into the wonder world of Audio, so any help would be much appreciated.

Question by:ShuttleDIK

    Author Comment

    I'm getting some clues that it may be DRM related.  Any ideas there?
    LVL 69

    Expert Comment

    no that shouldnt be it,  DRM only applies to WMA
    two things you can check
    WMP is finnacky about  not being the default player for certain files types, ie if it is not associated within WMP files types
    r/click a wav file go to open with>then choose choose default program select WMP
    apply and ok
    try and play it
    Check wav's is in the files types in WMP 11
    I am on windows 7 with WMP 12 so our interface is different
    Control Panel > All Control Panel Items > Default
     Programs > Set Associations
     Let me know if that solves it
    LVL 42

    Expert Comment

    by:Davis McCarn
    I suspect something is wrong with the audio codecs and the fix is going to be the reinstallation of Windows defaults.
    To test, try playing a WAV file in Sound Recorder ( Start -> All Programs -> Accessories -> Entertainment )
    If that doesn't work, follow these instructions:

    Author Comment

    Thanks for the input, folks!  Much appreciated.

    @Merete:  The associations are all as they should be, WMP is the default on the workstations for all applicable Media Types, incl. .WAV & . MP3.  The files do open automatically w/ WMP, but there is no "play" of the file.  The Player stays dormant with the file showing, but no activity (wave form display or audio, i.e. it doesn't play)

    @DavisMcCarn:  Sound Recorder, mplayer2.exe (WMP 6 in the Windows Media Player program folder), Real Player, etc. ALL have no problem playing the file - it's only WMP that loads the file and then proceeds to do nothing.  Additionally, it shouldn't need a codec to play .WAV according to the GSpot audio file analysis tool, recommended by many for this type of research.

    I did notice another possible culprit - ffdshow has been loaded onto the builds with the problems.  We've tried some 'fixes' from other sites to address any possible conflicts there, to no avail.  As I did not perform the build, I'm not clear as to why that software is necessary or even present.  But we do have many custom 3rd party apps that require special supporting software, so it may be necessary.

    I'm perusing their SourceForge forum now, but not getting much in the way of results.

    Author Comment

    Ok, here's some more interesting info.

    I did the obligatory:
    re-install WMP 11 - no luck
    unistall ffdshow - no luck
    roll back WMP 11 to 9 - no luck
    Then realized WM Format Runtime was still installed - aand still bupkis (no luck)

    So I think we can see it's not the version, nor the 3rd party app ffdshow - unless, of course, there's some deeper registry holdup.  Running CCleaner reg portion now.


    Assisted Solution

    Sweet!  Fixed it!

    The porblem (I love that typo!) sat in the AC3 filter that was present in the programs folder for Windows Media Player.  I don't know if that comes from the ffdshow, though it could.  I have seen it before on some workstations, but since it doesn't show on it's own in the Add/Remove, I wasn't aware it could be there until I started searching for details on the AC3 / WMP conflicts.  References to that appeared while researching the issues.

    In order to fix the issue, the configuration program's System tab must reflect the "Prefer other decoder" option under Filter merit, instead of "Prefer AC3Filter".  [see image]

    Author Comment

    I've requested that this question be closed as follows:

    Accepted answer: 0 points for ShuttleDIK's comment http:/Q_27418409.html#37047208

    for the following reason:

    There are hoards of posts accross the internet about this issue. &nbsp;Not many of them dealt with AC3 as the cause, as the symptom may be from different sources. &nbsp;It's nice to have a full resolution, however.<br /><br />Thanks, everyone for your input.
    LVL 42

    Accepted Solution

    And my fix was the only one which would have restored the default Windoze audio codecs and their settings which would have reverted Windoze to the correct WAV codec and fixed your problem.  Did you test it with Sound Reocorder?
    Or more importantly, did you reinstall the ACPM drivers to restore the AC3 to it's defaults.
    I have fixed thie problem before......
    LVL 69

    Assisted Solution

    Just a note from me since EE was down in my day time, I would have definately looked in to the ac3 aspect, but as you said you checked the file in Gspot  I didnt ask for a snapshot of the results
    as that would have reported what codecs was used, in the wav. But figured you knew that since you posted a reference to checkin the wav.
    ac3 ( direct show)  of course will not play in wmp natively, installing the ac3 filter would have resolved it. Where you are there I dont understand.
    Anyway the main thing is it's resolved

    Author Comment

    And yet, beyond rudimentary responses, that conflicted with the initial problem description, our in-house research was what actually fixed the issue.  Please accept split points in consolation.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Why You Should Analyze Threat Actor TTPs

    After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

    Suggested Solutions

    Title # Comments Views Activity
    Audio interference 6 48
    Photo Display Application 4 47
    Video Wireless Microphones 2 40
    3D Rendering GPU or CPU? 1 34
    In this article, I'll explain how to setup a Plex Media Server ( on a Redhat (Centos) 7 based NAS with screenshots to help those looking for assistance.  What is Plex? If you aren't familiar with Plex, it’s a DLNA media serv…
    Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
    Viewers will get an overview of how to make and use Drum Racks in Ableton Live. Load new Drum Rack into empty MIDI track: Fill rack with audio samples: Re-arrange sample slots as necessary: Adjust parameters of each slot to tailor each sound a…
    Viewers will learn the basics of using Ableton Live's advanced sampler instrument, Sampler. Load new Sampler into an empty MIDI track: Select a sample and drop it into sample window in Sampler: Adjust pitch if necessary with Root Key setting: …

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now