Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 519
  • Last Modified:

Folder names changing

We have a new file server in place with users folder shared out as USERS$ and then subfolders for each user. The server has been in production now for about a month. In looking on the server this morning, many of the subfolders now appear as My Documents instead of the expected. If you click on the properties of the folder it shows \\servername\users$\username but from an admin perspective you see \\servername\users$\My Documents listed about 12 times. The other folders still show the expected usernames - what causes the name to change and how can I make it stop.
0
kingsville
Asked:
kingsville
  • 6
  • 5
  • 2
1 Solution
 
TheCleanerCommented:
I've seen this before...it's because you allow Folder Redirection and users are redirecting their profile/My Docs.

See here for a few links I'd saved from the past:

http://support.microsoft.com/kb/947222
http://blog.salamandersoft.co.uk/index.php/2010/09/how-to-stop-home-folders-being-renamed-documents-in-the-network-share/

NOTE:  there might be new KB articles or fixes on this...I didn't dig too deep to be sure, but the KB article I posted looks like it was revised in September so there can't be too many updates since then.
0
 
kingsvilleAuthor Commented:
I changed the desktop.ini permissions as indicated in the links. I searched for desktop.ini in the users$ folder and changed the permission there. I logged in as one of the users and the share still appears as My Documents on the server. Have I changed the permission in the proper location and will the folder name revert back to the actual username rather than My Documents when completed properly?
0
 
kingsvilleAuthor Commented:
Also - users showing this issue are thin cllient users logging onto Windows 2008 terminal servers with Citrix XenAPP 6.5 in case this makes a difference
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
TheCleanerCommented:
If you used the KB article and method 3 it should fix it for existing users regardless of how they are accessing it.
0
 
kingsvilleAuthor Commented:
and to my previous comment? will the folder go back to its original name being the username? Or will  need to manually go change them back?
0
 
TheCleanerCommented:
You need to understand what is actually happening.  The folder name itself never changed it just displays differently because of the desktop.ini file.

By DENYing read access to say "Domain Administrators" the next time a domain admin opens that share it will display the real folder name because it can't read the desktop.ini that overrides that default display.

You'll need to set a DENY on the desktop.ini files for anyone or group that you want to see the real name of the folder for.

That second link gives you a script to help automate it, but in your case if it is only 5-10 folders you can set the permissions for each desktop.ini file pretty quick manually.

Does that help?
0
 
kingsvilleAuthor Commented:
Tried opening one of the folders by going to actual folder name and it opened but it is still listed as My Documents when looking at the folder structure through explorer
0
 
TheCleanerCommented:
You set a deny for your account on the desktop.ini for that folder?

It should work as described.  Make sure the account you are using to view the structure has been set to DENY explicitly.

Another alternative would be to use icacls to do it:

%windir%\system32\icacls.exe %homedrive%\Desktop.ini /deny “Domain Admins”:r

Where %homedrive% is the location of the user's shared folder.  Probably not wise to use Domain Admins though...better to limit just your account or create a group of user accounts called "Home Folders Correct Names" or something like that and put your account in there and deny that group access.

Remember, it is the desktop.ini file INSIDE each of the user's folders that you must change and by default they are hidden.
0
 
kingsvilleAuthor Commented:
The file is located in e:\users$\username\windows folder. i have tried on one user this morning to deny on desktop.ini on the administrator account specifically of the network(previous attempt on Domain Admins). If I go to Start - Run and enter the path using the username - the folders come up fine. If I am looking at a list of all the users folders on the server this particular folder still appears as My Documents so the only way I can tell what folder it is from that view is to select the properties and find the name.

It is only the administrator account showing this behaviour. When I browse to that location via my laptop and my account - all are listed as expected.

I under stand we are essentially saying the same thing. Just wanted to verify the location of the desktop.ini that I am modifying the rigths to as being the one you mean
0
 
TheCleanerCommented:
Yeah, except in the case I've seen when working with a small biz on this, it was just inside the share itself.

So if the folder was \\server\SHARE\username

and the user mapped to \\server\USERS\kingsville

then the desktop.ini file would be at \\server\USERS\kingsville\desktop.ini


One thing to note...I see that sometimes a user on Technet will state that even after setting DENY permissions it still shows wrong.  You could search for the desktop.ini files and just delete them it seems.  I have never done that though...and I'm not sure what exactly that would do (if it would auto-recreate one the next time a user connects to their share or what).

One thing I find interesting is that I've never had this happen at my actual company, perhaps because of the way I do share and user level permissions.  For me I deny the user access to anything except their folders and they only have modify rights, not Full Control.  Not sure if that causes the desktop.ini to not have the same effect you are seeing.
0
 
mcsweenSr. Network AdministratorCommented:
This definitely has to do with the desktop.ini files.  You can delete them with no worries although they will re-create themselves.

Try this:

Open a command prompt and cd to the E:\Users folder (or wherever these user folders are) then type
 
attrib -H -S desktop.ini /s
del desktop.ini  /s /q

Open in new window


You could save this to a batch file and run it when  you need to look at the folders.  Not the best solution but it should work for you.
0
 
mcsweenSr. Network AdministratorCommented:
oh, forgot to mention; in server 2008 you will need an elevated command prompt to do this.
0
 
kingsvilleAuthor Commented:
The solution will work as a workaround to the issue to make things easier to work with in the future
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 6
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now