[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Chrome and Safari on Mac Lion does not open last open pages

Posted on 2011-10-27
7
Medium Priority
?
416 Views
Last Modified: 2012-08-14
I have noticed recently that Safari and Chrome on Mac Lion will not open the pages that were open last when the browser is closed from the red X at the top of the browser window.

However, if the dock icon is used to quit the browser, it does open the pages that were open last.

Is this a feature or a bug?

To me it is a bug, as the behavior should be consistent. I do not have the habit of thinking about the two ways of closing to cause different behavior later. And even if this action is a feature, it seems backwards -- the dock icon seems a "more complete quit", but the window red X less complete.

Insight please!
0
Comment
Question by:jasimon9
7 Comments
 
LVL 9

Assisted Solution

by:sshah254
sshah254 earned 300 total points
ID: 37039213
I always use Command+Q to quit the browser, and when I re-open it, it opens all my tabs correctly.

SS
0
 

Author Comment

by:jasimon9
ID: 37039473
Yes, I believe Command-Q would be similar to the dock icon quit, not the red-x quit.
0
 
LVL 84

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 300 total points
ID: 37039476
You could go into options and select "Reopen the pages that were open last" in Chrome or in Safari "Safari opens with: All windows from last session".
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 

Author Comment

by:jasimon9
ID: 37039689
That is the present setting for Chrome. That's why I was confused by the behavior which does not do this.

I changed the Safari setting as suggested. That works for Dock Icon and Ctrl-Q; but the red-x seems to mean "start with no pages from before." To me this is very strange, and seems a design bug. What is the intent of have a prominent red X that means "behave differently?"

Is this new behavior for the red X? Or was it this way in Snow Leopard too?

To me, if you have a setting such as "all windows from last session", it should just work, and not depend on how the app was quit.

- dock icon: obey setting
- Ctrl-Q: obey setting
- red X: disregard setting

I am of a mind to report this as a bug, unless someone has a good explanation.
0
 
LVL 7

Accepted Solution

by:
DanielleFavreau earned 900 total points
ID: 37111947
This is apparently an issue others have experienced and it can be considered a "feature".  Read more here: https://discussions.apple.com/thread/3203884?start=0&tstart=0

It also walks you through various solutions you may want to try.
0
 

Author Comment

by:jasimon9
ID: 37123384
Most of the conversation deals with Safari. I don't use Safari much. Mostly to check compatibility of my web site.

0
 

Author Closing Comment

by:jasimon9
ID: 37223536
Seems like a bug to me, so I have given feedback to Apple. However, points for the contributions to the partial answer.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we discuss how to recover the missing Outlook 2011 for Mac data like Emails and Contacts manually.
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question