• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8594
  • Last Modified:

SBS 2011 can't relay SMTP email from LAN scanner

Hello,

I have newly installed SBS 2011.
all email communication works fine with exception of relaying email from LAN devices.

I have a HP MFP printer/scanner that I want to relay SMTP through mys SBS 2011 server.
(I also want to forward emails from local FAX server to email enable Public folder)

I have created receive connector called "SMTP Relay from LAN devices", but I still can not relay through the server. I have done it before with full blown version of Exchange 2010 and previous version of SBS, but it seems not to work on SBS 2011.

I have noticed that SBS 2011 creates Dafault Receive connector and Internet Receive connector that is different than it was in SBS 2008 or Exchange 2010.

Any ideas what am I doing wrong?
0
pyotrek
Asked:
pyotrek
  • 10
  • 8
  • 2
1 Solution
 
Joe Winograd, EE MVE 2015&2016DeveloperCommented:
Perhaps the firewall is blocking it. Regards, Joe
0
 
pyotrekAuthor Commented:
I assume that you are refering to Local Windows firewall that is on the SBS 2011.

There are few reasons why this is not the case

- I am trying to relay from the FAX Service that is local to the server itself
- when I test the SMTP gateway (there is a test button on the scanners interface) it comes bac as "Valid gateway"
- in order to troubleshoot the issue I have completly disabled the Firewall on the server.
- there is no hardware firewall between the local LAN device and the server.
0
 
Joe Winograd, EE MVE 2015&2016DeveloperCommented:
I had a recollection of a recent thread where this issue was discussed and found it:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_27031335.html

It's for SBS 2008, not 2011, so it may not help you, but it's worth a read. Regards, Joe
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Rob WilliamsCommented:
You need to set up a receive connector on the SBS. Relaying is blocked by default. Philp Elder has a nice article on this. Skip over the Sharepoint part and down to "Create new receive connetor"
http://blog.mpecsinc.ca/2009/09/sbs-2008-mfpcopier-to-scan-to-e-mail.html
You may also want to review the SBS blog article:
http://blogs.technet.com/b/sbs/archive/2008/09/18/how-to-configure-trusted-smtp-relay-in-exchange-on-sbs-2008.aspx
0
 
pyotrekAuthor Commented:
I've just read it, but it describes the scenario that is in place in SBS 2008.
It seems that SBS 2011 handles email on the local LAN in different way.
0
 
Rob WilliamsCommented:
Perhaps the latter part of this article would be more relavent then.
0
 
pyotrekAuthor Commented:
Maybe I was not clear in my original description - I have setup a special Receive connector for specific IP address (I have done it many times in SBS 2008 and Exchange 2011), but it seems that there are new receive connectors that are in SBS 2011 that are different that anything I have seen in SBS 2008 or plain Exchange 2010 or 2008.

It looks like by default the Internet Connection Wizard creates additional wizard to receive emails from Internet which was not in SBS 2008. See attached:
 Receive Connectors on SBS 2011
0
 
Rob WilliamsCommented:
Those are the same 3 standard/default connectors on every SBS 2008/2011 I have seen. Non-SBS installations are different, but I have not seen any variation of this on SBS.
0
 
pyotrekAuthor Commented:
I just realised that sbs 2008 and SBS 2008 R2 have different connectors and SBS 2008 R2 is similar to the connectors on SBS 2011.

Hmmm. that is even more weird as I have that going on SBS 2008 R2 with identical settings.
0
 
Rob WilliamsCommented:
SBS 2008 R2 is SBS 2011
There is only SBS 2008 and SBS 2011 and the receive connectors are identical. Interesting that you have variations. There are most definitely differences between Exchange 2007 (SBS 2008) and Exchange 2010 (SBS 2011), but to the best of my knowledge there are no differences in the 3 default connectors.
0
 
pyotrekAuthor Commented:
RobWill - you are right - I just got mixed up with "plain" exchange 2010.
Regardless my settings are the same as in the other installation that I had done. (and as decribed in the articles tha you have quoted.

I guess i will try to redo the Intarnt Connection wizard etc.
0
 
Rob WilliamsCommented:
I don't work with Non-SBS Exchange but agreed it can be quite different. SBS adds in a lot of default configurations. Let us know how you make out.
0
 
pyotrekAuthor Commented:
Just tried to rerun the Internet Wizard and it comes back with:

 Error from Internet Wizard
... so I guess i have some other issues here.
0
 
Rob WilliamsCommented:
That can be due to group membership. There is an article relating to that:
http://support.microsoft.com/kb/2501155
0
 
pyotrekAuthor Commented:
Thanks for that - I've checked but Domain Admins were already there.
Regardles I have removed them applied the changes and readded them, applied changes, rerun the wizard and it still does not work.
I will reboot the server tonight and check again afterwards.

Strange that it worked fine on the original run and now it does not. I did not mess with the security settings and tried using wizards to do everything as I know that SBS does not like it any other way.
0
 
Rob WilliamsCommented:
If domain admins was already there it shouldn't matter but if you made a change I am not sure exactly how/when it is applied. I don't think you would have to reboot, but you would definitely have to log off and back on.
0
 
Rob WilliamsCommented:
The above issue I was aware of but the following I had not seen, but where you were working with the receive connectors it might be related. It says for SBS 2008, but may still be worth reviewing:
http://support.microsoft.com/kb/974979#appliesto
0
 
pyotrekAuthor Commented:
In principal what I was setting up was correct, but during the proces settings got corrupted. As a result the Internet connection wizard was finishing with an error. Resetting the Default <servername> receive connector as per RobWill article link did allow for the Internet Connection Wizard tof inish correctly.
Afterwards I have added "SMTP Relay from LAN Devices" receive connector with scanner IP address, and it worked as it was supposed to from the begining.
0
 
Rob WilliamsCommented:
Great. Glad to hear pyotrek. Thanks for updating.
Cheers!
--Rob
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 10
  • 8
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now