• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 264
  • Last Modified:

VLC Media Player only plays DVDs when it feels like it

VLC Media Player is probably the best free DVD Video software that is free out there online.  It has a great equalizer preset bunch, you can stretch the video anyway you want it, and the volume control to 200 percent actually works.  It's pretty awesome.  Anyways, whenever I insert a DVD, only like 24 percent of the time will it actually load into VLC.  I click on File>Open DVD>Play File and it tries and loads and then just freezes the program or does nothing.  The only trick I have found is to pick it from AutoPlay if that pops up.  It usually plays then, but sometimes not.  Is there something I am doing wrong or doesn't the program recognize copy protected DVDs that well?  Most of the ones I try to watch are fairly new and probably have advanced copy protection on them.  The thing is, no matter what it always loads into Windows Media Player just fine.  But I like to watch them with VLC because of all the customization in it is fantastic.  Please help!
0
jschristian44
Asked:
jschristian44
  • 5
  • 3
  • 2
1 Solution
 
garycaseCommented:
Depending on the age of your system, this may be related to how CPU-intensive the DVD you're trying to play is with VLC's codecs.

Do a Ctrl-Alt-Del before you use VLC and minimize task manager => this will show a small rectangle in the notification area that lets you monitor CPU usage.

Now play (or attempt to play) one of your troublesome DVDs with VLC and look at the CPU usage.
0
 
MereteCommented:
Which version of VLC do you have?
Use the latest.
http://www.videolan.org/vlc/
Make sure WMP is not running in the  back ground or trying to access the DVD when you insert it.
Sometimes default players auto run when a disc is inserted please checkj your task manager

You keep mentioning copyrights or protected DVD that shouldnt come into the equasion here
VLC or WMP just plays the DVD as is.
They don't see whether it is protcted or not unless you copied it? or there is a fault in the DVD then they would spit out an error
But if WMP plays it then so should  VLC
All you can do to assist it is ensure you have a ffdshow installed it provide the directshow needed to play DVD  and other video.
http://www.videohelp.com/tools/ffdshow
Let us knwo how you go
Merete
0
 
jschristian44Author Commented:
the cpu theory sounds legit.  my cpu is pretty slow and that's the worst part of my system.  it is a 1.5 dual amd cpu and i thought it would be enough for me because its a dual core, but i guess 1.5 is just too slow.  i was having issues before when playing music and sound the cpu wouldnt work, but that was fixed with an update so it is all good now.  i don't know what else to do.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
MereteCommented:
If it plays ok in WMP I would imagine WMP uses more CPU than the open source VLC which uses less, shouldn't be the CPU is too slow
refs to>
no matter what it always loads into Windows Media Player just fine<< holds a key
0
 
garycaseCommented:
Media Player and VLC use (or at least CAN use) different codecs.   VLC tends to be very powerful, but also fairly CPU-intensive.    If you're trying to play media that run ups the CPU to 100% that easily explains what's happening.    But before simply assuming that's the issue, do as I suggested earlier and monitor the actual CPU usage.    If it's "pegging the meter" (i.e. hitting 100%) then that's almost certainly your problem.    If not, there are other things to look at.
0
 
jschristian44Author Commented:
Yeah it definately gets up to the 100 percent.  Everything else on this laptop works great except this darn slow CPU.  I thought a dual 1.5 ghz would be fast enough for most of the stuff I do.  I don't game really anymore and I thought a dual core would be enough.
0
 
jschristian44Author Commented:
I guess I will just use Windows Media Player since I don't have any more options.  I have tried other free ones like VLC but most of them don't even play DVDs and no one comes close to the options VLC has.  Anybody got any other advice like turning off all processes or something that could help?  I have Advanced Systemcare 4 if that helps?
0
 
garycaseCommented:
Leave Task Manager in a full window and watch the Processes tab when you play something with VLC.   By default it should be ordered by the CPU column -- you can ensure that by clicking on CPU (if it's in the wrong order, just click again, which will toggle between descending and ascending) ... you want descending, so the process with the highest utilization is on top)

This will show if there are other processes besides VLC using a significant amount of the CPU -- if so, you could try stopping those to free up more resources for VLC.

Thinking a bit more about this, I think your issue is that Media Player is using the hardware decode assist features of your video adapter; but VLC is not.    A few years ago, VLC did not support hardware decode on graphics adapters, but I'm fairly sure the newest version does.    With hardware assist, the CPU usage should be MUCH lower [Look at the CPU utilization when you play a DVD with Media Player to confirm this].    

Look at Tools - Preferences - Video and be sure the "Accelerated video output" and "Use hardware YUV->RGB conversions" boxes are checked.     You may also want to change the Output mode from "Default" to "Direct-X"
0
 
jschristian44Author Commented:
thanks garycase, i think you helped me with something else in the past and you have been spot on.  thanks again!
0
 
jschristian44Author Commented:
Thank you!
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 5
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now