Cisco VoIP and Data over T1

I have several sites VoIP through fiber connections and switches.
I have added 2 2901 routers connecting through a T1 to my Remote site to Internal Network.
I need to prioritize or isolate (by vlan) the Voice Network traffic and am unfamiliar with routing VoIP. At this point all IP traffic is working successfully, even VoIP Network is working, but I want to make sure quality stays Good.

Local Data Vlan 1 name Default      10.10.0.0 255.255.0.0
Remote Data Vlan1600 name Remote1      10.50.1.0 255.255.255.0
Voice Vlan109 name voice109      10.1.9.0 255.255.255.0      
(IPs have been change to protect the innocent)
I need the best way (Vlans, QOS, etc.) and the commands to implement it.
      
Below are the two configs so far
RouterA
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
clock timezone CST -6 0
clock summer-time CDT recurring
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
ip domain name yourdomain.com
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-25
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-25
 revocation-check none
 rsakeypair TP-self-signed-25
!
!
crypto pki certificate chain TP-self-signed-25
 certificate self-signed 01
  3082022B 30820194
        quit
license udi pid CISCO2901/K9 sn
!
!
username XXX privilege
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description Internal Network
 ip address 10.10.0.1 255.255.0.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description $ES_LAN$
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 description T1 connection to RouterB
 bandwidth 1536
 ip address 192.168.1.13 255.255.255.252
 encapsulation ppp
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 10.10.1.1
ip route 10.1.9.0 255.255.255.0 192.168.1.14
ip route 10.50.1.0 255.255.255.0 192.168.1.14
!
!
!
!
control-plane
!
!
!
line con 0
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server 10.10.1.5
end

RouterB
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterB
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
clock timezone CST -6 0
clock summer-time CDT recurring
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
ip domain name yourdomain.com
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-31
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-31
 revocation-check none
 rsakeypair TP-self-signed-31
!
!
crypto pki certificate chain TP-self-signed-31
 certificate self-signed 01
  3082022B 30820194
        quit
license udi pid CISCO2901/K9 sn
!
!
username XXX privilege
!
!
!
!
!
!

interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description Remote Data Network
 ip address 10.50.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description Remote Voice Network
 ip address 10.1.9.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 description T1 connection to RouterA
 bandwidth 1536
 ip address 192.168.1.14 255.255.255.252
 encapsulation ppp
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 192.168.1.13
!
!
!
!
control-plane
!
!
!
line con 0
 password mesquite777
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server 10.10.1.5
end



dvandusenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Darrell PorterEnterprise Business Process ArchitectCommented:
So the first thing I would do is change your password from mesquite777 to something else, if that's really the password. :)

I'll put together the configuration changes at lunch and post them up here.
0
dvandusenAuthor Commented:
Dang it, I thought I caught everything.
That is no longer my password.
0
jjmartineziiiCommented:
Assume your clip traffic is being Mark with Cisco style tags, you can use coexist autoqos commands to setup qos on your devices. You want to prioritize blip traffic and qos is the tool to do that.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

dvandusenAuthor Commented:
Do you know the commands to prioritize this traffic and what ports to add them to?
 
0
dvandusenAuthor Commented:
Unless I'm missing it the autoqos command is not available on the 2901.
Any other ideas.
0
dvandusenAuthor Commented:
Cisco said to use DSCP for this
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dvandusenAuthor Commented:
Got final answer from Cisco tech
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.