?
Solved

$word = new COM("word.application"); Fails in PHP on Server 2008 R2 64bit IIS7

Posted on 2011-10-27
7
Medium Priority
?
681 Views
Last Modified: 2012-06-27
I have a script that works on other servers running XAMPP but when I have a script run on IIS7 on a Server 2008 64bit the script halts and does not work.
I have traced it down to the following line causing the error
$word = new COM("word.application");

I have installed OFfice 2003 32bit
I am running the application pool for this site in 32bit mode
I have set the DCOM permissions to Interactive User
but still the script is not able to access the COM("word.application").

Anything I am missing?  The display just goes blank when it gets to that line.
0
Comment
Question by:yoshcomputers
  • 4
  • 3
7 Comments
 
LVL 6

Expert Comment

by:regevha
ID: 37043121
You may find running the following command will solve the problem you are facing:
mkdir c:\windows\syswow64\config\systemprofile\Desktop

Based on MSDN blog
0
 

Author Comment

by:yoshcomputers
ID: 37043293
I had already tried that from a posting on another forum.  Still no luck.
0
 
LVL 6

Expert Comment

by:regevha
ID: 37043309
I recommend to read the whole blog post, it includes additional information regarding a problem which is very similar to the problem you are facing.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 

Author Comment

by:yoshcomputers
ID: 37051505
Yeah, I had been there and tried a bunch of the suggestions including the Registry hack....Is there a particular suggestion you thought was the correct answer?  I didn't try them all.

To add more fuel to the discussion, I removed Office 2007 and installed 2003 to see if that made any differnence.  Nope.  No ability to access it.
I am feeling like it is a IIS7 configuration/security thing that is affecting it.
0
 

Accepted Solution

by:
yoshcomputers earned 0 total points
ID: 37053923
I tried them all and none of those suggestions work.  
In the end I installed XAMPP and set it to run on a different port.  Since I couldn't use your solution I am not awarding any points.
0
 
LVL 6

Expert Comment

by:regevha
ID: 37055057
OK, you may close the question as soved by author
0
 

Author Closing Comment

by:yoshcomputers
ID: 37098922
No actual solution was provided...just installed a work around instead
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

3 proven steps to speed up Magento powered sites. The article focus is on optimizing time to first byte (TTFB), full page caching and configuring server for optimal performance.
I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.
The viewer will learn how to create a basic form using some HTML5 and PHP for later processing. Set up your basic HTML file. Open your form tag and set the method and action attributes.: (CODE) Set up your first few inputs one for the name and …
Suggested Courses
Course of the Month13 days, 13 hours left to enroll

755 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question