Pervasive and Accpac

Hi all Accpac/Pervasive experts,

I have an issue with one of clients which still runs  Accpac 5.2A and Pervasive 2000i database.  As you can all see the system is old but hardware is even older and is on its way out...so it needs replacement very soon  

So we want to transfer Accpac 5.2A  to a newer system, in this case Windows 2008 SBS  64-bit version.  Due to the fact that he has only 2 Accpac users at any given time (LANPAK is 2 license) I have decided to install Accpac on the server and then run it via TS for these 2 users

Here is what I did so far

1.  Installed Accpac 5.2A  on Win 2008, applied the latest patches available for this version
2.  Installed Pervasive 11 64-bit   on Windows 2008 server
3. Create system and company databases
4.  Create System DNS entries, one pointing to sytem database and one to company database

     NOTICE 1:  I used Pervasive ODBC interface 64-bit version which was, I assume, installed by
                    installation process of Pervasive v 11
      NOTICE 2 :  I did NOT install Pervasive Client 32-bit edition which is available on the media,
                        hence I did not have the option to create a 32-bit DNS entry

   5.  Verify the macro and make sure that they don't crush when they run
   6. Dumped data from old system and upload in the new company database just created

Everything works OK, the system is fast but there's one problem.  There are missing records(data) which I noted when running the macro. Crystal Report in preview mode shows no data, just the page frame with no data.  However some other records are showing correct data.  

In my opinion (not an Accpac neither a Pervasive expert) it might be 2 things causing this problem

1.  I made a mistake during dump/upload process
or
2.  I have to install Client 32-bit from Pervasive CD, create 32-bit DNS for System and Company database and then use them instead of 64-bit

Thank you all for spending time reading my post and for any hint you might have


Cheers



     Next steps



BibecuAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bill BachPresidentCommented:
Pervasive PSQL v11 can read and write the same files that PSQL2000i can read and write.  Instead of step 6, you should have just been able to copy over the database files from the old server to the new one.  I don't know what process you used to dump & upload, but I would recommend just copying the files over & see if that fixes it.
0
mirtheilCommented:
Can you create a new report and does that show the "missing" data?
Is all of this running on one machine (the server)?  If so, even installing the 64 bit server engine will get you the 32 bit components.  You may need to create a 32 bit DSN and can do so either in the 32 bit ODBC Adminstrator (in c:\windows\syswo64\odbcad32.exe not c:\windows\system32\odbcad32.exe).  
Does the PCC show the missing data?   If it does, then the problem is in the Crystal side of things.  If it doesn't then the dump/upload process might be at fault.  
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BibecuAuthor Commented:
Thanks Bill.  I think you refer to copy the files from \ACCPA\DATA\COMPANY\  directory  from old server onto the new one.  (DDF and DAT files)   I will try that and let you know

I used Accpac built-in database dump and uplod process
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Bill BachPresidentCommented:
Exactly.  You should be able to directly copy the files from the old system to the new one, if it is the same version of Accpac.
0
BibecuAuthor Commented:
Thanks Bill and Mirtheil for your prompt answers and suggestions, I will do it in the afternoon  ( I am EST zone) and let you know
0
BibecuAuthor Commented:
Update:
In the new system I have created a new database/company  and then copied the DDF and DAT files over from the old system.  Tried to run the macros, same issue,  they work correctly for some records and do not work for others.

To answer mirtheil's question, yes, everything is installed on the server so I got both 64 and 32-bit components.  I have tried with both, the issue remained

At this point I think is a Crystal issue, I will investigate and let you know

Cheers  
0
BibecuAuthor Commented:
Thank you BillBach and Mirtheil for the solutions. The issue was actually a combination of ODBC and dump/upload

I have divided the points because

-BillBach provided the tip of copying the files instead of doing a DB dump/upload (something was wrong with the dump/upload process)

-Mirtheil for tip of using ODBC 32-bit

Thank you both for the time and effort

Cheers
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Databases

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.