• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 406
  • Last Modified:

can't use wakeonlan to bring up server, hanging on PXE waiting for boot file name

I'd like to be able to use wakeonlan from one linux server to bring up another linux server. Problem is, the client wants to do a PXE boot and waits for a boot file name (I guess from the DHCP server) and never falls back to booting from it's local HDD. Is there a DHCP option I'm missing, or something else that will tell the client to fall back to a local boot?

For information, my DHCP server is windows server 2008, and I have no PXE servers on the network that would be able to service this kind of request. I only want to use wakeonlan to power the machines up without having to be in the same room as them, not for remote deployment or anything. Don't know the model of NIC on the clients off the top of my head, but can find out if it would help.
0
Joe_Pritchard
Asked:
Joe_Pritchard
2 Solutions
 
joolsCommented:
It sounds like the server is waking up ok but the BIOS settings on the server are set to just boot from the network. Check the server you are waking up.
0
 
vivigattCommented:
You have to make sure that:
- The server you want to wake up can local boot. Check BIOS settings and local HDD sanity. Just try a manual power-up and check that the server is actually booting as expected.
- The Wake On Lan feature does not chain to PXE boot. Check the NIC configuration, especially PXE and WoL configuration.

In case you don't want to spend more time on that, I can let you have a small PXE boot file that will instruct the machine to boot off the local HDD. You would just need to have a TFTP service on your DHCP server and to configure one DHCP option. But I think you'd prefer to set up your WoL system so that it works as expected.
0
 
d_nedelchevCommented:
Some OEM machines has different boot order for a normal power up and wake on LAN. I would suggest checking the BIOS for those settings.
0
 
Joe_PritchardAuthor Commented:
Vivigatt, thanks for the information, your second point was correct, the server's first priority boot target was 'network/PXE' Also, thanks for the suggestion of the boot file, but you're right I'm glad it turned out not to be neccessary!

Nedelchev, you were right about there being different settings for a normal boot as opposed to a network boot. Normal boot order was set to network as fourth priority after CDROM and HD1 and 2, but the network boot order was in a different area in the BIOS, so I had missed it.

Thanks, this is going to save me a lot of time!

Joe
0
 
joolsCommented:
Glad you got it sorted.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now