• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 441
  • Last Modified:

I am unable to launch a web app, I am prompted that I need .NET framework 3.5 SP1, even though it is already installed.

I get this error with two different OS's(7,XP) and two different versions of IE(8,9). So I am guessing that it isn't os/ie related, because I also have users on the same setups where it works. I am trying to access a local database site on our server, we access it through the web, but it is locally hosted. The page brings up a popup web app , but I have users that arent getting the popup and the website just appears to be loading , but never fully loads. I've attached the prompt message below.

Thanks in advance,   error
0
KH_IT
Asked:
KH_IT
  • 2
  • 2
1 Solution
 
KH_ITAuthor Commented:
ps. I've disabled the popup blocker and set the security settings to medium-low in ie to troubleshoot this and I it still doesnt work
0
 
David Johnson, CD, MVPOwnerCommented:
it checks the user agent in the browser and looks for  "runtimeVersion = "3.5.30729"
https://deltek.custhelp.com/app/utils/login_form/redirect/home/session/L3NpZC9xSjdQUE9Iaw==

if the installer runs on your system change the javascript to just look for "3.5" versus '3.5.30729' this will be on your iis server
0
 
David Johnson, CD, MVPOwnerCommented:
that or through windows updates you will need to get service pack 1 for .net 3.5
0
 
KH_ITAuthor Commented:
@ ve3ofa : thanks for the suggestions, I will try to implement this fix and get back to you when I do so.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now