Firefox Displays Partial Image, Then Blurred

Hello Experts,
Strange Issue ~
Some pictures / images are not displaying properly in Firefox, and I cannot seem to find why. If I check the image in Internet Explorer, they display fine. I've Googled around, but it's an issue that's tough to explain, but easy to show. (image attached - Firefox vs IE)

This doesn't happen with all images, not even a majority, just certain images from any page...

Thanks for your help!

Image problem replicated from Amazon.com:
http://ecx.images-amazon.com/images/I/41ALcMtCc1L._SL246_SX190_CR0,0,190,246_.jpg Image_Trouble
LVL 7
ottobockAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
You would have to give us the link to the page where the problem is.  The image isn't the problem.
0
ottobockAuthor Commented:
I know the image itself isn't the problem. But I did add a link to an image with the issue, as shown in the screenshot...

http://ecx.images-amazon.com/images/I/41ALcMtCc1L._SL246_SX190_CR0,0,190,246_.jpg
0
Dave BaldwinFixer of ProblemsCommented:
It's not a problem from here in Firefox 7 which is why I though you had it on another page.
0
ottobockAuthor Commented:
I cannot find why firefox does this. Left image is firefox 7, right is IE9. If I even right-click > Save Image As from Firefox, I get the 1/2 image. Totally strange. In IE, if I save the image, it's saved fine.

If I google anything, and go to images, the same mess appears. Most pics are OK, some random ones are 1/2-OK, 1/2-nothing. Again, only in FF - not IE.

I hope I'm making sense. I wouldnt post it on EE if it didnt confuse me a bit too.
0
Dave BaldwinFixer of ProblemsCommented:
Try starting Firefox without any add-ons and see if it still happens.  From http://news.cnet.com/8301-13880_3-10081925-68.html :

"To disable all of Firefox's add-ons, you have to open the browser in its Safe Mode (no relation to Windows' own Safe Mode) by clicking Start > All Programs > Mozilla Firefox > Mozilla Firefox (Safe Mode). A quicker way is to press the Windows key (in XP, follow this by pressing R), type Firefox -safe-mode, and press Enter."
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.