?
Solved

Can't send mail

Posted on 2011-10-30
4
Medium Priority
?
340 Views
Last Modified: 2012-05-12
Iphone 4 - OS 5
Didn't have this problem on my iphone 3.

Main mail account - exchange works fine
Second account - (home ISP account)
Receives mail fine but if I try to reply to one of these emails or compose one using the home account I get the message the address <my home address> is rejected and the message has been placed in the outbox.

If I open the email address from the outbox and change the from field and make it the exchange account then it sends fine.

I have treble checked the SMTP settings on my home account and all looks fine.

Could it be that my home account is attempting to send email using the exchange server and this is rightly blocking relaying?
0
Comment
Question by:QPR
  • 2
4 Comments
 
LVL 4

Expert Comment

by:Teargas
ID: 37054087
have you tried to change it from pop3 to imap? and it shouldn't use the other account because the smtp settings are set for this account and for this only
0
 
LVL 29

Author Comment

by:QPR
ID: 37054156
Aren't we talking SMTP as opposed to pop? I can receive fine. Just can't send/reply to an email if the "from" field shows as the home account. Switch it to the exchange account and it's fine. The SMTP settings for the ISP account are tghe same as they are set up at home and on my previous iPhone

0
 
LVL 9

Accepted Solution

by:
mmusurlian earned 2000 total points
ID: 37054533
because your issue is sending not receiving, I would check to see if you have an authentication issue on your home ISP account. Many of them require auth to send mail. Many times, it is just entering your username (email address) and password or checking a tick box saying use the same settings your use for receiving mail (which is the username and password for the account). Just a thought...
0
 
LVL 29

Author Closing Comment

by:QPR
ID: 37054591
How embarrasingly simple! I added my username and password under smtp settings and set authentication to password and it worked fine.
Not sure why I need to do this as I didn't on my previous iPhone (3) and don't have to specify when using my ISP account through Outlook.
Oh well, sorted now. Thanks
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Learn new improvements released by Google for Google Calendar. Noted in this article are simple tips and tricks that can make your everyday use of Google Calendar better.
Set up iPhone and iPad email signatures to always send in high-quality HTML with this step-by step guide.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question