Fonts in MSIE9 still not working properly

Due to an error, I lost all my fonts. I recovered them all, but I am still having problems in MSIE9 (I am using windows 7 64 bit). On certain sites, such as wordpress sites, the fonts do not appear properly. When copied and pasted to word, the font states it is helvetica. I have already gone to the advanced tab and clicked on reset. That didn't help. What do I do now.

The image below shows a wordpress page. The text on the left is from google ads, and looks fine. The text on the right is from the blog and is now very hard to read. Previous to the error on my computer, everything was fine.
 Image from a wordpress page
Lev SeltzerAsked:
Who is Participating?
 
Lev SeltzerConnect With a Mentor Author Commented:
I found a solution. On the Microsoft IE9 board, someone suggested turning on "Ignore font styles specified on webpages" via the ACCESSIBILITY option. I did and the fonts displayed properly.
That got me thinking that it was a specific font problem. I found the helvetica font file Helvet77.TTF and moved it out of the font folder (I wanted to keep a copy in case this didn't work. Do you know how difficult it is to move a font file out of the font folder? I ended up using a CMD window to MOVE it!). I then rebooted.

Wow.The websites that didn't work before now work perfectly!

I assume that the Helvet77.TTF file must have been corrupted in some sense. I do not know where it came from, and why windows decided to use this file now, rather than another file, for the website.

Thank you again to everyone for all your help.
0
 
Run5kConnect With a Mentor Commented:
Just to double-check, have you already tried to execute a System Restore to a point prior to the error and/or loss of your fonts?

How to Do a System Restore in Windows 7

Windows 7 System Restore FAQ
0
 
johnb6767Connect With a Mentor Commented:
If that doesnt work for some oddball reason....

How to restore Windows 7 default fonts.
http://answers.microsoft.com/en-us/windows/forum/windows_7-desktop/how-to-restore-windows-7-default-fonts/73a8eb3e-3189-4514-b87c-18fcdca4fe26

Just type Fonts in the start menu search box (slowly), and hit enter. Click the second link from the top......

Then click the button in the following screenshot, to reset the Fonts.......

http://www.thewindowsclub.com/how-to-restore-default-fonts-in-windows-7
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
Lev SeltzerAuthor Commented:
System restore had been turned off, so that is not an option.
I had previously clicked the "restore fonts" button, and nothing happened. I did it again now and there were no changes on MSIE.
I tried FireFox and these wordpress pages display properly.
It is possible that I am missing a font that MSIE expects. I do not know what the default fonts are in MSIE or how to change them.
0
 
Run5kCommented:
That's unfortunate.  If you don't mind me saying so, with the advent of the Windows 7 generation of operating systems it normally causes more problems than it solves to turn off the System Restore function.  Unless there is a specific, compelling reason to do so, you lose some extremely valuable capabilities when you disable this feature.  In addition to dropping back to a previous stable or error-free snapshot of the operating system itself, you also lose the terrific Restore Previous Versions function:

Restore Previous Versions of Files in Every Edition of Windows 7

Windows 7 Restore Previous Versions FAQ
0
 
Run5kConnect With a Mentor Commented:
That being said, if you already restored the default Windows 7 fonts perhaps there is now something problematic with IE9 itself.  It might be prudent to backup your IE9 personal settings (bookmarks, cookies, etc.), remove it, and then re-install it:

Control Panel -> Programs and Features -> View Installed Updates (on the upper-left)

Scroll down until you find Windows Internet Explorer 9.  Highlight and click the Uninstall button.

As an alternate method, you can open up a command prompt with full admin rights... Start -> cmd -> Ctrl+Shift+Enter -> acknowledge the UAC prompt.  Within the elevated command prompt, paste in the following, run it and then reboot:

FORFILES /P %WINDIR%\servicing\Packages /M Microsoft-Windows-InternetExplorer-*9.*.mum /c "cmd /c echo Uninstalling package @fname && start /w pkgmgr /up:@fname /norestart"

If that doesn't work and you have also installed Windows 7 Service Pack 1 already, you may need to weigh your options.  If you really don't like IE9, you would potentially need to temporarily uninstall SP1, then uninstall IE9, ensure that IE8 is working, then re-install SP1.
0
 
Lev SeltzerAuthor Commented:
I did not say that I turned off system restore. Only that it had been turned off. I do not know why this was so. Unfortunately, windows 7 does not alert me when the system restore function has been turned off, and so I naturally assumed that it was on - until I discovered that this was not the case.
0
 
Run5kConnect With a Mentor Commented:
That truly is unfortunate.  Sorry for the misunderstanding, but I can certainly empathize.  It is definitely frustrating when the hard-working IT administrators are blind-sided like that.

Hopefully we can team up still get that machine back to normal.  As a last resort, there is always the Windows 7 in-place repair install.  It should restore everything back to normal while still preserving all of your critical data:  user accounts, applications, and personal files/folders.

How to Do a Repair Install to Fix Windows 7
0
 
Lev SeltzerAuthor Commented:
I removed MSIE9, then reinstalled. the display problem was not resolved.

I don't want to do the in-place repair install, as it can take quite a long time, and I just don't trust that it will not introduce other problems.

I think I might just resign myself to living with this problem until I purchase a new computer and reinstall windows on that computer.
0
 
Run5kConnect With a Mentor Commented:
I certainly can't blame you for wanting to be relatively conservative.  I tend to be the same way with my Windows builds.

On the other hand, keep in mind that an in-place repair really wouldn't take that long... perhaps a couple of hours.  Additionally, the chances of of "introducing other problems" are extremely small.  You are essentially starting over with a fresh load of Windows 7 that automatically imports your previous applications and settings.  In other words, there wouldn't be any new problems and it would probably resolve the ones that you already had.
0
 
johnb6767Connect With a Mentor Commented:
"On certain sites, such as wordpress sites, the fonts do not appear properly. When copied and pasted to word, the font states it is helvetica. I have already gone to the advanced tab and clicked on reset. That didn't help. What do I do now."

Can you go into the View>Source and see what Font it is looking for?
0
 
Lev SeltzerAuthor Commented:
The font family is: helvetica,trebuchet,arial,sans-serif.
This is on another site that I have no control over.



Note ta
wp-Editor.JPG
0
 
Lev SeltzerAuthor Commented:
to continue from my previous comment, the word press editor that I use also has a problem. However, if there is a solution within WordPress, then I can implement that.

Again, I had no problems with either site before I lost my fonts and had to reload them all.
0
 
Lev SeltzerAuthor Commented:
I finally had the opportunity to run the windows in-place upgrade.
IT took several attempts and several hours. In the end, I got a message that the installation would not work until the system rebooted. It did reboot, but there was no change.
0
 
Lev SeltzerAuthor Commented:
I ran the upgrade again. This time I am sure it ran properly.

There was still no change in the display.
0
 
Lev SeltzerAuthor Commented:
Any other ideas?
0
 
Run5kConnect With a Mentor Commented:
It's really surprising that an in-place repair install didn't fix the problem.  Hopefully the Experts Exchange "call to arms" will generate some additional feedback that will allow us to solve this together!
0
 
David Johnson, CD, MVPConnect With a Mentor OwnerCommented:
if you can get access to another computer running any version of windows 7 copy the c:\windows\fonts folder to a usb key and then copy these files onto your computer overwriting as required.


0
 
Lev SeltzerAuthor Commented:
I copied all the fonts from a different windows 7 computer. 4 fonts failed to copy, including GlobalMonospace.CompositeFont, GlobalSansSerif.CompositeFont, GlobalSerif.CompositeFont and GlobalUserInterface.CompositeFont.
I restarted MSIE9 and it still did not display properly.
The sites display properly in FireFox.
0
 
MereteConnect With a Mentor Commented:
When you copied these fonts over did you actually install each one?
r/click it and install?
or just paste them into the fonts folder?

The font family : helvetica,<< this font is not free and based on that maybe the previous version you had has lost it's regestration to you?
http://www.linotype.com/526/helvetica-family.html
trebuchet,arial,sans-serif.<< these are pretty normal
And these>
GlobalMonospace.CompositeFont, GlobalSansSerif.CompositeFont, GlobalSerif.CompositeFont and GlobalUserInterface.CompositeFont.<<  Composite Fonts
http://msdn.microsoft.com/en-us/library/system.windows.media.fontfamily.aspx
Microsoft Windows 7 & fonts
http://www.prepressure.com/fonts/basics/windows-7-font-handling

These CompositeFont files are bundled within the .NET framework 3 or higher
you could try and uninstall your version of .net and re-install it
in the Add or Remove Programs, check which version of the .netframework you have, and uninstall it and reinstall the same then update it
if you have 3 reinstall 3 then upgrade to 4
you should see some of these reappear in your Fonts folder.
http://www.microsoft.com/download/en/details.aspx?id=17113
0
 
centervConnect With a Mentor Commented:
Things to consider:
When copy/pasting to wordpress, avoid pasting to/from Word at all cost if possible.
Use a text editor such as Textpad ot Notepad++  preferably.  At the very least, strip the formating from Word if you must use it or go to WordPad.

See these other options as well

http://www.liveside.net/2010/09/18/ie9-that-thing-about-fonts/ 

http://tndhuy.wordpress.com/2011/01/01/debugging-a-css-issue-with-ie9-mtley-cre-edition/ 
0
 
David S.Commented:
Has anyone considered the possibility that this might be a ClearType problem? How to adjust ClearType in Win7
0
 
Lev SeltzerAuthor Commented:
I removed all .NET programs, rebooted, reinstalled. NO change.
I ran the clear type adjuster. No change.
This happens on sites created by other people - not just my own wordpress sites. For example:
http://syosset.patch.com/
 Syosset Patch imageIn any case, I always strip formatting from my WordPress entries.
I never purchased helvetica. I just used whatever fonts MSIE displayed, and never thought about anything.
I didn't see anything on LiveSIde that was applicable to my situation.
Note that when I increase magnification to 180%, the fonts look perfect.

Any other thoughts?
0
 
MereteConnect With a Mentor Commented:
yes this had crossed my mind>when I increase magnification to 180%, the fonts look perfect<<
Then that must be the problem,
How much  have you  tinkered with settings throughout internet explorer
most web pages are viewed at 125 zoom, but again depending on how the page ie represented
The fact firefox displays the pages fine and internet explorer does at 180%
open the VIEW in internet explorer9
check the difference between font size  used "medium"
and zoom ( 100%) standard  or you can use custom
try increasing Font Size and reducing the zoom or vide versa
In internet options general have you looked in the Fonts used here Latin based >Times New Roman>Courier New
and in accessibility> formatting all unticked?
Colours<use windows

0
 
centervCommented:
Check for proper setup or correct graphics card driver
0
 
Lev SeltzerAuthor Commented:
I do not think this is a screen resolution or a graphics card/driver problem. The problem started when I uninstalled a program, and the automated uninstallation procedure removed all my fonts.

When I go to a particular website that displays hebrew characters, they are not displayed properly:
 Hebre websiteNotice that the top line is correct. It is set to display in the font "arial". The other lines are set to display in "david" which is a valid font on my computer.
I tried another computer in my home and copied the fonts from there. The composite fonts did not copy once again, but everything else did (including another DAVID font) and still the hebrew and the english do not display properly as before.

Most websites continue to display perfectly at 100% resolution. That is why I believe this is a font configuration problem.

Thank you for any help you can offer.
0
 
MereteConnect With a Mentor Commented:
ok running out of ideas here
what did you uninstall that could remove your fonts, dont be shy we're here to help not be nosey or anything.
Was it a language pack?
Put it back?
Was it Java?
Office? or Office.org? all of these may effect fonts behaviour
I feel we are have to use guess work until all the details are provided then it's more precise.

with refs to the vidia card
Disable hardware accelator  Internet Explorer 9. go to
 Internet Options on the Tools menu.
Advanced tab, at the top of the list > Accelerated graphics section.
 select > Use software rendering instead of GPU rendering check box.
 Apply, and then click OK.
Close all open Internet Explorer 9 windows, and then restart Internet Explorer 9.
Check.
maybe the unicode is not working right
check these
Old version
How do I fix Unicode display problems on my computer?
http://unicode.org/help/display_problems.html
Enabling Unicode in Your Browser
I'm still seeing little boxes! What to do
http://www.sacred-texts.com/unicode.htm
0
 
centervConnect With a Mentor Commented:
Can you reinstall that program and see what other fonts it may install as part of that package?
0
 
Lev SeltzerAuthor Commented:
centerv: Spybot was in beta test, and there must have been something wrong with the uninstall program, which is why it removed all my fonts. As stated earlier, the recovery program had been turned off, so I could not easily recover the fonts.
0
 
Run5kConnect With a Mentor Commented:
WEBuilder, if you don't mind me chiming back in again, I have a few pieces of friendly advice to pass along that may not help at the moment, but could definitely prove beneficial in the future:

- Spybot Search & Destroy really seems to be well past its prime.  These days many of us have one active antivirus application installed on our Windows builds along with one on-demand malware application.  Quite often, the latter choice is Malwarebytes.  It is updated constantly, very fast & light on system resources, and it never seems to cause any problems with the operating system.

- Utilizing any type of Beta-status software on a machine that you are genuinely relying upon for important data and/or functions is very risky.

- As I mentioned earlier, it's critical that we keep the System Protection settings maintained so that we still have System Restore points.  It sounds like either an end-user with admin rights or a rogue application turned them off.  Either way, it's very unfortunate.

That being said, I was the one who enlisted the help of the moderators to generate some additional input for your problem, and I am certainly glad to see so many of the EE community's technical geniuses join forces in an effort to help.  Hopefully we will be able to get your system back to normal!
0
 
MereteConnect With a Mentor Commented:
WEBuilder, thank you for providing that, if the other suggestions I provided dont help
Spybot has/d a system restore. so that you can undo any files it delets.
The problem with Spybot in itself  is fine but is the Resident TeaTimer program, this little tool has caused numerous issues even to the point of having to re-install winmdows becuase the HDD had become unstable and windows corrupted.
http://www.safer-networking.org/en/tutorial/index.html
Which it seems to point to in your situation.
You can try running a system file checker first
go to the start>run>type in    sfc /scannow  exactly as is and then press enter
http://www.intowindows.com/how-to-repair-windows-7-system-files/

However this point I feel it would simpler to run a repair re-install or a Start-up repair.
To fix the regestry and restore your windows integrety.
Using this method you are offered several choices one being to restore your system to an earlier point.
A Repair Installation or Startup Repair of Windows  when you need to reinstall important Windows files but keep all of your personal files and programs intact.
A Repair Install can be thought of as a "copy over" of Windows.
http://www.windows7professional.windowsreinstall.com/repairwin7startup/indexfullpage.htm
 http://pcsupport.about.com/od/toolsofthetrade/ss/windows-7-startup-repair.htm






0
 
Run5kConnect With a Mentor Commented:
Hi, Merete!  Nice to work with you again.

We already suggested that he perform a repair install a few weeks ago (http:#37055116).  From what he described, he actually attempted it more than once (http:#37093234 and http:#37098457).  However, apparently that still didn't fix the problem, which was very surprising.
0
 
MereteConnect With a Mentor Commented:
Hi Run5k, thankyou for the quick links and the point of course I missed them,, very long threat to go back...
 wow!!   very surprising  still no resolve.
I feel there is more to this now, looking at the Fonts types that will not install or is that really a problem?
This a multiple problem and seems to point to certain web sites that use certain Fonts not native to windows
let me recap for eveyone.
Straightup webman said>>In any case, I always strip formatting from my WordPress entries.<< really
>>>I never purchased helvetica. <<did you make a web based one yourself??
Unicode?

I just used whatever fonts MSIE displayed, and never thought about anything.<<<<
Note that when I increase magnification to 180%, the fonts look perfect<<<OKAY
And>>
Most websites continue to display perfectly at 100% resolution. <<OKAY
That is why I believe this is a font configuration problem.<< a little conflcting if they function correctly at different zoom levels.
So why not just adjust the zoom level>or resolution?
------------------------------------------------------------------------------------------
The rest of this is it really relevent?
wordpress page.<< but these Fonts although dislpayed shaded out
displayed when viewed 180?<<OKAY

then we have this reference>
the word press editor that I use also has a problem.<<< However, if there is a solution within WordPress, then I can implement that.
Uninstall it and reinstall
12 WordPress Editors you can choose
http://www.iamkarthik.com/12-wordpress-editors.html
------------------------------------------
This one>
When I go to a particular website that displays hebrew characters<< functions ok by changing the resesolution?
And this one
The font family is: helvetica << not free ,trebuchet,arial,sans-serif.<< but displays okay at  100%??
And this one
4 fonts failed to copy, including GlobalMonospace.CompositeFont, GlobalSansSerif.CompositeFont, GlobalSerif.CompositeFont and GlobalUserInterface.CompositeFont.<< Unicode

It may explain why Spybot removed them as either they were illegal or corrupted in some way.
Spybot does not normally remove Fonts only nasties and spyware.
-------------------------------------------------------
I have not heard back from WEBuilder if actually installed the Fonts he copied, were they the Fonts themselves from the Font Folder then he will need to download the original again and " install" not just copy and paste from one windows 7 to another this does not install them.
On that windows has not identified with them ie Re- Associated
or the problem is not WINDOWS NATIVE FONT but rather these other.
Unicode ? Composite ??? Fonts Hebrew??
-----------------------------------------------
Control Panel\Appearance and Personalization\Fonts
Mine donot have the option to Install once installed, so if I copy them to another computer
And open them I donot see install
So I dont believe any that he copied over have actually re- installed.
And he wont be able to with  the heluca since it is not free
The font family : helvetica,<< http://www.linotype.com/526/helvetica-family.html
Hebrew is not free Helvetica® Hebrew Family Pack
http://www.fonts.com/findfonts/detail.htm?productid=736609

The problem lies in Fonts that he has not purchased it seems to me.
And he has created Unicode representations.

Writing in Hebrew may require a special word processor and fonts and he is having problems with his wordpress.

Arial is an open Font  Arial is an extremely versatile family of typefaces which can be used with equal ... in reports, presentations, magazines etc, and for display use in newspapers, ...
 Hebrew and Arabic glyphs, with most of Arabic added on non-italic fonts
Since 1999, Microsoft Office has shipped with Arial Unicode MS, a version of Arial that includes many international characters from the Unicode standard.
 Tahoma is an OpenType font, it provides support for Latin and Hebrew scripts ... Once you link fonts, you can use the base font to display code points
OpenType Fonts
One of the biggest challenges in enabling the operating system for international character sets is the ability to select and display the right character or glyph. When editing a multilingual document
The Unicode–based OpenType font format has been developed jointly by Microsoft and Adobe; it extends the TrueType font file format originally designed by Apple. OpenType fonts allow rich mapping between characters and glyphs, thus enabling support for ligatures, positional forms, alternates, and other substitutions.
http://msdn.microsoft.com/en-us/goglobal/bb688134
Arial
http://en.wikipedia.org/wiki/Arial
-----------------------------------------------------------------
Short version I believe he has created some type  Unicode Fonts and these make windows see these as default Fonts>4 fonts failed to copy, including GlobalMonospace.CompositeFont, GlobalSansSerif.CompositeFont, GlobalSerif.CompositeFont and GlobalUserInterface.CompositeFont.<< Unicode
Unicode Fonts not free
look for any fonts in>GlobalMonospace.CompositeFont << 
Sorry for the lengthy article to make a point but the language sometimes escapes me.
 I just see it in my head
I'd look into Internet Explorer Fonts
and maybe a corrupted Office or Wordpress.
my opened Font  already installed no install option

opened-Font-no-option-install.jpg
iE-Font-settings.JPG
0
 
MereteConnect With a Mentor Commented:
To display an HTML page correctly, the browser must know what character-set to use.
HTML Character Sets
http://www.w3schools.com/tags/ref_charactersets.asp
How to Use Fonts on Wordpress
http://www.ehow.com/how_7558628_use-fonts-wordpress.html
How to Change the Font on Blog Post Titles in WordPress
http://www.ehow.com/how_8680702_change-blog-post-titles-wordpress.html

This should help you get rid fo the boxes in Internet Explorer
How to generate a list of Unicode characters with names and/or codepoints
http://people.w3.org/rishida/blog/
0
 
Lev SeltzerAuthor Commented:
I really appreciate all the help that everyone is offering. It is a bit overwhelming at times to try all the different solutions, so I apologize for not keeping up so well.

I have NOT created any custom fonts. I installed WIndows and used it normally. I tried the beta version of spybot, but decided I did not like it. When I uninstalled it, it removed ALL the fonts. It was the UNINSTALL program that removed the fonts, and not SPYBOT while it was scanning the computer!

I have several computers in my home with WIndows 7 and MSIE9, and all the websites mentioned in this thread display perfectly on these computers. The blogs that other people created with WordPress do not display properly on my computer, but display properly on the other computers in the home. While the WordPress editor (for my personal website) does not display properly on my computer, it does display properly on other computers (therefore, I do not want to investigate replacing the editor). I did not purchase Helvetica, yet these websites display perfectly (on other computers) without this purchase. I did not purchase any custom hebrew fonts, yet these websites display perfectly (on other computers) without this purchase.

0
 
MereteConnect With a Mentor Commented:
No worries WEBuilder sorry about  the lengthiness,
fonts that are managed by windows seem ok it is just these other Fonts.
Windows may have hidden them
http://www.prepressure.com/fonts/basics/windows-7-font-handling
Try the restore my computer to last known good configuration that worked?
Boot to safemode  advanced options
http://www.computerhope.com/issues/chsafe.htm
which is really the last ultimate fix maybe you have some spyware onboard
please install hijackthis save it a folder and extract it to the same folder do a system scan and save a log
takes about 4 secs to do a system scan
http://free.antivirus.com/hijackthis/
0
 
Lev SeltzerAuthor Commented:
As previously stated, system restore was turned off (I don't know how or why) so I could not restore the fonts.
I have attached the HiJackThis.log file below.
 hijackthis.log
0
 
MereteConnect With a Mentor Commented:
Many
Unknown file in Winsock LSP: c:\windows\syswow64\nmnsp.dll
to fix this use the winsock fix here
http://www.cexx.org/lspfix.htm

You have lots of unknowns in the Winsock
here's a short analyses all with ? are unknowns
[?] - C:\Program Files (x86)\CallStation\CStation.exe
[?] - C:\Program Files\CrashPlan\CrashPlanTray.exe
[?] - C:\Program Files (x86)\CallStation\CStation.exe
[?] - C:\Program Files (x86)\CE\CovenantEyes.exe
[?] - C:\Program Files (x86)\CE\CovenantEyesHelper.exe
----------------------------
[X] - R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = file:///E:/My%20Documents/Web/home.htm << fix this one in hijackthis rerun the select  it then select fix and ok
---------------------------------
[N] - O2 - BHO: Bing Bar Helper - {d2ce3e00-f94a-4740-988e-03dc2f38c34f} - "C:\Program Files (x86)\Microsoft\BingBar\BingExt.dll" (file missing)
[N] - O3 - Toolbar: Bing Bar - {8dcb7100-df86-4384-8842-8fa844297b3f} - "C:\Program Files (x86)\Microsoft\BingBar\BingExt.dll" (file missing)
[?] - O4 - HKLM\..\Run: [Microsoft Default Manager] "C:\Program Files (x86)\Microsoft\Search Enhancement Pack\Default Manager\DefMgr.exe" -resume
[?] - O4 - HKLM\..\Run: [NMSVC] C:\Program Files (x86)\CE\CovenantEyes.exe
[?] - O4 - HKCU\..\Run: [CallStation] C:\Program Files (x86)\CallStation\CStation.exe
[?] - O4 - Global Startup: CrashPlan Tray.lnk = C:\Program Files\CrashPlan\CrashPlanTray.exe
[X] - O10 - Unknown file in Winsock LSP: c:\windows\syswow64\nmnsp.dll
[?] - O16 - DPF: {1A1F56AA-3401-46F9-B277-D57F3421F821} (FunGamesLoader Object) - http://www.worldwinner.com/games/v47/shared/FunGamesLoader.cab
[?] - O16 - DPF: {8A94C905-FF9D-43B6-8708-F0F22D22B1CB} (Wwlaunch Control) - http://www.worldwinner.com/games/shared/wwlaunch.cab
[?] - O16 - DPF: {8F6E7FB2-E56B-4F66-A4E1-9765D2565280} (WorldWinner ActiveX Launcher Control) - http://www.worldwinner.com/games/launcher/ie/v2.22.01.0/iewwload.cab<<< this could be a nasty if it contaimns Dialer and Casino

[?] - O16 - DPF: {95A311CD-EC8E-452A-BCEC-B844EB616D03} (BejeweledTwist Control) - http://www.worldwinner.com/games/v51/bejeweledtwist/bejeweledtwist.cab
[?] - O16 - DPF: {C82BB209-F528-46F9-96D5-69DEF7260916} (MysteryPI Control) - http://www.worldwinner.com/games/v45/mysterypi/mysterypi.cab
[?] - O16 - DPF: {EDFCB7CB-942C-4822-AF14-F0B687409848} (Image Uploader Control) - http://www.fujiprintnet.co.il/Online/ImageUploader/ImageUploader4.cab
[?] - O23 - Service: Auth Service - Unknown owner - C:\Windows\system32\authServer.exe
[?] - O23 - Service: CrashPlan Backup Service (CrashPlanService) - CrashPlan - C:\Program Files\CrashPlan\CrashPlanService.exe
[?] - O23 - Service: lxdn_device - Unknown owner - C:\Windows\system32\lxdncoms.exe (file missing)
------------------------------------
Once you fix the winsock reboot
0
 
Lev SeltzerAuthor Commented:
>nmnsp.dll
This is used by CovenantEyes, which is a valid program that monitors my internet usage.

>http://www.cexx.org/lspfix.htm
It only found CESpy.dll to clean, and that program is also part of Covenant Eyes.

>You have lots of unknowns in the Winsock
I have gone through them all, and they are all for valid programs (e.g. Call Station telephone answering machine, Crash Plan online backup, etc.)

MSIE home page is my own HTML page. Very simple without any scripts

I used HiJackThis to remove "fix" (hopefully remove) all references to WordlWinner. There was no change in the fonts.
For other items with "file missing" I clicked on "fix this" but nothing happened - the error was still there when I rescanned.
0
 
MereteConnect With a Mentor Commented:
WEBuilder you've been very good to follow all of our suggestions but I feel we have reached the end of this.
Spybot may very well have damaged some areas of your windows regestry and only a clean install will fully fix it.
By that I mean a new install not a repair since you have tried that.
And it failed, on that it has to be the integrety of the regestry.
As even a new profile will not solve  a new account still associates with current windows regestry.

One last idea> you say there is no problem with the exact web pages on other windows 7 machines running IE9  as you have?
Did you try and  uninstall internet explorer 9
First, be aware that Internet Explorer cannot be completely uninstalled. Various components of IE are used and required by other applications as well as Windows itself.
 uninstalling IE9, is really attempting to revert to the previous version, IE8.
It is  not recomended.
You can do it but you will revert to IE8, if you did not IE 8 on before a new problem is caused.
Windows is damaged as windows updates will be psuhing out updates for IE 8 or IE9

I can perform this next phaze but  I dont know how experienced you are
consider taking your computer to a professional, they can re-install windows 7 to a new partition on your current HDD, this current windows would become Windows 7 old you will need
16 GB available hard disk space (32-bit) or 20 GB (64-bit)
therefor you can access it like on a slaved drive.
As I see it there is some form of corruption within your windows ( IE is part of windows)
( regestry is part of windows) and I mentioned earlier I have seen this before with the Resident TeaTimer program causing a full reinstall.
Leave this for a whiel and see if anyone else can offer more
Reread everything and see what you missed

The fact these are unusual Fonts not windows standard I have no idea.
And the web pages seem fine when used with a different zoom
I'm off as it's late here.
Regards Merete
0
 
Lev SeltzerAuthor Commented:
Merete: Thanks for the summary. Hopefully someone will come up with a solution - if not now, then in the future via another forum.

Thanks to everyone that has helped. If no one has further suggestions on a solution, then does someone have a suggestion on what to do with the points?
0
 
MereteConnect With a Mentor Commented:
Morning WEBuilder, EE is about exchanging knowledge so folks look up answers to solve their problem, in your case we could not solve it.
Giving points for effort is nice but doesnt provide any solutions.
Usualy PAQ or delete is done here unless the other experts who contibuted feel it is worth keeping it in our databse for a record, can't see why though as it doesnt provide anything other than the many varied troubleshoot methods we used.
So you go back to your original question at the top and click on the> request attention, and ask the mod to delete it, he will post's this request/ comment into your question and they get 4 days to object.
Then it is deleted. And your points refunded.
I truely wish we could have resolved it but I give you 200 points for your effort
Hands on would have been much better.
Regards Merete
0
 
centervConnect With a Mentor Commented:
WEBuilder
As said, unusual for this to go this long with no resolution.
For me the next step would be to pop in a new drive, unplug other and install windows on new drive.
This would determine if there's a hardware problem, and if not, then the older windows version has
problems beyond repair and continue reloading the rest of the software.
Whichever way you go, best of luck.
0
 
MereteConnect With a Mentor Commented:
WEBuilder hooray
That's excellent to hear, finally,
 I did suggest that you look into internet explorer Fonts in my lengthy comment.
I even looked at the ignore settings
Yes I can believe it is difficult to move files that windows explorer uses,
Control Panel\Appearance and Personalization>Fonts> choose Preview/Delete/ or show and Hide Fonts
Well done.
Regards Merete
0
 
Lev SeltzerAuthor Commented:
Thank you for all your help. I am accepting my comment as the solution because someone on a different forum suggested it, and I was able to correct the problem based on teh suggestion. I appreciate all your help, and I have split the points between everyone that has offered a suggestion.
0
 
MereteCommented:
WEBuilder did you feel we didnt give you excellent asistance, why the  3.8 rating?
0
 
Lev SeltzerAuthor Commented:
I do not remember selecting 3.8. I was given lots of advice and I thanked everyone and distributed points to everyone.
0
 
MereteCommented:
Righto.
Sometimes we just dont have all the answers and that rating just felt like you were dissappointed or somethng.
Thanks for coming back though.
Best Wishes
Merete
0
 
Lev SeltzerAuthor Commented:
Sorry that it seemed like I was disappointed.
I do not remember selecting a grade. I do remember spending many minutes trying to distribute the points evenly.
0
 
AntimidasCommented:
Sorry for jumping into the loop this late in the game.  I really wish I saw your issue previously.

This is a problem that we have been running into continually  I work for a Fortune 500 company that provides a portal framework for clients to be able to view financial information.  When our clients navigate to specific pages using Windows 7 and IE9, a blank page is displayed.  This is specific to this browser/OS combo.

We cannot ask our clients to remove fonts or change system settings, so we are determined to find a solution from the server side.  Our initial workaround was to add a header tag to the HTML to force compatibility mode on for those pages where clients reported issues.  This circumvented the issue, however, this was not the ideal solution.

Further research through the MSDN forums reveals that IE9 in particular has an issue with Type 1 fonts installed on client computers.  Iti s a reported bug in IE9 that Microsoft is aware of yet does not plan to fix.  A client could remove all Type 1 fonts and resolve the problem.  However, the better solution is a modification of CSS files on the server side to remove reference to Helvetica and instead use Arial or Verdana. (one such complaint: http://oddballupdate.com/2011/08/13/internet-explorer-9-helvetica-type-1-and-you/)

We are still in testing after modifying CSS files in lower environments, and results look very good.  The sites are now using Arial and rendering properly within the browser.

The problem is in getting all web developers to remove reference to Helvetica in CSS as a matter of practice.  I do not think this is likely nor feasible.  That leaves clients with only two options: 1) turn on compatibility mode, or 2) uninstall all Type 1 fonts.

Hope this helps!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.