• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 332
  • Last Modified:

Exchange 2007 Home Server Can't send Mail!

I owned a exchange 2007 home server box for testing and to aid my work at school, the ip address stayed same ever since the server built back in 2010 & everything is working great!

Last week the server restarted due to power issue and some ports was reset from the router too., I manually placed these ports (included enabled firewall) into the linksys router and everything is working fine except i couldn't send mail! (received email no problem)

I read couple of post here at EE and made sure Send/Receive Connectors plus telnet setting are properly in-placed, I can send email to Gmail and Yahoo BUT some vendors including Sbcglobal, Charter and School Email send failed?!

I check my server on most spam sites and wasn't listed - except Charter or maybe SBC... I don't know and am not sure how to resolve this due to it's not a commercial location on my box
(it does works for me for the whole time.)

I may not have done everything right due to my lack of experience in 2007 or should I indicate NO experience at all - my 1st server box!

I need advise & direction on how to make it work just like this box used to before!
(see also attachment enclosed)

Please! & Thanks,
howien
Delivery-has-failed-to-these-rec.docx
0
howien
Asked:
howien
  • 6
  • 5
1 Solution
 
Rob WilliamsCommented:
This normally means you are being blocked and considered a possible spamer. If you can send to any domain, this is probably the case and not related to an Exchange problem.

Did your IP address change through all of this? If so your new IP may be have been in use by someone else who was spaming, or it may be on a list of dynamic IP ranges. Some sites block these. I assume if you have a dynamic IP, you did not have a reverse DNS record but if so and the IP changed that could cause similar problems.

Your best bet is to set up a smarthost and send mail that way. It is located under SBS console | network | connectivity | start the wizard and enter your ISP's smtp server name.
0
 
howienAuthor Commented:
Hi RobWill:

I do and i tried using smarthost and i didn't help but maybe i didn't do it right?
I ran the smarthost configuration and manually enter the FQDN, user name and password - was that all or should there be more steps I needs to be modify the authentications from the EMC / EMS?!?!

Forgive me if I am off-track on my question and appreciated for quick reply on this sunday,
btw you had helped me before thanks! - :)

howie
0
 
howienAuthor Commented:
the IP address hasn't been changed at all and still the same, sorry i forgot to answer... Do i need to setup a DNS Reserve look up and how?

I meant smtp / server name, user name and password on the smarthost from my answered above!

howien
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Rob WilliamsCommented:
Normally you just run the wizard and do not need to add a username and password. If your ISP requires authentication you do need to add the username and password. Also if the ISP requires you use, SSL, or custom ports there are  additional steps.

A reverse DNS is set up with your ISP and you must have a static IP. One of the reasons to use a smarthost is the inability to set up a Reverse DNS record.
0
 
howienAuthor Commented:
Ok
So in that case I should contact Charter Comm which is my ISP for Smarthost information.,  isn't Charter the one who blocked me?

About SSL, I purchased a Certificate from godaddy would that work and I still haven't figure out how to work it yet!

Custom ports, i can't seem to change it from port 25 by executed a EMS command - it stayed the same after executed: (any idea?)

see below

thank U Sir!
howien
-----


[PS] C:\Windows\System32>Set-SendConnector -Identity "Windows SBS Internet Send
SERVER" -PORT 10025

[PS] C:\Windows\System32>Get-SendConnector | fl


AddressSpaces                : {smtp:*;1}
AuthenticationCredential     :
Comment                      :
ConnectedDomains             : {}
ConnectionInactivityTimeOut  : 00:10:00
DNSRoutingEnabled            : True
DomainSecureEnabled          : False
Enabled                      : True
ForceHELO                    : False
Fqdn                         : remote.servername.com
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : SERVER
Identity                     : Windows SBS Internet Send SERVER
IgnoreSTARTTLS               : False
IsScopedConnector            : False
IsSmtpConnector              : True
LinkedReceiveConnector       :
MaxMessageSize               : 10MB
Name                         : Windows SBS Internet Send SERVER
Port                         : 25
ProtocolLoggingLevel         : None
RequireTLS                   : False
SmartHostAuthMechanism       : None
SmartHosts                   : {}
SmartHostsString             :
SourceIPAddress              : 0.0.0.0
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {SERVER}
UseExternalDNSServersEnabled : False

AddressSpaces                : {SMTP:*;1}
AuthenticationCredential     :
Comment                      :
ConnectedDomains             : {}
ConnectionInactivityTimeOut  : 00:10:00
DNSRoutingEnabled            : True
DomainSecureEnabled          : False
Enabled                      : True
ForceHELO                    : False
Fqdn                         :
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : SERVER
Identity                     : INSIDE
IgnoreSTARTTLS               : False
IsScopedConnector            : False
IsSmtpConnector              : True
LinkedReceiveConnector       :
MaxMessageSize               : unlimited
Name                         : INSIDE
Port                         : 25
ProtocolLoggingLevel         : None
RequireTLS                   : False
SmartHostAuthMechanism       : None
SmartHosts                   : {}
SmartHostsString             :
SourceIPAddress              : 0.0.0.0
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {SERVER}
UseExternalDNSServersEnabled : False


[PS] C:\Windows\System32>
0
 
Rob WilliamsCommented:
>>" isn't Charter the one who blocked me?"
The message may have come from Charter, though I don't see that, but the message would have been blocked by the recipient.

>>:About SSL, I purchased a Certificate from godaddy would that work "
Totally different issue and unrelated. That is for connecting to your server with RWW, OWA, and smartphones. However if interested, assuming you have a dynamic IP you need to first set up a DDNS service and then you can add your Godaddy Certificate (see end of article for certificate).
http://blog.lan-tech.ca/2011/10/30/using-ddns-services-with-sbs-20082011/
Again, this is not related to your current problem.

By SSL I meant some ISP's have requirements when connecting to their smtp server. Some have none, some require username and password, some use SSL, and some use non-standard ports. To change the port see:
http://msmvps.com/blogs/cgross/archive/2009/03/09/specifying-a-custom-port-for-smarthost-communications-in-sbs-2008.aspx
0
 
howienAuthor Commented:
RobWill,
I appreciated the unrelated input and link.,
I will open a ticket for another issue - such as the port 25 won't changed for me on my Box?!

this ticket will close once I return from dinner,

thanks again!
howien
0
 
Rob WilliamsCommented:
So
set-sendconnector –identity "Windows SBS Internet Send ServerName" –port xxxx
is not working for you when you substitute your connector name and port?
Are you using the Exchange Management shell and not a standard DOS window?
Try right clicking on it (under all programs | Microsoft Exchange Server 1007 | Exchange Management shell) and choose run as administrator.
0
 
howienAuthor Commented:
That, Exactly what I've done in many attempted - Yes, I ran with EMS not Dos -
Do you have any idea why ? (see my posted earlier on EMS resulted

Howien
0
 
Rob WilliamsCommented:
I am sorry but I don't know why it won't accept the changes. What port is it you want to use?
0
 
howienAuthor Commented:
Don't need Apology I will close this now - i forgot last night, thanks RobWill!
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now