[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

How to configure mx records so that I can receive and send emails from my new exchange server

Posted on 2011-10-30
30
Medium Priority
?
1,611 Views
Last Modified: 2012-08-13
I just set up Exchange Server 2010. I also have a 2008 server running my DC.

I have configured everything that I believe is needed on the exchange end. Where I am confused is on the MX side.

I got my MX records from hostgator (host my email). They gave me A records and cname records with an Ip address. I have a host record created on the server which of course is done automatically.

I created a MX record and put in my FQDN and server priority of 0. I am not sure if i need to be using the ip address giving by my email host provider and if so where do i enter that info. Do i create a host record with that ip and create a mx record to point to that host record?

Can someone please help out. I need this up and running asap. I will be standing by waiting for some help. I am new to exchange so please be specific when replying thanks.

Thanks in advance.
0
Comment
Question by:vmagan
  • 17
  • 10
  • +2
30 Comments
 
LVL 21

Expert Comment

by:Papertrip
ID: 37054742
Your MX record needs to be the incoming mail servers that hostgator provided to you.  Don't use the IP, but rather use the hostname that they provided to you.

If the MX record(s) they provided you have a domain of your own (ie: mail.yourdomain.com), then yes you will need to create A record(s) for any of those hostnames, then point your MX record(s) to those hostnames.
0
 
LVL 9

Expert Comment

by:mmusurlian
ID: 37054751
Well, in general, the way it works is like this:

you have the domain of  testdomain.com -- you would create the following records (on external DNS server) or with DNS host:

1) A record similar to the following: mail  pointing to external Ip of exchange
2) MX record for mail.testdomain.com - pointed to external IP of exchange (lowest priority wins) default is 10
3) PTR record for MX (using configured by ISP = external IP resolves to FQDN of MX record

does this help?

Cheers!
0
 
LVL 6

Author Comment

by:vmagan
ID: 37054774
they provided me with a few domains two of them being (using same ex) testdomain,com and mail.testdomain.com

Should i be creating a host record for one of these and mx record?

Also, exchange server and DC are the same server. I know its not recommended but $ is tight right now.
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 6

Author Comment

by:vmagan
ID: 37054776
also this is created in forward lookup zones right? on the sub folder with the domain name not the _msdcs.domain name?
0
 
LVL 9

Expert Comment

by:mmusurlian
ID: 37054790
your records would be created in the forward zone

lets say the domain is acme.com and the IP for exchange is 100.200.10.1

and you want to reference you mail server by mail.acme.com

you would likely have records like this:

A record for mail pointing to 100.200.10.1
MX record for mail.acme.com pref 10
PTR (reverse DNS) for 100.200.10.1 resolves to mail.acme.com (this would be done by ISP though)

does this help?
0
 
LVL 6

Author Comment

by:vmagan
ID: 37054868
ok so i have a A record that says example-dc (with the ip address of the dc, which is also the exchange server)
and a mx record that under host or child domain: i put mail.example.com (that's the info i got from the mail host provider) and the FQDN i just browsed to the DC. Server priority is set to 10.

IS there anything else that is missing? I sent several messages  and they are still stuck in the queue, do i have to wait the 24-48hrs? or am i missing something else?
0
 
LVL 6

Author Comment

by:vmagan
ID: 37054912
I send test emails from my yahoo to my example.com email address and it still going to the old host.
0
 
LVL 9

Expert Comment

by:mmusurlian
ID: 37054947
when did you change SPs? It sounds in part like you are having DNS resolution issues . This is common with ISP and DNS changes because of changes to DNS servers , Records, etc because of the existing TTL (time to live) of your current records (typically 48 + hrs) by default.

Have your DNS nameservers changed? what is the current TTL of your records?

If you run a diagnostic (smtp test) from http://www.mxtoolbox.com what are the results?
0
 
LVL 6

Author Comment

by:vmagan
ID: 37054963
I created this exchange server and DC this morning. The TTL is set to 4hrs according to toolbox. DNS servers have not changed again because this is a new DC\Exchange server that i configured this morning.

these are the results from the smtp test

220-gator1595.hostgator.com ESMTP Exim 4.69 #1 Sun, 30 Oct 2011 22:45:47 -0500 We do not authorize the use of this system to transport unsolicited, and/or bulk e-mail.
 OK - 216.172.179.126 resolves to 7e.a0.acd8.static.websitewelcome.com
 Warning - Reverse DNS does not match SMTP Banner
 0 seconds - Good on Connection time
 Not an open relay.
 0.140 seconds - Good on Transaction time



Session Transcript:
HELO please-read-policy.mxtoolbox.com
250 gator1595.hostgator.com Hello please-read-policy.mxtoolbox.com [64.20.227.133] [0 ms]
MAIL FROM: <supertool@mxtoolbox.com>
250 OK [31 ms]
RCPT TO: <test@example.com>
550-(please-read-policy.mxtoolbox.com) [64.20.227.133]:56995 is currently notpermitted to relay through this server. Perhaps you have not logged intothe pop/imap server in the last 30 minutes or do not have SMTPAuthentication turned on in your email client. [62 ms]
QUIT
550-(please-read-policy.mxtoolbox.com) [64.20.227.133]:56995 is currently notpermitted to relay through this server. Perhaps you have not logged intothe pop/imap server in the last 30 minutes or do not have SMTPAuthentication turned on in your email client. [16 ms]


It is still pointing to the old mail host provider.
0
 
LVL 9

Expert Comment

by:mmusurlian
ID: 37054978
which portion is pointed to the old provider?

Who is old?  Who is new? I am not trying to be redundant -- just want to make sure we are clear here.. who do you want to be pointing at ? are you using a smarthost type setup? or are you your own host?
0
 
LVL 6

Author Comment

by:vmagan
ID: 37054987
Hostgator is the current provider. I am not my own host do I need a smart host type setup?

I thought since I owned the domain that I could set it up on my new exchange server, I guess I'm wrong?
0
 
LVL 9

Expert Comment

by:mmusurlian
ID: 37055009
no.. if hostgator is your host, you just need to make sure they have the proper records, if they are providing records, you will use the FQDN of the records they give you and make sure the proper IPs are pointing to those records. what do you get for the following records if you run an nslookup against your domain?

A =  record for fqdn of mail server (ex. mail.domain.com)
MX = domain.com

are the IPs correct on  the lookup ? If not, they would need to be changed to the correct one with the DNS host
0
 
LVL 6

Author Comment

by:vmagan
ID: 37055017
I will post nslookup results in 3min
0
 
LVL 6

Author Comment

by:vmagan
ID: 37055038
When i do a nslookup i get back a default server unknow: and address is 10.10.10.40 which is my DC\exchange server.

when i do a set q=mx and put in my domain name i get back:

server: Uknown
address: 10.10.10.40

non-authoritative answer:
domain name.com mx preference =0, mail exchage =  domain name.com

domain name.com internet address = x.x.x.x. external ip that was provided by hostgator which i also pasted in previous comment.

Thanks again
0
 
LVL 9

Accepted Solution

by:
mmusurlian earned 2000 total points
ID: 37055056
ok, just to be clear we should have multiple records, even though it seems redundant... for example: if I own domain community.org and I want to send / receive mail here is what I need: We will assume I host DNS through a provider
my external IP for exchange is 1.2.3.4
I determine that the FQDN of my mail server is going to be mail.community.org (what the server is going to respond as when another mail server attempts to connect to it) you should also have the fqdn of the server as your SMTP banner on your exchange server (but we wont worry about that yet) --

1) with DNS host I have the following records in forward zones
A record ---- mail = 1.2.3.4
MX Record ---- mail.community.org -- priority 10
PTR -Reverse DNS (set by ISP) ---- 1.2.3.4 = mail.community.org

Exchange server FQDN is set for mail.community.org
Exchange has authority for community.org domain and has recipient policy for it.
Receive connector allows mail from everyone
Send connector allows exchange server to send to all domains

Let me run some checks based on your information provided..
0
 
LVL 7

Expert Comment

by:Kamalasekar Parthasarathy
ID: 37055060

Have you configured the accepted domain and send/receive connector in exchange 2010.
0
 
LVL 6

Author Comment

by:vmagan
ID: 37056761
THe receive connector is set up with two connectors. Client example.com and default example.com
under network i have all available ipv6 and ipv4 port 587 and receive mail from remote server with open ip address. 0.0.0.0 255.255.255.255

Under accepted domains i have my internal domain there.

Under send connectors -> address space tab i have an * for address with a cost of 1 fot type= smtp

I have it set to use dns "mx" records to route mail automatically.

I created another host record with the ip 216.172.179.126 that was provide by hostgator.  THen I created a mx record to point to that host record with the external ip address 216.172.179.126. and the fqdn is example.com.example.local (example.com is what i got from hostgator that was associated with the ip address.

under com zones i have two records. A MX record that says mail.example.com.example.local with a priority of 10. and a host A record with example.com.example.local and the FQDN and an ip of 216.172.179.126.

Let me know if you have any other ideas.
0
 
LVL 9

Expert Comment

by:mmusurlian
ID: 37057188
Sounds mostly like default connectors -- you will want one that is something like INBOUND from INTERNET and set it up for the internal IP of your server -- on port 25 from 0.0.0.0 - 255.255.255.255 and under the perm groups tab - anonymous and the fqdn would be the same as your mx record.
0
 
LVL 6

Author Comment

by:vmagan
ID: 37057478
Under Use these local ip addresses to receive mail:
all available ipv6 and ipv4 and I added my internal ip address which is 10.10.10.90 on port 25.
Under receive mail from remote server that have these ip addresses i have :
start address: 0.0.0.0 and end address: 255.255.255.255

These settings are under default connectors

Under permission groups I have Exchange users, exchange servers, and Legacy exchang eservers checked off. Anonymous and Partners are not checked.
0
 
LVL 6

Author Comment

by:vmagan
ID: 37060279
anymore ideas?

I am ready to give up on this and just stay with a hosted account. I dont believe this is such a headache
0
 
LVL 9

Expert Comment

by:mmusurlian
ID: 37061346
Ok, lets go back to beginning here for a second..lets just confirm a few things...

1) your router is set to allow 25,443 from anyone from the outside and  NAT port 25,443 down to your exchange server(also 80 if you are going to use a OWA redirect of any kind)

2) You have an accepted domain configured -- Under Organization Config -- hub transport -- you will need to define your external domain name here to allow the server to have authority to receive mail for your domain

- Can you send receive mail internally ok? Just outside having trouble?

3) Also under OC - HT - you will want email address policies configured - as well as Send Connector (Something like OUTBOUND TO INTERNET) - specify the fqdn of your mx record for HELO EHLO - Address Space should be type SMTP - Address (*) - Cost 1 -- Network - Use MX to route - Source Server should reflect the hostname of your Exhcnage Server and show the roles configured

4) Your Server Config - Hub Transport
Client <servername>
Default <servername> should both be enabled and should not need to be modified - they were created by default

Create a Receive Connector Called INBOUND FROM INTERNET or something you can remember -- General - use fqdn of MX record for EHLO HELO
Network
Change "use these local IP addresses.." to show the actual IPv4 address of your server on port 25
Receive mail from remote servers that ...
0.0.0.0 - 255.255.255.255
Authentication
TLS
Permission Groups
Anonymous -- needs to be done for external receive connector (from outside)
Your two other defaults mentioned earlier take care of internal routing of email. This is for you to receive mail from outside world.

Once we have these steps confirmed we can test - use Exchange Connectivity Tester or MXtoolbox to test - We can then make sure DNS Records and entries are correct..

cheers!
0
 
LVL 6

Author Comment

by:vmagan
ID: 37062321
1) Are you talking referring to port 25,443?

2) I do have an accepted domain. I have example.local and I also have example.com
I cannot send or receive mail internally or externally

3) I have a email policy created with 1st initial and last name and I have it set to specify the custom FQDN for the email address to: example.com (no @ just example.com)

4) Client server name and default are both there and have not been touched.
I created the new receive connector and the fqdn that was on the mx record was example.com.example.local

 WHere do i find the exchange connectivity tester? Is this something built in with exchange?

When i do a search for my domain on mxtoolbox what am i checking for? THis is what i saw in mxtoolbox not sure what to look for tho.

Reported by ns3190.hostgator.com on Tuesday, November 01, 2011 at 7:38:04 AM (GMT-5)





0
 
LVL 3

Expert Comment

by:Circleblue
ID: 37062367

Remote connectivity tester:

https://www.testexchangeconnectivity.com/

test your email flow there.  
0
 
LVL 6

Author Comment

by:vmagan
ID: 37115601
These are my results from the test.

      ExRCA is testing Exchange ActiveSync.
       The Exchange ActiveSync test failed.
       
      Test Steps
       
      Attempting the Autodiscover and Exchange ActiveSync test (if requested).
       Testing of Autodiscover for Exchange ActiveSync failed.
       
      Test Steps
       
      Attempting each method of contacting the Autodiscover service.
       The Autodiscover service couldn't be contacted successfully by any method.
       
      Test Steps
       
      Attempting to test potential Autodiscover URL https://example.com/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
      Attempting to test potential Autodiscover URL https://autodiscover.example.com/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
      Attempting to contact the Autodiscover service using the HTTP redirect method.
       The attempt to contact Autodiscover using the HTTP Redirect method failed.
       
      Test Steps
      Attempting to contact the Autodiscover service using the DNS SRV redirect method.
       ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method.
       
      Test Steps
       
      Attempting to locate SRV record _autodiscover._tcp.example in DNS.
       The Autodiscover SRV record wasn't found in DNS.
0
 
LVL 6

Author Comment

by:vmagan
ID: 37126035
I verified today that the mx records were still pointing to the hosting company. I now have them pointing to my public address.

I can send an email internally but not to an external domain and i cannot receive emails from an external domain.

Port 25 is open on the router.

Any ideas?

Please help
0
 
LVL 9

Expert Comment

by:mmusurlian
ID: 37127708
While Port 25 is open on the router  I would also make sure that your NAT entries exist for your mail traffic down to your exchange server.

Also verify that your send and receive connectors are properly configured

Can you telnet to your exchange server on port 25 from the outside.

telnet <ext ip of exchange> 25
0
 
LVL 6

Author Comment

by:vmagan
ID: 37127903
I will check that but I believe that thought port 25 is open on router it might be closed on isp side. I will keep you posted.
0
 
LVL 6

Author Comment

by:vmagan
ID: 37133732
Now that i have port 25 open i can receive emails but for some reason i cannot send emails to external clients. What can i be missing.

one more question... If i wanted to setup an exchange email on lets say my phone or ipad, what would be my server name? I know its not going to be my internal server name for instance my hostname.

where would i find i guess the external server name?

thanks for all your help we are almost there.
0
 
LVL 6

Author Closing Comment

by:vmagan
ID: 37142270
There were a few issues here, but DNS was one of the biggest issues i had. Thanks for being patient and providing step by step instructions.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

With so many activities to perform, Exchange administrators are always busy in organizations. If everything, including Exchange Servers, Outlook clients, and Office 365 accounts work without any issues, they can sit and relax. But unfortunately, it…
Stellar Exchange Toolkit: this 5 in 1 toolkit comes loaded with mega-software tool. Here’s an introduction to tools’ usage and advantages:
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses
Course of the Month18 days, 5 hours left to enroll

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question