[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

win7 - remote desktop - force log off of currently logged in user

Posted on 2011-10-31
12
Medium Priority
?
3,625 Views
Last Modified: 2012-06-21
when I (as an admin) try to remote desktop to a users computer is there a way to force the currently logged in user off?
I am getting the message:
"another user is currently logged into this machine, if you continue the user has to disconnect"
I want to be able to force log them off and log in as me.
Fast user swicthing is disabled.
0
Comment
Question by:Pete
  • 6
  • 3
  • 2
  • +1
12 Comments
 
LVL 6

Expert Comment

by:Azhrei1
ID: 37055982
If you continue the log in, it will force the currently logged in user off. Another option would be to start an MMC for Remote Desktop session administration on a server machine, connect to the client in it, and force logoff from there.

If you both log in at the same time, you can simply do it from the task manager.
0
 
LVL 1

Author Comment

by:Pete
ID: 37056000
thanks, it does indeed force the user off but is there a way to reduce the 30 second timeout?
0
 
LVL 6

Expert Comment

by:Azhrei1
ID: 37056021
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 
LVL 27

Expert Comment

by:Jason Watkins
ID: 37056072
Careful here, if the person on the other end has unsaved work, they could lose it. This can be more trouble than it is worth.
0
 
LVL 1

Author Comment

by:Pete
ID: 37056101
I am confused, the policy settings in the link talk about remote desktop sessions but the users I am trying to log off (and lower the 30 second timeout) are not using RDP, they are simply logged in locally. Why do I need to change these RDP timeout policy settings?
0
 
LVL 6

Expert Comment

by:Azhrei1
ID: 37056478
Yes, but you're connecting through RDP, I'm not 100% sure, but it seems like the same timeout comes from there...but I'd have to test and mess with it as well to make sure. It should definitely be in the registry or GP somewhere on the client pc you're connecting to.
0
 
LVL 1

Author Comment

by:Pete
ID: 37056709
The link advice does not seem to work.

I have enabled
"Set rules of remote control of remote desktop services" witch lets you specify the interaction mode and the control level for an RDP session, enabled it and choose the "Full control without user permission" option. so the logged user won't be prompt for confirmation.

Connecting as admin gives the same message to the currently logged in user and 30 second count down. Any timeout values I can see do not seem to relate to this 30 second delay on connection.
0
 
LVL 1

Author Comment

by:Pete
ID: 37061156
are there any ideas Azhrei1?

thanks
0
 
LVL 1

Accepted Solution

by:
NewtonGreen earned 2000 total points
ID: 37074703
A possible workaround:

If you don't mind bending your license slightly (since you are going to log them off straight away, I can't see the harm), there are illegitimate ways to log on instantly where the other account will not be logged off, they will stay connected. You can then go into task manager and log them off.

Google 'concurrent win7'.

0
 
LVL 1

Author Comment

by:Pete
ID: 37091284
if I leave the other user logged in and i need to install software etc will the os allow me to do that?
this seems like a great idea, I can test from that workstation without taking it out of use. I need not bother logging off the other user!
0
 
LVL 1

Expert Comment

by:NewtonGreen
ID: 37091461
Yes it will. At worse if something is open that it needs shut down (eg. IE) it will do the usual prompting. Win7 is basically running as a Terminal Server so similar rules apply.

nb. This patch is obviously not supported by MS and could break in the future..
0
 
LVL 1

Author Comment

by:Pete
ID: 37092642
OK, I will look at that but lastly back to the original question, which GPO can I set to reduce this 30 second timeout when connecting? I can not see any GPO ref. in the Q earlier that does this.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Suggested Courses

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question