Problem with SilverLigth WebPart

Hello. I deployed .xap into   /_catalogs/masterpage/ClientBin/mysligthwebpart/SilverlightWeppart.xap. As always, everything great until I realized that members of the reader group cannot load my Silverlight application. *Seems* to be a configuration issue, but I have no idea how to fixt the problem.
LVL 1
tolppaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Member_6283346Commented:
Hi! Why did you put it in masterpage gallery? I guess this is not the right place for silverlight app, so it maybe a security issue. Try to put your app in /_layouts/ClientBin/mysligthwebpart/SilverlightWeppart.xap instead (physical path is Program Files/Common Files/Microsoft shared/web server extensions/14/Template/Layouts/ClientBin).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.