• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1026
  • Last Modified:

TrueNAS and Cisco L3 LACP Etherchannel configuration

Hi- I have a new TrueNAS (FreeBSD) device and a Cisco 3560 running code c3560-ipbase-mz.122-25.SEB4.bin that I need to have configured as L3 LACP Etherchannel. Oddly enough the TrueNAS support people didn't have any suggestions since they don't work with a lot of Cisco devices. That seems to be an odd statement but that's what I got. I configured the TrueNAS device with a port-channel address of 192.168.50.38 and the Cisco switch with a port-channel address of 192.168.50.40. They can talk to each other but not to another on any subnet. The following is my switch configuration which links up correctly as shown by "show etherchannel summary". What am I missing? Many thanks in advance!

interface GigabitEthernet0/7
 description TrueNAS-Virgo
 no switchport
 no ip address
 channel-protocol lacp
 channel-group 1 mode active

interface GigabitEthernet0/24
 description TrueNAS-Virgo
 no switchport
 no ip address
 channel-protocol lacp
 channel-group 1 mode active

interface Port-channel1
 description TrueNAS
 no switchport
 ip address 192.168.50.40 255.255.255.0
end

Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(RU)         LACP      Gi0/7(P)    Gi0/24(P)
0
merker19
Asked:
merker19
  • 2
  • 2
1 Solution
 
FrabbleCommented:
Bacause you've used L3 LACP, the network between is a stub network off the 3560 and the TrueNAS device will need the 3560 address, 192.168.50.40, as its default router/gateway. To talk to other networks you need to do whatever routing configurations; static, protocol entries you use, to allow to and from the other networks.
0
 
merker19Author Commented:
Thanks Frabble. Your response made a lot of sense. I tried to configure routing on my switch but it gave me an error that basically said that EIGRP is not supported on the version of code that I'm running. So I moved it to the core switch and configured it accordingly:

TrueNAS lagg0: 10.10.10.2/24 with a default gateway of 10.10.10.1

interface GigabitEthernet0/38
 description TrueNAS
 no switchport
 no ip address
 channel-protocol lacp
 channel-group 1 mode active

interface GigabitEthernet0/40
 description TrueNAS
 no switchport
 no ip address
 channel-protocol lacp
 channel-group 1 mode active

interface Port-channel1
 description TrueNAS-Virgo
 no switchport
 ip address 10.10.10.1 255.255.255.0

TrueNAS and the port-channel could ping each other. The switch could ping each side of the L3 LACP Etherchannel interface and since routes existed on the core switch, the TrueNAS knew how to contact the other networks and vice versa. Excellent.

My preference would have been to address the NAS on the NAS we created - 192.168.50.0/24 but I get the error when I address the port-channel to an ip on that subnet "192.168.50.0 overlaps with Vlan50" Is there a way around this? Thanks!
0
 
FrabbleCommented:
Thanks for the points. To finish off, you can't give an interface an address in a network already configured on another that is active.
The way round it for you is to configure the port channel as layer 2, access mode, on the switch and let the routing be done by the SVI as wanted. I'n assuming you pass VLAN 50 traffic through the switches involved.
You'll need to re-create the port channel as layer 2 by removing the channel group from each of the interfaces and then no interface po1. Configure each of the ports for switchport and channel group 1 mode active, then configure interface po1:
switchport mode access
switchport access vlan 50

Gateway for the NAS will be Vlan50 address.
0
 
merker19Author Commented:
This sounds like my previous L2 Etherchannel configuration. =)

Thanks for the reply. TrueNAS Support seems to favor the L3 LACP Etherchannel configuration but I honestly don't see a performance difference between the L2 and L3 configuration that I had setup.
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now