[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Why can't I print to my HP Deskjet 6840?

Posted on 2011-10-31
6
Medium Priority
?
537 Views
Last Modified: 2012-05-12
I have an HP Deskjet 6840 connected wirelessly to my LAN.   I can print to it from other computers in the domain, but not from this one.   Some run Windows 7, others run XP.   I can connect to it using a browser, but cannot print a test page.   I have tried disabling Windows firewall, but it makes no difference.
0
Comment
Question by:DoctorK12008
  • 3
  • 2
6 Comments
 
LVL 39

Expert Comment

by:hdhondt
ID: 37060644
What happens when you print? Do you get any error messages? Do the lights flash on the printer, telling you it's receiving data? Do you print via a server, or direct to the printer (via a Standard TCP/IP port)? Which driver do you use? Which operating system are you using?
0
 
LVL 93

Accepted Solution

by:
nobus earned 2000 total points
ID: 37061662
try uninstalling the printer completely form your pc -then reinstall with latest driver -pick the correct OS version :
http://h10025.www1.hp.com/ewfrf/wc/softwareCategory?product=385458&lc=en&cc=us&dlc=en&lang=en&cc=us
0
 

Author Comment

by:DoctorK12008
ID: 37062244
WIndows 7 Professional 64-bit.   The printer shows up in Devices & Printers with an exclamation point.   No messages appear when I try to print.   No lights flash on the printer.   I print direct to the printer.   How do I completely remove the printer?   If I do this and try to delete the TCIP/IP port, it says the port is still in use.
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
LVL 93

Expert Comment

by:nobus
ID: 37063748
>>  The printer shows up in Devices & Printers with an exclamation point  <<  that means a corrupt install
i believe you connect over lan?
for the uninstall here instructions :  http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm
0
 

Author Closing Comment

by:DoctorK12008
ID: 37067105
Instructions worked perfectly.   I had tried to shortcut the process by leaving ou the wired connection.
0
 
LVL 93

Expert Comment

by:nobus
ID: 37068178
tx for the feedback - useful
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
In this article I will be showing you how to subnet the easiest way possible for IPv4 (Internet Protocol version 4). This article does not cover IPv6. Keep in mind that subnetting requires lots of practice and time.
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
In a question here at Experts Exchange (https://www.experts-exchange.com/questions/29062564/Adobe-acrobat-reader-DC.html), a member asked how to create a signature in Adobe Acrobat Reader DC (the free Reader product, not the paid, full Acrobat produ…
Suggested Courses

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question