[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 512
  • Last Modified:

Web.Extensions 3.5 conflicts with 1.0.61025

Hi,

I have installed both vs 2010(.net4.0) and vs 2005(.net2.0).
.net 4.0 working correctly. When  i build the .net 2.0 projects gets error below.

First installed .net4.0(vs2010) then installed .net 2.0(vs 2k5)

The type 'System.Web.Script.Services.ScriptMethodAttribute' exists in both
'c:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\projectking.web\5437aa02\ea21bcc0\assembly\dl3\76285535\0045f8b2_18dcc801\System.Web.Extensions.DLL'
and 'c:\Windows\assembly\GAC_MSIL\System.Web.Extensions\3.5.0.0__31bf3856ad364e35\System.Web.Extensions.dll'      

Ambi-DLL-Version.png
0
sunilpasupunuri
Asked:
sunilpasupunuri
  • 2
1 Solution
 
JustAndreiCommented:
Please check whether your project references both assemblies.
0
 
sunilpasupunuriAuthor Commented:
I have added this System.Web.Extensions.dll  dll files externally. Not through add reference. Because there is different version(higher) there. So i have added manually into bin folder.  Please attached the screenshot
DLL-Versions.png
0
 
JustAndreiCommented:
I don't think it's a correct way.
You should create a .net 2.0 project that references right assemblies.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now