Terminal Server Session Printer Redirecting issues

Folks,
i am wondering if someone could please help me.

I have a TS server 2008 at work and we have the owners wife that logs in from home and when she logs into the TS Server she wants to be able to print to her printer at home that is visible in printers as a redirect printer.

The problem is that when she logs in she not only sees her redirect printer she sees redirected printers from everyone else sessions, sometimes for some reason there are 30 there, seems like there is 5 of every printer.

How do i turn off the redirecting of other TS users so that she sees her printer from her session.

I hope this makes sense.

thisonehasmestumpedAsked:
Who is Participating?
 
thisonehasmestumpedAuthor Commented:
Moomin83,
http://technet.microsoft.com/en-us/library/cc731963%28WS.10%29.aspx

i found this and it seems to work for all users, it needs to be a default printer on the local machine but it works good.

Thanks for the help
0
 
Moomin83Commented:
Hi

There are multiple solutions depending on your Network setup.
Option 1
If your printers are IP based I would suggest creating AD groups ( Printer A, Printer B etc. - or whatever naming convention works for you)
Install these printers "manually" - Local printer, but specify the IP.
Assign the corresponding AD groups to the printers in question - Assign access for group "Printer A" to "Printer A"
remove the "Printers" selection from the "Local devices and resources" section
 RDP1When the users log off completely (Not disconnect) and log back in they should only see the printers that they have access to (Deny the boss' wife access to the other printers). After hours remove all the "session printers" - this provides a cleaner view and manager easier.
When she logs in she should only see her printer that gets mapped automatically - Alternatively...
Option 2 (I got this to work in Server 2003)
Disable printer mapping on the server. Open "Remote Desktop Session Configuration". Right click on RDP-Tcp, select properties, proceed to the "Client Settings" tab and un tick printer mapping..
 RDP2When the Boss' wife is connected to the "VPN" (assumption on how your network operates) from the server select start and then run
\\Boss' wife's computer name\ press enter  (for this to work ensure that her printer is shared on her computer)
Proceed to right click on her printer and select install (ensure you have the required drivers available)
Only grant her access to this printer

Either or it sounds like effort - It would suggest option 1 regardless of the Boss' wife's printing problem as it makes managing the printer easier for you.
0
 
thisonehasmestumpedAuthor Commented:
awesome response and very thorough, i will give it a go and let you know

thanks for the quick reply
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Moomin83Commented:
on option 2 I made a typo (actually a few in the doc) but, in "Remote Desktop Session Configuration" you MUST tick windows printer to disable and not un-tick like first mentioned. sorry
0
 
thisonehasmestumpedAuthor Commented:
Moomin83,
The printer is actually installed on her local machine by USB and she doesnt run off a VPN, any other ideas?

0
 
Moomin83Commented:
How does she connect to your TS server? Via TS web? The printer I connected for our user on vpn was also USB, I just had to share the printer. Also worth mentioning is that the pc on my side was part of our domain
0
 
thisonehasmestumpedAuthor Commented:
please see above comment
0
 
Moomin83Commented:
Glad you found a working solution. :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.