Office 12.0 Access - OLE DB Provider Not Listed in my Delphi Application (using ADO)

Hi,

I am trying to import data from MS Access 2010 using...

           Provider=Microsoft.ACE.OLEDB.12.0.

I have written a large delphi application uing tADOConnection to import data from external applications.  When I run my program on my PC and open up the "Data Link Properties" then the above provider is not listed.

But if I run MS Excel 2010 it is listed as one of the providers.
Also when I test my program on another PC it is listed as one of the providers.

So what do I need to do to my PC to get this provider made available to my application.

I tried downloading and installing the driver from here...
http://www.microsoft.com/download/en/details.aspx?id=23734
Data Link Properties
LVL 1
enigmasolutionsAsked:
Who is Participating?
 
mlmccConnect With a Mentor Commented:
If it works on 1 64-bit Win7 PC and not another I wold suspect there is some difference in how it is installed on configured.  Did you configure it to run in 32-bit mode?

mlmcc
0
 
peter57rCommented:
Can't say for sure but this sounds like it might be a 'bit-ness' issue.
Is your app being built in a different bit-ness from the version of Office you have installed?
0
 
mlmccCommented:
It might be that.

I know with Crystal Reports we have to use the ODBC drivers MS provided.  They never provided an OLE driver for MS Access or Excel for Office 2007 or 2010 if we want to use files in the new format as accdb or xlsx.

mlmcc
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
enigmasolutionsAuthor Commented:
Thanks for the ideas.

I don't know what "bit-ness" is but we compile our application on two different PCs... on one PC it works on the other it does not.  The Delphi App is compiled to 32-bit.  Both PCs are running Win 7 64 bit.

Long shot... Is there some check in the registry I could look for???

mimcc, I was think along those lines, which is why I downloaded the MS ODBC drivers and instaleld them.

Still Stumped...
0
 
enigmasolutionsAuthor Commented:
I agree it has to be a difference in how it was installed.

How do you configure the "Microsoft.ACE.OLEDB.12.0." provider to run in 32-bit mode?

0
 
CodeCruiserCommented:
See if downloading and installing 32 bit version(top one) from here helps

http://www.microsoft.com/download/en/details.aspx?id=13255
0
 
enigmasolutionsAuthor Commented:
Sorry for the slow response...

The 32 bit would not install - because I have "64-bit Office products installed".
0
 
enigmasolutionsAuthor Commented:
Wow.  That's strange.  

When I tested my application today the provider now appears in my application.

Gosh, I guess all I had to do was reboot my PC.

I am sure I tried that.
0
 
enigmasolutionsAuthor Commented:
mimcc,

You get the points.  

I suspect the re-install of the driver fixed the problem after rebooting.

Who knows...?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.