• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1794
  • Last Modified:

Windows 7 PPTP VPN not using VPN DNS servers

We have a small branch office with a Windows 2003 server setup there.  It is running RRAS with a simple PPTP VPN setup.

It works just fine, and users are able to connect to it just fine using Windows XP.

However, we have one user there with Windows 7 at their home.  They can connect just fine but even if I manually set the DNS servers for their PPTP connection the windows 7 machine will continue to try and use the local ISP at their house for DNS resolution (in this case resolver.qwest.net).

I have done my own 5 minutes of research and found some mention of changing the linkage subkey in the registry and making sure the NDIS\WanIP is at the top of the order and/or the GUID for the PPP adapter is at the top.  I did this, but still no luck.

Use Default Gateway on Remote Network has been checked and unchecked, and almost all of the TCP/IP settings have been messed with to see if anything helps.  No luck.

ping and browsing after connecting to the VPN by IP works just fine, it's just that the client refuses to use the DNS servers at the office once connected.

I've also tried doing nslookup and setting the server to one of the DNS servers at the branch office and querying but I get "server failed" on any query.


Any help is appreciated.  If EE can't figure this one out I'll just open a ticket with MS and let them deal with it.
0
TheCleaner
Asked:
TheCleaner
3 Solutions
 
wolfcamelCommented:
i have seen this sometimes if the home IP range is similar to the work Ip range.
0
 
TheCleanerAuthor Commented:
wolf,

Not the case here.

Home IP range is 192.168.1.x/24
Work/VPN IP range is 10.30.10.x/24

0
 
isaman07Commented:
You can solve this by manually entering the desired DNS server IP addresses in the VPN connection properties, under networking, Internet protocol tcp/ip 4 properties.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
TheCleanerAuthor Commented:
Tried that isaman07.  Even set a static IP and static dns suffixes.  The connection still sets their isp's dns server as the first dns server to query.  The only "fix" that works is host entries.
0
 
isaman07Commented:
Just tried it in my lab and it uses the manually entered DNS server by default. Can you give it a go? dial your vpn and then perform an nslookup, see what is the returned IP of the server.
0
 
TheCleanerAuthor Commented:
Did that...nslookup shows resolver.qwest.net as the default DNS server, even if I manually enter DNS servers.

I have Windows 7 on my machine and it works fine.  It must be something unique to Windows 7 Home or something semi-unique to him.

Here's example urls I've found:

http://www.hideipvpn.com/2009/09/dns-issues-on-pptp-vpn-connect/
http://support.microsoft.com/kb/942440
http://support.microsoft.com/kb/311218
http://www.hydrous.net/weblog/2009/10/28/force-windows-to-use-a-vpns-dns-server

I've tried those fixes as well...no joy.  It's as if something is inserting their ISPs DNS server into the binding regardless of what I do.
0
 
Rob WilliamsCommented:
Have you added the corporate DNS suffix as per:
http://blog.lan-tech.ca/2011/05/14/vpn-client-name-resolution-2/
0
 
TheCleanerAuthor Commented:
Rob,

Yes.  However, I've noticed that they don't stay.  If you add them they just go back to the default radio button after hitting OK and closing those settings and going back to them.

The one thing I haven't tried that would be somewhat a given is to completely delete the VPN connection and create a new one in hopes that these gremlins go away.
0
 
isaman07Commented:
Weird i tested this on a wondows 7 and it works just fine. Maybe recreating the VPN connection as you suddest will fix it?!
0
 
TheCleanerAuthor Commented:
The user tried recreating the VPN account and it still doesn't work right.  However, the user tried it on a different Windows 7 computer at his house and it works just fine.

I don't know...chalk it up to aliens.
0
 
TheCleanerAuthor Commented:
Suggestions were accurate...just not applicable here for some reason.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now