I have a Dell Latitude D830 that has a Intel wireless adapter (4965AGN) that won't enable.

I have a Dell Latitude D830 that has a Intel wireless adapter (4965AGN) that won't enable. The wireless indicator icon doesn't light up. I've changed adapters (opened up the laptop and replaced) but I still can't get the wireless to enable. The radio for the wireless won't turn on. This laptop's OS was reinstalled with Vista Svc Pack 2. In BIOS the Internal Wi-Fi is enabled. The Bluetooth light stays on regardless of whether the switch is on or off. Anyone else having this problem with Dell Latitudes?
marvingilmoreAsked:
Who is Participating?
 
edbedbConnect With a Mentor Commented:
To enable or disable WiFi, use
the wireless switch on the left side of the computer.
0
 
atipicoCommented:
Some laptops need a certain key combination pressed (such as fn + f8 in mine, it can be identified by the icons on the keyboard) in order to enable the wireless functionality. Isn't this the case here?
0
 
marvingilmoreAuthor Commented:
This laptop has a switch on the left side to turn on and off the Wi-Fi but it doesn't appear to work. There is no key combo in this case.
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
edbedbCommented:
Check the status of the adapter in the Device Manager.
0
 
atipicoCommented:
You said the laptop had its OS reinstalled. Maybe the drivers were not installed correctly afterwards. Install the latest drivers from the manufacturer's website.
0
 
AntoinevdConnect With a Mentor Commented:
Are the wireless switch and the corresponding actions enabled in the BIOS?
0
 
nobusCommented:
If your LAN is running, you can also use windows update, or drivereasy (free) :  www.drivereasy.com
let it scan, then hit Get Drivers, it will list the drivers - you can google them, or let drivereasy do it
0
 
natcomCommented:
- Right-click your Intel wireless adapter. and choose properties. Uncheck  any protocols related to your antivirus or third-party firewall.  just leave the Microsoft default protocols.
0
 
marvingilmoreAuthor Commented:
Called Dell and extended the warranty. The tech replaced the motherboard, and the switch. The wireless now works. Thanks!
0
 
nobusCommented:
that is always a solution..
0
 
marvingilmoreAuthor Commented:
A hardware problem. Needed manufacturers parts. Used and extended warranty to solve problem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.