We help IT Professionals succeed at work.

Domino 64 bit memory high usage

helpdesk_wlk
helpdesk_wlk asked
on
Medium Priority
3,296 Views
Last Modified: 2013-12-18
Hi, I recently install Domino 64 bit 8.5.3 on a new Windows 2008 R2 Standard 64 bit server.  The total memory is 6 GB. When the server starts, it uses about 3 GB, after just a couple of hours, the memory usage balloons to 5+ GB.

Anybody else experience the same problem?  Is this normal?

Thank you.
Comment
Watch Question

Sjef BosmanGroupware Consultant
CERTIFIED EXPERT

Commented:
Check this document, it contains valuable information:
http://xpageswiki.com/web/youatnotes/wiki-xpages.nsf/dx/Memory_Usage_and_Performance

But I suppose you already found the doc...
Looking at http://www.ibm.com/developerworks/lotus/library/domino8-64bit/ and http://www-10.lotus.com/ldd/dominowiki.nsf/dx/managing_64-bit_memory_in_ibm_lotus_domino_8.x

1 - you need to manage the Windows file-system cache:
Due to the dramatically increased file-system cache size on Windows 64-bit, it is necessary to constrain the file system cache on 64-bit Windows to limit its usage and to avoid taking out system memory. see IBM Technote 1377517  Constraining the file system cache on 64-bit Windows for more information.

2 - you need to manage the NSF_BUFFER_POOL_SIZE:
In Domino 64-bit , it still requires notes.ini NSF_BUFFER_POOL_SIZE_MB to control UBM memory usage, but does not require ConstrainedSHM or AddressableMem. For more information, refer to the Support Technote #1286171, Recommendations for setting NSF_BUFFER_POOL_SIZE_MB.
Drat IBM is botching their technote system.

Link to Constraining the file system cache on 64-bit Windows
http://publib-b.boulder.ibm.com/lotus/c2359762.nsf/0/C0615A5D97D34BFF852574AC005A386E will take you to the 8.0.2 Release notes, and spare you navigating.

I think it is the file system cache wich is eating memory.  Note that this is not a totally bad thing, but read the articles provided to give you insight and help you decide what will be best for your specific environment.

Please report back your progress!!

Author

Commented:
changing the setting for MEM_FSCachePercentMem helps!  I have it set to 20 percent right now.  I am gonna play around with the setting and see.  Thank you