We help IT Professionals succeed at work.

Setting Background image using group policy

Hi,

I would like to set the background image on all of our servers to be the same image for all the users. However I dont want the users desktops or or anyother computers to be affected by this.

The Servers are in an OU called Servers and the domain controllers are in the Domain controllers OU. So If I can make a change in the group policy I can just link it to these OU's

Can you tell me what is the best way of doing this?

Thanks
Matt
Comment
Watch Question

Paul MacDonaldDirector, Information Systems
CERTIFIED EXPERT
Commented:
There's already a user configuration setting in GPO to set the active desktop wallpaper to some predetermined image.  You just need to put the image somewhere all the affected machines can get to it., specify the path to the image in the GPO, then link the GPO to the appropriate OUs.
Staff Engineer
CERTIFIED EXPERT
Commented:
Yes, you need to create a gp policy and link gp which you configured for desktop wallpaper under Administrative Template “Desktop Wallpaper” Setting. If you planning to do in windows 2008 r2 then you need to install the hotfix from http://support.microsoft.com/kb/977944

Author

Commented:
I have SP1 installed on the Server 2008  r2 machines do I still need the hotfix?

Also is the setting I need to change this one:

User Configuration>Policies>Administrative Templates>Desktop>Desktop Wallpaper

The rest of the settings are set to not configured.

Also is there a way of storing the image locally on the machine or do I have to put it in a shared location?
Paul MacDonaldDirector, Information Systems
CERTIFIED EXPERT

Commented:
Yes, that's the setting.  Yes, you can store the image locally, but it will have to be in the same place on each machine (since the path in the GPO will be the same for all machines).

I believe the wallpaper problem is fixed in SP1.

Author

Commented:
I have created a folder on each machine called C:\Background Image and have put a Background.bmp image in this location but the background has not changed I have tried doing a gpupdate /force

If I do a RSOP it doesnt list the policy.
Paul MacDonaldDirector, Information Systems
CERTIFIED EXPERT

Commented:
Who are you logging in as?  Domain Admins are exempt from most policies...

Author

Commented:
I am Logging in as a Domain Admin. The Policy shows up in RSOP under the Computer configuration but not on the users configuration.

Could this just be due to me being a Domain Admin? If so I want all users including Domain admins to be able to see this background.
Paul MacDonaldDirector, Information Systems
CERTIFIED EXPERT

Commented:
Try changing the permissions on the GPO so Domain Admins are not "denied" Read permissions.

Author

Commented:
Domain Admins have the Read permission and the problem still exists

Author

Commented:
The problem is fixed now Im guessing it proberly was slow to replicate or something.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.