We help IT Professionals succeed at work.

SSRS Failure sending email subscriptions

SSRS Subscriptions have been working without a problem for the past year.  They stopped running the past 2 days.  Receive the error:

"Failure sending mail: At least one of the From or Sender fields is required, and neither was found. Mail will not be resent."

The "To" fields have a complete email address, firstname.lastname@company.com. Reporting Services Configuration Manager states the Sender Address as administrator@company.com which is a valid email address.

Is there a service I should check?
Comment
Watch Question

TallKewlOnezDatabase Administrator

Commented:
I would look at the account(s) and verify no one has changed the password.    If they have check SSRS configuration and verify that the new password is implemented. (unattended account configuration)

Author

Commented:
Checked Reporting Services Configuration Manager, Execution Account.  This page is blank, nothing is filled in.   (I do not believe it was ever used).  

Is this necessary in order to email SSRS subscriptions?

Commented:
you need to check the mail configuration in the reporting service configuration manager. There at the senders address, see if the correct address is provided or not. Again check in any of the pre-configured subscriptions what is the senders mail configured there?

Author

Commented:
Reporting Services Configuration Manager
E-mail Settings:
SMTP Settings
Sender Address:  administrator@company.com
Current SMTP Delivery Method:  Use SMTP server
SMTP server:  server name

In the SSRS subscriptions:
To:  firstname.lastname@company.com
The subscription does not contain a "From" field.

Active Directory does have a administrator@company.com

Commented:
Hope administrator@company.com is active on active directory with password settings properly set.

Can you try sending a mail to the administrator@company.com. Look whether if it fails.

Author

Commented:
The password for administrator@company.com had been changed approximately 3 weeks ago.  The subscriptions have been running successfully since then with no problem.

I tried changing the the Sender Address to my email address but the subscription still failed.  Is there a place in Reporting Services for checking/entering a sender's password?

The problem seems to have started when the server was rebooted.  What else should I be looking at?
Commented:
check in the error logs if something is being written. Also try sending a database mail from the reporting server if it works.
TallKewlOnezDatabase Administrator
Commented:
I agree (as mentioned before) check to see if you can send a test DB Mail.   Check the Operator setup in SQL Server (SSMS, Management/Database Mail, and verify you can send mail there.   You may also want to check the mail server configuration and verify that nothing was changed there (I have seen in the past that a domain wide policy change impacted email).