We help IT Professionals succeed at work.

How to remove "Network" from the Word 2010 "Open file" dialog

meirionwyllt
meirionwyllt asked
on
Users are logging in to a Windows Server 2008 R2 terminal server.  When they open the "Open file" dialog in Word 2010, and click the drop-down next to "Look in:", the menu takes about 30 seconds to appear, because it is populating the "Network" list, scanning the whole domain (about 2500 PCs) and putting all of them in the drop-down.  (By the way, I've checked for any mapped drives, and the only one I have works fine.)

I don't even want the users to be able to go into "Network", so it there a way of getting rid of this option (and also the My Network Places button) from Word's "Open file" dialog.

I've managed to get rid of "Network" from Windows Explorer, by following this article...

http://www.askvg.com/how-to-remove-network-from-windows-7-explorers-navigation-pane/

...but it doesn't remove it from Word.

Is there some more reg hacking I can do to achieve this?

Thanks.
Comment
Watch Question

Commented:
i couldn't test it , sorry but maybe you can take a look here

http://www.itechtalk.com/thread9034.html
meirionwylltSenior Desktop Engineer

Author

Commented:
Hmm, I've looked at Trusted Locations in Office 2010 before, with another problem, and it is a real PAIN trying to programmatically set this with group policy, because the registry entry that you send to the clients PCs must contain the hostname of the PC - which is impossible when all PCs have different hostnames.

So, if possible I would very much like to avoid the Trusted Locations route.

Thanks
meirionwylltSenior Desktop Engineer

Author

Commented:
I'm rather concerned about this, because this minor thing is preventing us from rolling out our brand new thin client environment.

I'll explain a little more about what's happening - we have several Windows Server 2008 R2 XenApp servers, with Office 2003 installed.  We have many users logging into each one to have a desktop, which they access via ICA through a thin clients.

All users log in with a mandatory profile, with group policy folder redirection pointing the rest of their profile (my docs, desktop, favorites) to their personal network share.

They log in, and open Word, and go to the "Open File..." dialog, but once they do that, Word 2003 automatically does some kind of Network Discovery in the background, which takes about a minute to popular (it populates every machine on our domain), but if you happen to click on the "Look in:" dropdown during that time (which most users will), then Word literally hangs until network discovery is complete - so, if they click on it straight away, Word will hang for a minute.

I don't want Word to discover the network.  "Network Discovery" is switched off in Windows' "Network and Sharing Center", so why should Word take it upon itself to ignore this and carry out network discovery?

I believe it is related to the fact that users' My Docs is relocated to a network share - but I don't want Word to discover any server other than the one which holds the user's personal network share.

Thanks.
meirionwylltSenior Desktop Engineer

Author

Commented:
I've narrowed down which folder redirection is the cause of this - and it's AppData!  When I set the AppData folder redirection to "Noti Configured", I don't get the issue.

Leaving AppData local is not an option.

Any ideas why redirecting AppData can have this effect?
Senior Desktop Engineer
Commented:
I fixed it myself.

In the AppData folder redirection properties in Group Policy, under the 'Settings' tab, I ticked the box "Grant the user exclusive rights to AppData(Roaming)", and although this is annoying for admin purposes, it fixed my problem.

The "Look in..." drop-down in Word now takes 1 second to populate, instead of 30 seconds.

Great.
meirionwylltSenior Desktop Engineer

Author

Commented:
Fixed it myself.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.